Unica curva

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#1
Buongiorno, ho costruito due curve chiuse per farne in seguito un solido multisezione ma una di queste è costituita da più curve (se volessi fare una estrusione riuscirei). Come posso rendere lo schizzo una curva unica chiusa? Grazie molte! Image 2.png
 

PiE81

Utente poco attivo
Professione: Ufficio tecnico
Software: Autocad, Catia V5, Solidworks, Kissoft
Regione: Campania
#2
Vuoi fare un solido multi sezione utilizzando queste due curve? In tal caso le due curve devono trovarsi su piani e quindi schizzi differenti.
Altrimenti non ho ben capito la domanda.
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#3
Vuoi fare un solido multi sezione utilizzando queste due curve? In tal caso le due curve devono trovarsi su piani e quindi schizzi differenti.
Altrimenti non ho ben capito la domanda.
Grazie per la risposta PiE81. Questa è la prima "faccia", la seconda non è visibile nell'immagine. Desidero rendere queste curve due uniche curve e non 16.
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#5
Con il comando estrai,
estrai la curva esterna e ottieni la curva unica "esterna"
estrai la curva interna e ottieni la curva unica "interna"

utilizzi le estrazioni (anzichè lo schizzo)

oppure
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#7
Con il comando estrai,
estrai la curva esterna e ottieni la curva unica "esterna"
estrai la curva interna e ottieni la curva unica "interna"

utilizzi le estrazioni (anzichè lo schizzo)

oppure
Gentile giann55, non trovo il comando "estrai". Potrebbe indicarmi dove si trova? Grazie molte.
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#9
ti da quell'errore perchè non sono 4 schizzi ma due,non centrano niente le curve,
ogni rettangolo arrotondato deve essere uno schizzo ed ogni cerchio uno schizzo
tu hai fatto come si fa con autocad,qui non sei su autocad
Capisco. Come faccio poi a "forare" il pezzo? Quello deve essere un condotto. Grazie motocad!
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#10
Il comando estrai è nell'ambiente generative shape design (menù/inserisci/operazioni/estrai)
concordo con motocad, il problema è che sono 2 schizzi anzichè 4, se non hai il modulo superfici, fai 4 schizzi anzichè 2, prima crei il solido multisezione e poi per svuotarlo usi la feature solido multisezione rimosso
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#11
Dunque, grazie ai vostri consigli sono riuscito a fare qualcosa (si veda immagine allegata) ma devo migliorare alcuni aspetti del pezzo. Ho dovuto usare il comando "estrai" come suggerito da gianni55. Ho usato poi la feature "solido multisezione rimosso" per praticare la cavità. Grazie a tutti! Image 4.png
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#12
Bene,
ma la modalità di costruzione che hai applicato non è ottimale (modalità ibrida con gruppi geometrici ordinati dentro il body, più entità in uno schizzo e di conseguenza estrazione dei profili ecc.)

meglio lavorare in modalità NON ibrida, dove in un gruppo geometrico semplice (non ordinato) inserisci lo schizzo 1 profilo esterno iniziale
schizzo 2 profilo esterno finale
schizzo 3 profilo interno iniziale
schizzo 4 profilo interno finale
poi attivi il body
esegui il solido multisezione
esegui solido multisezione rimosso
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#13
Bene,
ma la modalità di costruzione che hai applicato non è ottimale (modalità ibrida con gruppi geometrici ordinati dentro il body, più entità in uno schizzo e di conseguenza estrazione dei profili ecc.)

meglio lavorare in modalità NON ibrida, dove in un gruppo geometrico semplice (non ordinato) inserisci lo schizzo 1 profilo esterno iniziale
schizzo 2 profilo esterno finale
schizzo 3 profilo interno iniziale
schizzo 4 profilo interno finale
poi attivi il body
esegui il solido multisezione
esegui solido multisezione rimosso
E come potrei fare operativamente? Grazie gianni55!
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#14
strumenti/opzioni/infrastructure/part infrastructure/documento della parte togli i segni di spunta da modellazione ibrida

rifai il pezzo come ti ho detto
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#15
Caro gianni55 ho rifatto il pezzo come mi hai suggerito. Mi sono solo dimenticato di spuntare all'inizio "Crea un gruppo geometrico". Cmq adesso non userò più la modellazione ibrida come da tuo consiglio. Grazie! Image 3.png
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#16
adesso che hai ottenuto un diametro nella parte terminale, se vuoi puoi chiuderlo in una sfera perfetta:

dallo schizzo del diametro esterno, generi un prisma (alto quanto il diametro stesso), poi un raccordo (uguale al diametro stesso), poi un guscio (con lo stesso spessore del tubo)
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#17
Chiedo scusa ma è successo qualcosa di insiegabile. Dopo aver fatto il prisma mi sono accorto di aver sbagliato le dimensioni dell oschizzo e l'ho modificato. Non è stata però modificata l'estrusione. Ho cambiato le impostazioni di Catia come suggerito da gianni55 (no modellazione ibrida). Si nota poi facendo dei fori, che il solido non è pieno. Si vede che lo schizzo iniziale non coincide con il bordo del solido (prima immagine allegata). È come se il solido non fosse stato aggiornato. Image 3.png Ma che cosa è successo? Image 1.png Image 2.png
 
Ultima modifica:

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#18
mmmm

qualcosa è andato storto ma senza vedere il modello è difficile rispondere...

controlla lo schizzo.1 che sta nel gruppo geometrico, dovrebbe essere identico (poichè collegato) allo schizzo.1 del body

fammi sapere

ti mando un messaggio privato

ciao
 

fidippide

Utente poco attivo
Professione: Studente
Software: Catia, Fluent, Ansys
Regione: Toscana
#19
mmmm

qualcosa è andato storto ma senza vedere il modello è difficile rispondere...

controlla lo schizzo.1 che sta nel gruppo geometrico, dovrebbe essere identico (poichè collegato) allo schizzo.1 del body

fammi sapere

ti mando un messaggio privato

ciao
Il problema che si evince dai fori è dovuto allo svuotamento (non so bene utlizzare il comando per ora). Non capisco ancora perchè il prisma non è estruso da quello schizzo. Cmq ho rifatto il pezzo.