Simulazione Fem snodo sferico

Steppermotor

Utente standard
Professione: Disegnatore
Software: Solidworks 2017 - Autocad LT 2019
Regione: Toscana
Buon pomeriggio a tutti.
Ho riscontrato un problema simulando uno snodo sferico con Solidworks Simulation, allego una schermata del problema con un assieme molto semplificato ed in pratica il problema è questo:
La sfera è vincolata come fissa, lo snodo è accoppiato per tangenza e in simulation ha contatto senza comprenetazione.
La forza sulla leva è 1000N solo per amplificare lo spostamento.
Simulando mi sarei aspettato che mi segnalasse che il sistema è labile invece ha simulato perfettamente facendo flettere l'asta.
Anche mettendo l'attrito a 0 nella connessione la simulazione è simile.
Infatti come si vede dalla sollecitazione lo sforzo maggiore lo ha il perno della sfera che in pratica non dovrebbe fare nessun lavoro.
Questo è solo un esempio semplificato ma nella simulazione del gruppo reale i risultati sono simili e facendo un analisi critica dei risultati ci siamo convinti che questo accoppiamento ci porti fuori strada con tutta la simulazione.
Qualcuno ha avuto esperienze simili?
Grazie.
 

Allegati

Ultima modifica:

meccanicamg

Utente Senior
Professione: Mechanical engineer manager
Software: SolidWorks, FreeCAD, NanoCAD5, Me10, Excel, LibreOffice
Regione: Lombardia
Simulare gli assiemi, i contatti e quant'altro non è sempre semplice. Ritengo che i FEM siano validi solo per parti singole.
Credo che occorra usare un tipo differente di accoppiamento. C'è da analizzare meglio la situazione.
Tu stai facendo una analisi si movimento fisica? Oppure un FEM statico? Sono due cose diverse e si simulano in ambienti diversi.
 

Onda

Moderatore
Staff Forum
Professione: Ingegnere Meccanico settore Navale
Software: SolidWorks 2019, Rhino v6, Autocad 2008, Patran 2019, Nastran 2019, Apex,
Regione: Italia
Come hai simulato lo snodo sferico? contatti? in tal caso assicurati che fossero touching e non uniti.
 

Steppermotor

Utente standard
Professione: Disegnatore
Software: Solidworks 2017 - Autocad LT 2019
Regione: Toscana
L'accoppiamento sulla sfera è un tangente ma non cambia niente neanche con un concentrico. Su Simulation ho impostato l'accoppiamento come non compenetrante ad attrito 0.
Il caso reale sono due quadrilateri collegati con perni e cuscinetti radiali di cui solo un braccio è una biella con due snodi sferici in modo da essere regolato in lunghezza ed eventualmente compensare disassamenti. Il caso postato è solo una semplificazione dello snodo che ho usato per capire come impostare opzioni di calcolo.
Sono in accordo con meccanicamg che l'assieme non è il massimo per una FEM.
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
Sono in accordo con meccanicamg che l'assieme non è il massimo per una FEM.
Finche' resti nel campo dei piccoli spostamenti puoi ragionare anche in termini di assiemi. Per i cinematismi veri e propri no ovviamente.

Nel tuo caso c'e' qualcosa che non va nell'impostazione dei vincoli, che poi si tratti di un vostro errore o di un bug del software non e' facile capirlo. La forza agente sulla leva e' costantemente orientata secondo un asse nello spazio oppure e' definita come normale alla superficie di applicazione?

Riesci a caricare una immagine della deformata, con forte amplificazione?

In ogni caso la soluzione non doveva convergere perche' effettivamente l'accoppiamento e' labile.
 

Swarzy

Utente standard
Professione: Industrial Designer
Software: Solidworks 2014-2021
Regione: Puglia
Ciao,
a me è successa una cosa simile in passato in quanto mi erano sfuggite alcune facce su cui definire il contatto locale.

Come hai definito il contatto tra le facce, modificando quello globale o impostando un contatto locale?

Puoi condividere il modello con Wetransfer?
 

Steppermotor

Utente standard
Professione: Disegnatore
Software: Solidworks 2017 - Autocad LT 2019
Regione: Toscana
Scusate del ritardo ma ero in vacanza... :)
Abbiamo notato che anche mettendo l'attrito a zero considera sempre 0,05.
Il progetto comunque è andato avanti con una normale bielletta senza snodi sferici in quanto non c'era poi la necessità di usarli.
Ringrazio tutti delle indicazioni.