Movimento fra cuscinetti e camme

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#1
Salve gente, come da titolo dovrei realizzare un movimento fra dei cuscinetti e delle camme, ma al momento non riesco a far muovere tutto come vorrei.
Ogni camma ha due tratti, uno lungo e uno corto, che scorrono su un cuscinetto, se realizzo un accoppiamento di tangenza fra un tratto della camma (p.e. quello lungo) e il cuscinetto tutto ok, ma quando tento di realizzare anche l' accoppiamento fra il tratto corto e il cuscinetto l'insieme diventa totalmente definito e non si muove più.

Ho provato a montare il cilindro con i cuscinetti come assieme a parte e poi a inserirlo nell'altro assieme ma niente da fare. Ho realizzato un piccolo video per spiegarmi meglio.

[video=youtube_share;zLeg7g6BgtA]https://youtu.be/zLeg7g6BgtA[/video]

C'è un modo per far muovere la camma in accoppiamento con il cuscinetto in modo che quando il cuscinetto impegna sia il tratto corto che quello lungo della camma questa ruoti di conseguenza intorno al proprio innesto?

Grazie per l'aiuto.

Marco
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#2

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#3
Ciao Massi, nessun problema per allegare tutto l'assieme. Ho preparato il pack and go, può andare bene?

Poi per allegarlo come si fa?

Ciao!

Marco
 

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#5
Oopss...chiedo venia....

Ecco l'assieme zippato


Ciao!

Marco
 

Allegati

  • 3.5 MB Visualizzazioni: 10
  • 2.8 MB Visualizzazioni: 3
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#6
non te lo posso girare, ma la soluzione potrebbe essere usare l'accoppiamento percorso.
prima di tutto devo dire che modelli male; alcune parti e soprattutto le camme hanno schizzi sottodefiniti e con entità fisse (su un profilo del genere non avere il completo controllo della geometria può portare a problemi di accoppiamento), non sfrutti bene i piani per fare le funzioni e agevolare l'assemblaggio finale.
detto questo prova così:
- la camma la estrudi con piano intermedio e poi fai uno schizzo che ricalchi il profilo (vedi immagine schizzo rosso)
- la ruota disegni un punto di schizzo (schizzo giallo) sul piano medio (da costruire)
- nell'assieme fai l'accoppiamento di percorso fra il punto giallo e le linee rosse
- fra i due componenti non ci dovrebbero essere altri accoppiamenti
Immagine.jpg
 

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#7
Ciao Massi, grazie per le dritte.
Eh...che modello male me ne ero accorto anche da solo :redface:, ma spero di migliorare col tempo e con il vostro aiuto....:finger:

Gli schizzi non sono totalmente definiti perchè sarebbero ancora in fase di definizione, ho definito solo il profilo della camma che scorre sul cuscinetto, anche se sono ben cosciente che ci potrebbero essere dei problemi in fase di accoppiamento...

non sfrutti bene i piani per fare le funzioni e agevolare l'assemblaggio finale.
E quindi come dovrei fare? Hai detto che per estrudere la camma dovrei usare un piano intermedio, ma che differenza fa rispetto all'estrusione con il piano come ho fatto io? Serve per agevolare poi l'accoppiamento di percorso fra camma e cuscinetto? Scusa la domanda banale ma vorrei capire meglio.

Stasera provo e ti faccio sapere.

Grazie, ciao!

Marco
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#8
E quindi come dovrei fare? Hai detto che per estrudere la camma dovrei usare un piano intermedio, ma che differenza fa rispetto all'estrusione con il piano come ho fatto io? Serve per agevolare poi l'accoppiamento di percorso fra camma e cuscinetto? Scusa la domanda banale ma vorrei capire meglio.
se provi a fare l'accoppiamento ti dice che le entità devono essere sullo stesso piano perché il punto e il percorso devono essere sempre in contatto.
quindi se il cuscinetto deve stare centrato alla larghezza della camma ed è più largo di questa gli schizzi del punto e del percorso si devono trovare sul piano medio delle due larghezze. o fai due piani intermedi o modifichi le parti
Immagine.jpg
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#14
nel caso dell'accoppiamento percorso bisogna stare attenti al posizionamento delle entità. se si usano coincidenze o distanze per vincolare le parti si avrà una sovradefinizione dovuta al fatto che l'accoppiamento percorso oltre al proprio vincolo sottintende anche quello di coincidenza dovendo essere il punto e lo schizzo sullo stesso piano.
in questo assieme, dove c'era molta più roba ho dovuto oltre che eliminare tutto il superfluo per lo scopo finale (muovere solo una leva) cancellare tutti gli accoppiamenti e ridarne solo i pochi necessari (le parti fisse le ho impostate io per questo motivo) altrimenti mi sarei perso a cercare la magagna nascosta; invece così mi è saltato subito all'occhio dove era l'errore di ridondanza e poi ne ho capito il perché.
 

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#16
E invece nulla da fare....:frown:...Il file di Massi è per "versione futura", mentre io sono rimasto al palo alla 2013.

Ho provato a fare l'allineamento con percorso ma mi viene solo con 1 camma, con l'altra mi dice che i profili non sono allineati, con una differenza di 0,0021...

Come posso risolvere? Provo a riassemblare tutto?

Ciao!

Marco
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#17
con una differenza di 0,0021...
hai sicuramente un accoppiamento di distanza che sovradefinisce l'assieme. e dovrebbe uscirti il messaggio relativo oltre che evidenziare gli accoppiamenti problematici
e l'ho anche scritto in previsione che
massivonweizen ha detto:
nel caso dell'accoppiamento percorso bisogna stare attenti al posizionamento delle entità. se si usano coincidenze o distanze per vincolare le parti si avrà una sovradefinizione dovuta al fatto che l'accoppiamento percorso oltre al proprio vincolo sottintende anche quello di coincidenza dovendo essere il punto e lo schizzo sullo stesso piano.
 

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#18
Azz....!! Vero....:mad: Stasera ci riguardo meglio.....

Te non hai modo di mettere l'assieme per la 2013?

Ciao!

M
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#19
no.
per vedere il funzionamento fai come ho fatto io:
elimini o sospendi tutti i componenti superflui
sospendi tutti gli accoppiamenti e rendi i sostegni fissi
adesso parti da zero con il montaggio
 

Marvel

Utente Junior
Professione: Metalmeccanico
Software: Solidworks 2013; Rhinoceros 5.0
Regione: Toscana
#20
Fatto il montaggio e gli accoppiamenti, per funzionare funziona, ma le camme "affondano" nel cuscinetto....:mad:

[video=youtube_share;POxpntVIQQo]https://youtu.be/POxpntVIQQo[/video]

Dove sbaglio? O cosa ho omesso nell'accoppiamento?

Ciao.

Marco