Mancato aggiornamento quote pilotate da equazione

weldox

Utente Junior
Professione: Disegnatore
Software: Solidworks
Regione: Lombardia
Ciao a tutti,
Mi trovo ad avere un problema mai successo con toolbox.

L' ambiente è Windows 7 64 bit, SW2015 professional...rodato e stra rodato. Mai avuti problemi.

In pratica l'esagono delle viti incassate non risulta centrato (non si aggiornano le quote pilotate da equazione!).
allego cattura video esplicativa.

Qualcuno di voi ha avuto problemi simili?
Se si, come si possono risolvere?

Grazie mille!
Maurizio
 

Allegati

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
ma se non salvi il file come pretendi che si aggiornino?
e allega il file per permettere di fare qualche prova
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
ma perché legare l'esagono al centro con delle equazioni invece che disegnarlo direttamente concentrico?
 

Alan91

Utente poco attivo
Professione: Disegnatore Tecnico; Studente
Software: Solidworks 2017 ; Illustrator
Regione: Emilia Romagna
Guarda che ti stai complicando la vita con niente :). Se l'hai preso dal tool box con tutta probabilità la vite ha l'origine al centro, se selezioni la funzione esagono puoi direttamente crearlo dall'origine e ti viene automaticamente al centro senza bisogno di equazioni. Poi per farlo aggiornare all'assieme devi prima salvare la parte e se non si aggiorna, nel file dell'assieme, clicca sull'icona del semaforino in alto a sinistra.
 

320i S

Utente Standard
Professione: Progettista
Software: Catia V6, Creo 3.0, Pro-e (serie Wildfire 3÷5), Solidworks 2016 - 2018
Regione: Friuli Venezia Giulia
Hai provato ad isolare solo il/i componenti che ti danno il problema?
Su solidworks ti da lo stesso?
 

weldox

Utente Junior
Professione: Disegnatore
Software: Solidworks
Regione: Lombardia
MassiVonWeizen

In realtà io questa operazione di solito non la eseguo...nel senso che genero i miei componenti toolbox nell'assieme. Sono entrato nella parte toolbox per mostrare il fatto che è come se non si aggiornassero le equazioni.
Non so pechè non abbiano legato l'esagono al centro...è la componente originale toolbox, non è una mia creazione.

Alan91

E' un problema che ho con i componenti toolboox standard, non con un componente derivato o creato da me. Anche voi avete i file di toolbox impostati in "sola lettura"? Deve essere così oppure è un problema con la mia installazione? Credo dipenda da questo.

320i S

Diciamo che è un problema che mi da con tutti i componenti toolbox...sospetto dipenda dal fatto che tutti i file di toolbox nel mio sistema siano impostati su "sola lettura"....
 

Alan91

Utente poco attivo
Professione: Disegnatore Tecnico; Studente
Software: Solidworks 2017 ; Illustrator
Regione: Emilia Romagna
Uhm continuo a non capire. Io ho aperto un pezzo di toolbox in sola lettura eppure riesco comunque a modificarlo a piacimento come se fosse un pezzo normale, con origine e tutto.

1.PNG2.PNG3.png4.PNG

Vorrei poterti anche postare il file ma purtroppo uso SW2017 quindi non credo te lo apra
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
ho guardato una vite toolbox con sede esagonale e confermo la mia idea che le tollbox fanno cagare
la vite che ho aperto, una ISO 4762, ha lo schizzo dell'esagono sottodefinito (e già qui siamo messi male), poi è quelle quote guidate da equazione servono per definire l'esagono per dire che la distanza fra il centrpo e un lato è meta della larghezza della cava (bisogna essere geni per pensarla) col risultato che si hanno equazioni che non servono ad una benemerita cippa se non appesantire il file e comunque se sposti le entità dello schizzo va tutto in vacca.
i componenti toolbox sono sempre in sola lettura. per poterli modificare bisogna salvarli con nome e poi svincolarli dallo stato di toolbox tramite l'apposito eseguibile che trovi nella cartella di solid e che è già stato spiegato nel forum.

alan91, lo stato di sola lettura non impedisce la modifica dei componenti, ma il loro salvataggio. se weldox dopo aver modificato o aggiornato la vite non avesse chiuso il file ma fosse tornato nell'assieme avrebbe visto l'aggiornamento corretto.

a futura memoria, quando si deve aggiornare un file conviene sempre usare (a discapito di un tempo leggermente più lungo) CTRL+Q che fa l'aggiornamento in maniera approfondita mentre CTRL+B (il semaforo) lo fa solo per le funzioni modificate
http://help.solidworks.com/2018/italian/SolidWorks/sldworks/t_Checking_Model_Geometry.htm
 

weldox

Utente Junior
Professione: Disegnatore
Software: Solidworks
Regione: Lombardia
Mi scuso per il ritardo nel rispondervi ma ho avuto un incidente con conseguente operazione chirurgica per fortuna andata bene.
Vi ringrazio per le Vs risposte, utilizzerò le vostre informazioni per approfondire il problema.

Grazie mille!