Lentezza esasperante di soidworks 2015 , 2016

Per5

Utente Junior
Professione: impiegato
Software: mechanical 2008
Regione: Lombardia
#1
Buonasera a tutti .
L'azienda per la quale lavoro dispone di un solidoworks 2015 e 2016 , stiamo utilizzando la versione 2015, su una macchina con il seguente hardware CPU i7 4790 , scheda video Nvidia quadro K2200 , pensavo che il sistema dovesse volare, invece noto grossi problemi con assiemi, credo piccoli rispetto a quelli che si dovrebbero fare utilizzando questo software.
Che tipi di prove devo eseguire per capire se il sistema sta lavorando nel modo giusto?
Quando carico gli assiemi , nonostante ci sia un utilizzo della cpu minimo, solidworks ci impiega parecchio ad aprire il disegno,a volte anche più di 2 minuti.
Non riesco a capire se la macchina è sottodimensionata per il software oppure se ci sono problemi di altro tipo.
Produciamo nastri trasportatori, quindi macchine non troppo complesse con meno di 1000 particolari considerando la singola vite .

Grazie
 

Per5

Utente Junior
Professione: impiegato
Software: mechanical 2008
Regione: Lombardia
#3
Ciao Massi , ti ringrazio per la segnalazione. Nel mio caso però SI parla di una macchina recente con un processore di penultima generazione , scheda video certificata , SSD , e tutto quello che serviva a farlo andare quel software. Gli assieme per quanto siano fatti male , accoppia menti ridondanti schizzi non definiti , non danno una giustificazione , si blocca sulle sezioni , e gli zoom nella messa in tavola sono scattosi. Dall' assistenza sono stati furbi a ridurre tutti i settaggi grafici , ma come si fa a lavorare con i cilindri cubici. Forse la rete, forse la gpu, ma il processore non lavora, sta a 5 % e il disegno non si muove.
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014
Regione: Friuli Venezia Giulia
#4
ci sono tanti parametri da settare per velocizzare il software. io ne ho elencati alcuni che mi sono venuti in mente e che uso da anni.
prima di tutto comunque bisogna fare il test. con quello hai già alcuni parametri indicativi.
poi bisogna capire dove si blocca e quando:
ambiente parte
ambiente assieme
ambiente disegno

se i problemi sono soprattutto su quest'ultimo la tua frase
Gli assieme per quanto siano fatti male , accoppia menti ridondanti schizzi non definiti , non danno una giustificazione
è sbagliata. non è un disegno statico di autocad, se fai male l'assieme, magari lasciando parti mobili, il software lavora male perché deve ricostruire tutte le geometrie che non sono identiche a prima. e più l'assieme è pesante peggio è.
alcuni settaggi che migliorano le prestazioni:
sposta componenti trascinando: se attivato rigenera ogni volta il modello e nel tu caso dove è tutto mobile la cosa può avere significative ripercussioni. io ho disattivato quella spunta è assegnato un tasto al comando sposta cosicché sto un attimo a lanciare il comando solo quando serve.
scheda visualizza/selezione
-visibilità dei bordi tangenti: anche questo rallenta la ricostruzione grafica
-attiva selezione attraverso la trasparenza: oltre a complicare la selezione di entità rallenta il sistema
scheda prestazione
-qualità alta per la modalità dinamica: questa mantiene una grafica elevata anche durante la movimentazione dei modelli rallentando significativamente il software. se proprio necessario tienilo attivato solo con modelli semplici

le parti commerciali devono essere semplici, se hai un motore pieno di alette buttalo via e rifallo. nei disegni non usare la modalità linee nascoste ed attivale solo quando necessario.
posta uno screenshot che almeno si capisce su che tipo di disegno si pianta
 

Per5

Utente Junior
Professione: impiegato
Software: mechanical 2008
Regione: Lombardia
#5
ci sono tanti parametri da settare per velocizzare il software. io ne ho elencati alcuni che mi sono venuti in mente e che uso da anni.
prima di tutto comunque bisogna fare il test. con quello hai già alcuni parametri indicativi.
poi bisogna capire dove si blocca e quando:
ambiente parte
ambiente assieme
ambiente disegno

se i problemi sono soprattutto su quest'ultimo la tua frase

è sbagliata. non è un disegno statico di autocad, se fai male l'assieme, magari lasciando parti mobili, il software lavora male perché deve ricostruire tutte le geometrie che non sono identiche a prima. e più l'assieme è pesante peggio è.
alcuni settaggi che migliorano le prestazioni:
sposta componenti trascinando: se attivato rigenera ogni volta il modello e nel tu caso dove è tutto mobile la cosa può avere significative ripercussioni. io ho disattivato quella spunta è assegnato un tasto al comando sposta cosicché sto un attimo a lanciare il comando solo quando serve.
scheda visualizza/selezione
-visibilità dei bordi tangenti: anche questo rallenta la ricostruzione grafica
-attiva selezione attraverso la trasparenza: oltre a complicare la selezione di entità rallenta il sistema
scheda prestazione
-qualità alta per la modalità dinamica: questa mantiene una grafica elevata anche durante la movimentazione dei modelli rallentando significativamente il software. se proprio necessario tienilo attivato solo con modelli semplici

le parti commerciali devono essere semplici, se hai un motore pieno di alette buttalo via e rifallo. nei disegni non usare la modalità linee nascoste ed attivale solo quando necessario.
posta uno screenshot che almeno si capisce su che tipo di disegno si pianta
Ti ringrazio per la pazienza.
Domani provo a fare uno screenshot e lo inserisco.
Provo anche a mettere in pratica quello che hai indicato in modo da non avere più dubbi.
Non è tanto un bloccarsi, perchè prima o poi arriva al sodo il software e carica tutto, ma i tempi sono lunghi, a volte un paio di minuti.
la parte 3d funziona tutto sommato abbastanza bene, ma la messa in tavola è un disastro, sulle sezioni spesso devo chiudere il software e zoommare diventa un problema.
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#6
Da quando ti si è presentata questa lentezza? Ti dico questo xchè da poco tempo ho riscontrato che si presenta una "anomalia". Oggi parlando con una persona che utilizza sw anche lui mi ha confermato che c'è qualcosa che non va.
Questo è quello che chiedevo in un'altra discussione, magari ci sono dei legami fra loro....
http://www.cad3d.it/forum1/threads/...-e-impressioni?p=392746&viewfull=1#post392746
Detto ciò comunque i problemi sono solo nella messa in tavola, almeno con pc recenti....
 

Iraz

Utente Junior
Professione: ...a creare scatole in lamiera e componenti elettroniche
Software: SolidWorks 2016, Autocad; Draftsight
Regione: Veneto
#7
una curiosità: lavori con i file caricati in rete?
io faccio un pack&go in locale per lavorare e una volta finito (o a fine giornata sarebbe la procedura corretta) faccio un pack&go verso il server.
Ho notato che vi è una differenza tangibile tra caricare file in locale o dal server
 

Per5

Utente Junior
Professione: impiegato
Software: mechanical 2008
Regione: Lombardia
#8
Ciao ragazzi , scusatemi ma sono riuscito solo oggi a leggere. Ho detto la provo lavorando sull' SSD locale , rete 5 minuti , caricamento in locale 15 secondi. Effettivamente la rete fa pena , troppo lenta per il 3d . Una volta caricato il disegno per la parte 3d tutto abbastanza bene , per la parte tavole sistema troppo lento , sezioni tempi biblici. Non so se è il caso di fare una nuova installazione su altro SSD , e poi valutare.

Inviato dal mio Redmi Note 2 utilizzando Tapatalk
 

Per5

Utente Junior
Professione: impiegato
Software: mechanical 2008
Regione: Lombardia
#9
Mi correggo, volevo dire che ho fatto la prova su disco locale, velocità ottima , su rete purtroppo lentezza enorme nel caricamento. Resta comunque il problema della messa in tavola , nella quale ci sono serie difficoltà a far calcolare le sezioni. Ora eseguiamo i salvataggi in locale per voi beckup su server , ma qual è il procedimento corretto per non perdere riferimenti ed altro?



Inviato dal mio Redmi Note 2 utilizzando Tapatalk
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2019 sp0.1, autocad2017, pochino solidedge st7, draftsight
Regione: Lombardia
#10
Ciao io non posso darti altri consigli sul fatto che il tuo sistema sia lento:
però ti posso dire che ho appena cambiato computer, abbiamo acquistato una workstation hp z640 con nvidia m4000, disco ssd 16gb ram ecc una macchina di tutto rispetto(non progetto shuttle).
Pensavo che gli assiemi che realizzo(mai piu di 3000 componenti) volassero beh ecco hanno appena iniziato a camminare....
Con assiemi di 300 o 400 componenti già è lento....(per me) i settaggi che il buon Massi ti ha suggerito li ho provati tutti e in più combinazioni ma nulla, il sistema risulta ancora lento.
Io ricordo con molta nostalgia solidworks 2008; stabile e soprattutto veloce.....ora avranno come dicono loro ridotto il numero di click per realizzare geometrie super complesse; ma io per fare un click ci metto una frazione di secondo; mentre aspettare che solid pensi di rigenerare un assieme di 300 pezzi aspetto anche 20 30 secondi.
Non so voi ma io non sono affatto soddisfatto di come stando andando le ultime release.
Domani vedo ptc.....cosi vedrò se almeno anche li; ci sono gli stessi problemi......
Ripeto dovrebbero fermarsi per almeno un anno....e fan...o il marketing: e sistemare il mare di ca....e che in questi anni si sono portati dietro......

Una cosa anche excel e word sono lentissimi .....

ciao
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#11
Ciao io non posso darti altri consigli sul fatto che il tuo sistema sia lento:
però ti posso dire che ho appena cambiato computer, abbiamo acquistato una workstation hp z640 con nvidia m4000, disco ssd 16gb ram ecc una macchina di tutto rispetto(non progetto shuttle).
Pensavo che gli assiemi che realizzo(mai piu di 3000 componenti) volassero beh ecco hanno appena iniziato a camminare....
Con assiemi di 300 o 400 componenti già è lento....(per me) i settaggi che il buon Massi ti ha suggerito li ho provati tutti e in più combinazioni ma nulla, il sistema risulta ancora lento.
Io ricordo con molta nostalgia solidworks 2008; stabile e soprattutto veloce.....ora avranno come dicono loro ridotto il numero di click per realizzare geometrie super complesse; ma io per fare un click ci metto una frazione di secondo; mentre aspettare che solid pensi di rigenerare un assieme di 300 pezzi aspetto anche 20 30 secondi.
Non so voi ma io non sono affatto soddisfatto di come stando andando le ultime release.
Domani vedo ptc.....cosi vedrò se almeno anche li; ci sono gli stessi problemi......
Ripeto dovrebbero fermarsi per almeno un anno....e fan...o il marketing: e sistemare il mare di ca....e che in questi anni si sono portati dietro......

Una cosa anche excel e word sono lentissimi .....

ciao
Quoto in toto quello che dici! Chi ha l'esperienza di aver aggiornato si rende conto di aver fatto una grande c.....a! La versione 2008 non la conosco, ma rimpiango la 2012 con xp che girava da paura anche con sistemi 32 bit e schede grafiche che sulla carta non hanno nulla in confronto alla nostra "amata" M4000. Si devono fermare, ma non lo faranno mai e ci costringeranno a cambiare pc ogni 3 od al massimo 4 anni. Del resto hanno già tolto la possibilità di rientrare in assistenza quando lo si desiderava. Comunque credo che la tendenza la faranno tutte le software house... purtroppo!
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2019 sp0.1, autocad2017, pochino solidedge st7, draftsight
Regione: Lombardia
#12
Oggi sono stato a una presentazione di ptc, è ovvio che non posso dire di conoscere ptc ma come primo impatto mi è piaciuto molto....perchè beh per intanto non è hai mai crashatto....e poi un assieme di 1000 componenti mosso da una workstation di tre anni fa lo modificava come voleva.......ad una velocità accettabile....

C'è però da dire una cosa in solid almeno a prima vista abbiamo una gran interfaccia utente quella di ptc è indietro almeno due tre anni....
ma come dicevo nel post precedente meglio meno cose ma funzionanti.....
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#13
Io ho imparato il cad 3D con una vecchissima versione di proe... poi non ne feci più nulla, fino a quando qualche anno dopo comprai sw. Sw non è male, anzi molto "facile" da usare e con una bella interfaccia (che x fortuna hanno più o meno ripristinato dopo l'obbrobrio fatto con la 2016). Ma proe era di livello superiore, in quanto era veramente parametrico in tutto e x tutto. Questo comportava almeno al tempo delle apparenti limitazioni, che però una volta capite facevano la differenza.... La politica commerciale della parametric era al tempo, come dire, alquanto vergognosa e spero che nel tempo se ne siano resi conto...
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2019 sp0.1, autocad2017, pochino solidedge st7, draftsight
Regione: Lombardia
#14
Ma come politica economica beh che dire...ormai sono tutti li....
loro noleggiano anche il software quindi alla fine non c'è neanche il costo del software, la cosa che mi ha impressionato e che lo puoi noleggiare per quanto ti pare anche per 3 mesi....!!!!!

I costi della versione base mi sembra un po' piu di solid ma mica poi tanto direi un 10 20 %.....ma siamo all'inizio della valutazione.....la strada se decidessimo di cambiare beh è lunga direi.....non è una cosa da fare alla leggera.......

ciao
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2019 sp0.1, autocad2017, pochino solidedge st7, draftsight
Regione: Lombardia
#15
Una cosa ho notato che anche solid edge, qui ne l forum ha problemi di lentezza.....
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#16
Si la cosa va valutata molto attentamente xchè non è indolore... anzi!
Sono convinto che la situazione è x tutti i software, chi prima e chi poi avranno questi problemi. Iniziano prima i più "connessi" con mamma microsoft e poi piano piano gli altri seguiranno... e i cazzi (lasciatemelo dire) saranno solo ed esclusivamente i nostri però! Chi lavora e non è più di primo pelo queste cose le vedo molto bene e capisce prima quello che faranno. Io la prima cosa che ho notato passando dalla 2012 alla 2016, quando ho aggiornato tutto, sia pc che sw (purtroppo e con un costo di certo non irrisorio) che sw è diventato troppo integrato con il sistema operativo (io sono passato ed ancora lavoro con win 7). Questo molto probabilmente dipende da win e dalla politica di microsoft e quindi bisogna essere completamente integrati e sorbirsi tutte le porcate che fanno. In poco più di un anno dal passaggio, ho incontrato più problemi sia con win che con sw che in tutti gli anni precedenti. Questo x me è sufficiente x capire...
 

Per5

Utente Junior
Professione: impiegato
Software: mechanical 2008
Regione: Lombardia
#17
Buon Lunedì a tutti.
Ritorno su questo discorso, avendo risolto in parte il problema lavorando in locale, ora i disegni si caricano ad una velocità incredibile se paragonati alla lentezza della rete, rimane però quello della messa in tavola, dove la fluidita di movimentazione dei 2d almeno per ora e per come lo utilizziamo noi è ancora lontana.
Si sta comunque parlando di due sistemi completamente diversi.
Quello che volevo capire è se era possibile togliere il riggiornamento della vista ad ogni piccolo zoom con la rotellina, infatti ogni volta che eseguo uno zoom compare una sorta di clessidra circolare di ricalcolo, cosa che nella parte 3d non fa, è questo a lungo andare diventa fastidioso, su particolari piccoli il tempo di ricostruzione è quasi nullo, su assieme più grandi anche se non esagerati questo aumenta sempre più.
La cosa che mi pare strana è che il sistema lavora peggio nella messa in tavola che nella parte 3d.

Grazie
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#18
Assolutamente si sw fa molta più fatica nella messa in tavola che nel 3D. Nelle opzioni, dovresti trovare qualcosa, ma ora non ricordo di preciso. Comunque ho avuto qualche giorno fa di nuovo il problema con la messa in tavola di un grosso assieme e dopo essere esasperato ho contattato l'assistenza. Mi hanno consigliato di provare ad usare lo speedpack. Non l'ho mai usato, ma quando andrò a terminare quel lavoro vedrò di iniziare a vederlo. L'assieme di cui parlo ha più di 20000 corpi, ma la cosa incredibile è che nel modello non avevo il ben che minimo problema, mentre nella messa in tavola anche selezionare le note per spostarle risulta un grosso problema esasperante. Oltre lo speedpack non mi hanno consigliato nulla.
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014
Regione: Friuli Venezia Giulia
#20
se vi leggete il forum di solidworks (scrivete la parte in corsivo solidworks 2016 slow site:forum.solidworks.com nella ricerca di google e impostate come tempistica l'ultimo mese) sembra che il problema sia con i driver delle schede Gforce*. verificate che siano aggiornate in caso contrario provvedete

* riporto due risposte dei primi thread letti
#1 link After a search and reading threads it seems everyone using Nvidia GeForce graphics is having the same issue . I've been left with no option but Roll Back the driver to the previous version . Finally it's back to normal and Solidworks is running as it should .

2# link I've taken 9 reports of this behavior this week and all of them were cleared up with the latest driver off www.geforce.com. Your mileage may vary but updating to the latest is having a good impact.

può essere un buon punto di partenza.
copio e incollo anche sugli altri due trhead con lo stesso argomento