funzione di libreria per sedi or, non funziona

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2020, AUTOCAD 2016, INVENTOR 2016
Regione: campania
ciao a tutti
ho cercato una soluzione sul forum ma non sono riuscito a trovare quello di cui ho bisogno.
In pratica devo realizzare un a sede per o-ring,
utilizzo le funzioni libreria, scelgo la normativa ISO 3601, tipo di sede "face static",
dopo aver scelto l'o-ring che mi serve (nel mio caso B0180), mi compare la sede non concentrica col foro sul mio modello,

anche dopo aver scelto lo spigolo del foro dove deve andare l'o-ring, mi compare la sede decentrata rispetto al foro.
Cattura2.PNGCattura3.PNG
Dove sbaglio? oppure c'è un problema con le funzioni di libreria?
grazie a tutti
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
Il bordo del foro (edge) è selezionato correttamente?
Stasera do un'occhiata alla funzione
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2020, AUTOCAD 2016, INVENTOR 2016
Regione: campania
ciao massi
si il bordo è selezionato correttamente, mi sembra strano che già l'anteprima mi faccia vedere una cava decentrata
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
Ho controllato ed è proprio la funzione di libreria il problema. Se la espandi vedrai che lo schizzo di taglio in rivoluzione è sottodefinito perché manca il vincolo dell'asse che quindi viene sparato alla sbrisolona via.
Quello che devi fare è aprire la funzione di libreria (tasto destro sul task pane>apri) e cotteggerla vincolando l'asse all'origine e salvare
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2020, AUTOCAD 2016, INVENTOR 2016
Regione: campania
Ho controllato ed è proprio la funzione di libreria il problema. Se la espandi vedrai che lo schizzo di taglio in rivoluzione è sottodefinito perché manca il vincolo dell'asse che quindi viene sparato alla sbrisolona via.
Quello che devi fare è aprire la funzione di libreria (tasto destro sul task pane>apri) e cotteggerla vincolando l'asse all'origine e salvare
grazie massi, avevo provato a creare un asse per il foro ed a vincolare lo schizzo all'asse che avevo creato, così avevo risolto per questo caso.
con il tuo suggerimento, risolvo definitivamente o dovrò fare questa correzione ogni volta?
grazie ancora
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
L'ho gia scritto, devi correggere la funzione di libreria di base
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2020, AUTOCAD 2016, INVENTOR 2016
Regione: campania
Ho controllato ed è proprio la funzione di libreria il problema. Se la espandi vedrai che lo schizzo di taglio in rivoluzione è sottodefinito perché manca il vincolo dell'asse che quindi viene sparato alla sbrisolona via.
Quello che devi fare è aprire la funzione di libreria (tasto destro sul task pane>apri) e cotteggerla vincolando l'asse all'origine e salvare
ciao massi
ho fatto come mi dicevi, ora però ho un altro problema, diciamo.
in pratica ho vincolato lo schizzo delle funzione di taglio in rivoluzione, ma ora al momento di inseire la funzione nella mia parte, solidworks mi chiede di selezionare sia il bordo (edge) del foro, sia il suo centro, mentre prima chiedeva solo il bordo.
c'è un modo per evitare questa ulteriore selezione?
spero di essermi spiegato
ciao a presto
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: solidworks 2019
Regione: Friuli Venezia Giulia
Dipende da che vincoli hai messo.
Apri una delle altre funzioni delle or, verifica che funzioni, e studia come è gestita, soprattutto l'asse