frame lentissimo

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
buonasera a tutti, sono Luca, uno nuovo del forum e questo è il mio primo post. come prima cosa vi ringrazio dell'insostituibile supporto che date ai progettisti CAD. io ho cominciato ad utilizzare solidedge e solidworks già dagli ultimi corsi universitari specialistici in ingegneria meccanica ed ora sto continuando ad utilizzare solidedge a lavoro. ci occupiamo di banchi prova, principalmente per componenti automotive.
detto questo, utilizzando il "pacchetto" frame sto riscontrando una lentezza inaudita. praticamente se sposto, ruoto o aggiungo un singolo elemento frame, prima di ricaricare completamente il modello passano almeno 10 minuti (non per modo di dire, 10 minuti reali). scheda video e funzionalità del computer tutto regolare. ho problemi solo con elementi frame, tutto il resto funziona a dovere (anche con CAD di componenti molto elaborati); di contro la sezione dei frame è di una geometria banalissima (praticamente una sezione rettangolare cava o poco piu) quindi penso non ne giustifichi la lentezza.
unica cosa non proprio regolare che ho fatto è che gli sketch (usati per gli elementi frame) a causa delle modifiche e riassettamenti hanno perso i "riferimenti" facendo diventare le linee di quel brutto color marroncino. in ogni caso quando modifico riesco a lavorarci bene.
dopo questa descrizione, secondo voi quale potrebbe essere la causa di tutta questa lentezza? posso rimediare in qualche modo? puo esser tutto causato dagli "sketch marroni"? riiniziare sarebbe perdere molto tempo ed in ogni caso non saprei con i diversi sketch necessari come evitare di perdere i riferimenti, è davvero molto facile riuscirci... in allegato il telaio allo stato attuale.
grazie mille anticipatamente

1540558181409.png

1540558674017.png
 
Ultima modifica:

delki

Utente Standard
Professione: Tecnical Support e Formazione su Solid Edge e SolidRules
Software: Solid Edge, Visual Basic .NET, SolidRules: InCentro, Desk, Configurator Manufactoring, Studio
Regione: Veneto
Sicuramente gli schizzi arancioni non facilitano la cosa, ma su che versione e MP stai lavorando?
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
Schizzi "marroni" indicano dei conflitti, i conflitti rallentano il sistema in quanto vengono generati degli errori durante il tentativo di risoluzione delle relazioni.

Per prima cosa installa l'ultimo MP, poi sistema gli schizzi, probabilmente tendi a sovravincolare le geometrie
 

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
non avevo l'ultimo MP aggiornato. ho appena aggiornato ma purtroppo poco/niente è cambiato. quindi attualmente ho ST9 con MP12.
 

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
per quanto riguarda gli schizzi, non riesco a ritrovare il capo della matassa. nel senso che provo a modificare alcuni vincoli in modo da far tornare quello schizzo blu, passo al secondo schizzo, faccio lo stesso, e torna marrone il primo che avevo sistemato, anche andando "in fila" con la cronologia di creazione dei vari sketch.
allegherei volentieri il file ma come posso fare in maniera veloce a non perdere i collegamenti dei vari frame alla libreria dei frame che ho su una cartella a parte? se creo una nuova cartella con solamente il file incriminato e relativa libreria di frame devo sostituire per ogni elemento frame la provenienza del frame dalla nuova libreria, impiegando 10 minuti per ognuna delle tante sostituzioni. oppure allego il file da solo ma rimarrebbero solamente gli sketch...come potrei fare???
grazie
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
per quanto riguarda gli schizzi, non riesco a ritrovare il capo della matassa. nel senso che provo a modificare alcuni vincoli in modo da far tornare quello schizzo blu, passo al secondo schizzo, faccio lo stesso, e torna marrone il primo che avevo sistemato, anche andando "in fila" con la cronologia di creazione dei vari sketch.
allegherei volentieri il file ma come posso fare in maniera veloce a non perdere i collegamenti dei vari frame alla libreria dei frame che ho su una cartella a parte? se creo una nuova cartella con solamente il file incriminato e relativa libreria di frame devo sostituire per ogni elemento frame la provenienza del frame dalla nuova libreria, impiegando 10 minuti per ognuna delle tante sostituzioni. oppure allego il file da solo ma rimarrebbero solamente gli sketch...come potrei fare???
grazie
Copia tutti i file nella stessa cartella, zippali ed invia

Ciao
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
C'è qualcosa di sicuro che non va in questo assieme, il tempo che ci impiega ad aprirsi è anormale indipendentemente da vincoli saltati o meno.

Appena si apre lo analizzo, ma varrebbe la pena inviarlo a Siemens in modo da capire come mai ci mette tutto questo tempo anche solo per aprirsi.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
Forse sono proprio gli errori negli schizzi che mettono in crisi Solid Edge, e ripeto, non deve succedere quindi varrebbe la pena inviare l'assieme a Siemens per indagare.

Detto questo: ma ti servono davvero 17 schizzi ? La struttura non mi sembra così complessa da renderli necessari.
 

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
non sono assolutamente necessari, ne basterebbero 7-8 al max. diciamo che sono andato avanti non ponendomi il problema, aggiungendo sketch a seguito delle innumerevoli modifiche, aggiunte, mutate esigenze ecc... anche perchè il CAD è cominciato ad essere lento dall'inizio e pensavo di metterlo meno in difficoltà aggiungendo uno sketch rispetto a modificarne uno esistente...da quello che mi dici sbagliando?
grazie
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
In questo file c'è qualcosa che mette in crisi Solid Edge in maniera ingiustificata, ecco perché ti scrivevo di segnalarlo.

Il problema nell'avere tanti in schizzi non è nelle prestazioni, che normalmente non impattano, ma nella progettazione, se ora dovessi modificarne le dimensioni su quale schizzo vai ad agire ? E' un caos totale.

Ciao
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
Per poter lavorare, e risolvere il problema puoi disattivare "Aggiornamento automatico"

automatico.png
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
Disattivando l'aggiornamento automatico, sono riuscito ad eliminare tutti i conflitti negli schizzi (non sono più marroni) ed ora l'apertura dell'assieme è di pochi secondi.

Torno a ribadire che con tutti quegli schizzi è un caos totale lavorarci (non come prestazioni, ma solo per capire su cosa agire)

Ciao
 
Ultima modifica:

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
ottima notizia. appena posso "restauro" il tutto. grazie mille. comodissima anche la funzione sull'aggiornamento che non conoscevo
 

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
allora son riuscito a togliere tutti i conflitti riportando tutti gli schizzi in blu ed ora il file si apre e chiude al volo. il problema è che ora non posso piu ne aggiungerene nuovi ne modificare gli elementi frame gia creati; posso solo eliminarli...è come se il modello fosse congelato in quella configurazione. se ad esempio modifico uno schizzo non aggiorna il frame relativo a quello schizzo. se creo un nuovo schizzo e gli assegno un elemento frame, sul menu "a tendina" a compare quel nuovo frame, ma non viene poi visualizzato, rimane come visualizzazione il solo sketch nudo...
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
allora son riuscito a togliere tutti i conflitti riportando tutti gli schizzi in blu ed ora il file si apre e chiude al volo. il problema è che ora non posso piu ne aggiungerene nuovi ne modificare gli elementi frame gia creati; posso solo eliminarli...è come se il modello fosse congelato in quella configurazione. se ad esempio modifico uno schizzo non aggiorna il frame relativo a quello schizzo. se creo un nuovo schizzo e gli assegno un elemento frame, sul menu "a tendina" a compare quel nuovo frame, ma non viene poi visualizzato, rimane come visualizzazione il solo sketch nudo...
Hai riattivato "Aggiornamenti automatici" ?
 

lucacecchetti

Utente poco attivo
Professione: ingegnere meccanico senior
Software: solid edge, solid works, autocad, matlab
Regione: umbria
si riattivato. dopo 5 minuti di bestemmie l'ho rifatto tutto da capo in maniera ordinata, molto piu veloce. ora tutto funziona alla perfezione. grazie