FastSearchScope

e.ferriani

Utente Junior
Professione: disegno/progetto meccanico; ex programmatore cam
Software: Solid Edge 17...SE2019, Featurecam, altri cad
Regione: emilia
#1
Al lavoro ho un problema che sembra essere una cosa irrisolvibile, almeno chi mi sta facendo assistenza non ha esperienza, e non mi sa dare altro aiuto. Provo a spiegarvi.

Premetto che mi viene contestato come possibile motivo il fatto che nella cartella con i 3d ci sono più di 8192, anche se ho letto che il numero massimo dovrebbe essere (2^32)–1.

Siamo in due ad utilizzare SE2019 full, ed abbiamo una cartella di lavoro in rete dove mettiamo TUTTI i files 3d ed una dove mettiamo TUTTI i dft. I 3d, che possono essere parti, lamiere o assiemi sono utilizzati per disegnare qualsiasi cosa, dal pannellino in ferro al cablaggio al codice finito ed assemblato. Spesso le parti 3d vengono ricavate da altri codici esistenti quindi per disegnare la parte viene inserito come feature un altro file .par o .asm.

Un altro motivo che mi viene contestato è la quantità di collegamenti esistenti tra i vari files a vari livelli.

Cosa facciamo noi, prendiamo un file par o asm esistente, e con Design Manager ne copiamo con nuovo nome il dft e tutto quello che contiene il 3d nativo, poi in ambiente 3d viene modificato.
In svariate occasioni, per capire come disegnare o rinominare o spostare qualcosa viene fatto un "dove usato" e ad un certo punto della storia questa funzione ha rallentato in modo evidente.
Contestualmente chi ci assiste aveva installato sul server anche il FastSearch, che quando l'ho visto lavorare ho detto "è un fulmine, teniamolo assolutamente". Dopo aver installato qualcosa sul server, è stato impostato SE2019 per utilizzare il proprio gestore dati, e sono state inserite le cartelle indicizzate nella pagina deputata nella configurazione.
Eseguendo "dove usato" non c'era nemmeno bisogno di specificare dove e cosa cercare, in 4 o 5 secondi venivano cercate in modo "silenzioso" e mostrate le connessioni dei file contenitori.

Capitava spesso però che all'improvviso il servizio di ricerca veloce era veramente lento, più di prima, come se non stesse lavorando. Ho cominciato a dare colpa al disco del server dove è contenuto il lavoro, tant'è che spostando per prova tutto in un'altra disco le cose andavano bene.

Ovviamente era una prova e non ho potuto lasciare le copie. Abbiamo deciso di prendere un disco esterno NAS.
Collegato in rete ovviamente non funzionava più niente. Il servizio di indicizzazione non era funzionante, o meglio, a differenza di quando tutto andava bene, facendo "dove usato" ha ripreso a comparire la finestra che consente di impostare. Chi ci fa assistenza dice, non avendo esperienza con queste unità esterne, che probabilmente il fatto che sul NAS gira Linux, il servizio di window non lo riconosce.
Abbiamo ho collegato il nas come unità disco di rete al server ed ora sto puntando al server, ma non cambia niente. Continua ad uscire la finestra dove bisogna impostare cosa e dove andare a cercare il file incriminato.

La mia domanda è se esiste sul server una configurazione del fast search, dove andare a specificare le cartelle dentro cui esaminare le relazioni dei vari file. Il mio collega ha impostato tali cartelle nel servizio di Windows, ma non sembra cambiare niente. Per esempio, se metto nel gestore dati di SE2019 le vecchie cartelle, quelle non funzionanti per capirci, la ricerca avviane in modo silente. Per questo credo ci sia un'altra configurazione nascosta da qualche parte che continui a puntare là.

Grazie a chi saprà aiutarmi.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#2
Da tempo ho intenzione di iniziare ad usare il FastSearch ma ho sempre rimandato in quanto da noi ad ogni disegno corrisponde un codice ed una distinta, di conseguenza il "dove usato" lo faccio tramite "implosione".

In ogni modo, ad ogni aggiornamento di Solid Edge esce anche il corrispondente aggiornamento del Fast Search, avete le stesse versioni installate ?

Ricordo poi che ad un certo punto c'è stato un aggiornamento di Windows 10 che ha rallentato in maniera davvero drastica le prestazioni di rete per le cartelle con più di 1000 file. C'è un qualcosa da disabilitare ma al momento non ricordo cosa. Dopo lo cerco.

Ciao
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#4
Che il fast search smetta di funzionare e' un problema ricorrente, a me lo fa ad ogni aggiornamento di Windows. Per risolvere nel mio caso bisogna ri-registrare una dll come anministratore (parlo del computer su cui viene utilizzato solid edge, non del server):

Codice:
cd "c:\Program Files\Solid Edge ST9\Program"
regsvr32 /s SEPropertyHandler.dll
Di solito, dopo aver fatto questo bisogna killare il processo explorer di windows e riavviarlo (lo fai da task manager).

Con i "never-ending-update" di Windows 10 ho pensato bene di mettere quelle due istruzioni in un batch che viene eseguito automaticamente ad ogni avvio del computer, altrimenti ci passavo la vita.

Qui' trovi un po' tutta la storia che io ti ho condensato in poche righe:
https://community.plm.automation.si...stacles-to-Solid-Edge-Fast-Search/ba-p/368416
 

e.ferriani

Utente Junior
Professione: disegno/progetto meccanico; ex programmatore cam
Software: Solid Edge 17...SE2019, Featurecam, altri cad
Regione: emilia
#5

e.ferriani

Utente Junior
Professione: disegno/progetto meccanico; ex programmatore cam
Software: Solid Edge 17...SE2019, Featurecam, altri cad
Regione: emilia
#6
Che il fast search smetta di funzionare e' un problema ricorrente, a me lo fa ad ogni aggiornamento di Windows. Per risolvere nel mio caso bisogna ri-registrare una dll come anministratore (parlo del computer su cui viene utilizzato solid edge, non del server):

Codice:
cd "c:\Program Files\Solid Edge ST9\Program"
regsvr32 /s SEPropertyHandler.dll
Di solito, dopo aver fatto questo bisogna killare il processo explorer di windows e riavviarlo (lo fai da task manager).
Era già implementato. Grazie.