Esportazione in formato stl

spodus

Utente poco attivo
Professione: studente
Software: Catia V5, SolidEdge, Solidworks, Inventor
Regione: Liguria
Buongiorno a tutti,
sono Luca uno studente iscritto all'ultimo anno di ingegneria meccanica presso il politecnico di Milano. Per il mio lavoro di tesi mi trovo ad usare il software openFoam, un CFD opensource. La geometria oggetto di indagine è il recente etr1000 (nome commerciale frecciarossa 1000) che mi è stato fornito come assembly catia. Dovendo fornire la geometria ad openFoam, e leggendo quest'ultimo il formato stl, mi sono informato riguardo alla conversione di file catia in stl e ho letto che è possibile convertire in formato stl solo i file di tipo part e non i file di tipo product. Mi confermate che non è possibile esportare un file product in formato stl?

Sono consapevole del fatto che posso convertire agevolmente un file product in part con il comando ''generate part from product'' ma purtroppo quando provo questa soluzione con l'assembly del treno non riesce a convertirmi tutto e mi da errore. Sarebbe perciò preferibile se vi fosse l'opportunità di convertire direttamente il product in stl senza passare per la conversione in part.

Grazie mille per la vostra attenzione e buona giornata!

Luca
 

Joshua662

Guest
Buongiorno a tutti,
sono Luca uno studente iscritto all'ultimo anno di ingegneria meccanica presso il politecnico di Milano. Per il mio lavoro di tesi mi trovo ad usare il software openFoam, un CFD opensource. La geometria oggetto di indagine è il recente etr1000 (nome commerciale frecciarossa 1000) che mi è stato fornito come assembly catia. Dovendo fornire la geometria ad openFoam, e leggendo quest'ultimo il formato stl, mi sono informato riguardo alla conversione di file catia in stl e ho letto che è possibile convertire in formato stl solo i file di tipo part e non i file di tipo product. Mi confermate che non è possibile esportare un file product in formato stl?

Sono consapevole del fatto che posso convertire agevolmente un file product in part con il comando ''generate part from product'' ma purtroppo quando provo questa soluzione con l'assembly del treno non riesce a convertirmi tutto e mi da errore. Sarebbe perciò preferibile se vi fosse l'opportunità di convertire direttamente il product in stl senza passare per la conversione in part.

Grazie mille per la vostra attenzione e buona giornata!

Luca


Buongiorno Luca

la procedura che hai usato è per caso questa?

1) apri il catproduct
2) ottieni una cartpart dal product
3) apri la parte aprena creata
4) slava con nome e scegli estensione stl.

Fammi fare qualche prova e vede se è un problema di software.
 

spodus

Utente poco attivo
Professione: studente
Software: Catia V5, SolidEdge, Solidworks, Inventor
Regione: Liguria
Buongiorno Luca

la procedura che hai usato è per caso questa?

1) apri il catproduct
2) ottieni una cartpart dal product
3) apri la parte aprena creata
4) slava con nome e scegli estensione stl.

Fammi fare qualche prova e vede se è un problema di software.

Ciao Joshua662 e grazie mille per la tua rapida risposta!

La procedura è proprio quella e so che funziona perchè ho fatto delle prove con dei products semplici. Il mio problema è però che non riesco a trasformare in parte il treno+pantografi+isolatori ecc... quindi se potevo evitarmi il passaggio a part era meglio ;)
temo però che ciò non sia possibile

Luca
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
Sono consapevole del fatto che posso convertire agevolmente un file product in part con il comando ''generate part from product'' ma purtroppo quando provo questa soluzione con l'assembly del treno non riesce a convertirmi tutto e mi da errore.

Ciao Luca,

dovresti descrivere il tipo di errore e mandare qualche immagine, per comprendere e risolvere il problema.

Può darsi che il prodotto che ti hanno passato abbia all'interno qualche parte mancante oppure qualche parte con superfici degenerate che producono qualche errore e si tratta di isolarlo, o contiene CGR che non sono convertibili ecc.

Oppure si potrebbe convertire in step e verificare se il problema persiste.

Fammi sapere.

Ciao

Gianni
 

spodus

Utente poco attivo
Professione: studente
Software: Catia V5, SolidEdge, Solidworks, Inventor
Regione: Liguria
Ciao Luca,

dovresti descrivere il tipo di errore e mandare qualche immagine, per comprendere e risolvere il problema.

Può darsi che il prodotto che ti hanno passato abbia all'interno qualche parte mancante oppure qualche parte con superfici degenerate che producono qualche errore e si tratta di isolarlo, o contiene CGR che non sono convertibili ecc.

Oppure si potrebbe convertire in step e verificare se il problema persiste.

Fammi sapere.

Ciao

Gianni


Ciao Gianni e grazie per la disponibilità.

Il mio assembly è composto da varie parti ma mi compare errore già solo se faccio i seguenti passi:

-creo nuovo prodotto
-trascino la parte corrispondente al treno (etr1000)
-trascino la parte corrispondente all'infrastruttura dei binari (ballast)
-vado in ''tools''-->''generate part from product''

ti lascio in allegato lo screenshot con l'errore che compare: non si capisce molto purtroppo... in rosso c'è il ballast e del treno mi ha tenuto solo alcune parti dell'imperiale (tetto) che vedi in grigio... manca tutta la parte delle carrozze sotto..error.png


se poi provo a fare un aggiornamento locale del treno (''train'' nel tree) mi dà il seguente errore:
error2.png
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
Ciao Luca,

siamo in presenza di mancato aggiornamento dovuto ad errori nelle parti.

Il sistema richiede che questi errori vengano risolti e ci sono modi diversi per farlo (modificando, isolando, disattivando, eliminando l'entità ecc.) ma questo richiede l'analisi diretta di ogni errore e non è possibile un consiglio "generalizzato".

E' preferibile non divulgare file di cui non si è proprietari sul Forum.

Ti ho mandato un Messaggio Privato.

Ciao

Gianni
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
-creo nuovo prodotto
-trascino la parte corrispondente al treno (etr1000)
-trascino la parte corrispondente all'infrastruttura dei binari (ballast)
-vado in ''tools''-->''generate part from product''

Evita di trascinare la parte, ma una volta creato il prodotto:

Menù/inserisci/nuova parte (e inserisci le varie parti).

Anche se immagino (e spero) ti abbiano fornito il prodotto originale, che carica già tutte le parti in posizione.

Altra cosa che puoi fare è quella di aprire singolarmente le parti per verificare quale (o quali) generano errori, questo perché in presenza di errore il processo si "pianta" in questo modo eliminando le parti da risolvere puoi andare comunque avanti nel processo.

Prova anche a salvare in step e poi ricaricare lo step ed eseguire la AllCatPart

Fammi sapere

Ciao
 

Utenti online

Statistiche forum

Discussioni
55,991
Messaggi
477,635
Utenti registrati
96,836
Ultimo utente registrato
pinom

Top