CREAZIONE PARTE IN UN ASSIEME, non si aggiorna parte

Giancesa

Utente Junior
Professione: progettista meccanico
Software: SOLIDWORKS 2020
Regione: veneto
Ho creato una parte in un assieme (coperchio rettangolare), cliccando sul piano di un componente dell'assieme stesso (una scatola), in sostanza volevo creare un coperchio di una scatola, che si aggiornasse in automatico se cambiavo le dimensioni della scatola. Sono andato in un secondo momento a modificare le dimensioni della scatola ma il coperchio non si aggiorna. nel coperchio si vedono i contorni "neri" risolti, ma non si aggiornano.
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: SolidEdge
Regione: Friuli Venezia Giulia
Dipende da come hai creato il coperchio. Se lo hai relazionato alla scatola allora si modificherà altrimenti no. E dipende anche da come modifichi la scatola.
nel coperchio si vedono i contorni "neri" risolti, ma non si aggiornano.
I contorni neri significa solo che lo schizzo è completamente definito.

Dare risposte su problemi di specifici file non è possibile, a maggior ragione se sono stati creati da chi non ha dimestichezza con il software.
Come hai creato lo schizzo? Lo hai relazionato? E' un banale converti entità? Come possiamo saperlo?
In inventor con questa tua descrizione sarebbe esistito un solo e unico modo per fare lo schizzo e di conseguenza dire perché non funziona?
 

Giancesa

Utente Junior
Professione: progettista meccanico
Software: SOLIDWORKS 2020
Regione: veneto
Facendo crea componente nell'assieme, ho cliccato il piano superiore della scatola, da dove appunto sarà appoggiato il coperchio, e poi ho iniziato a tracciare lo schizzo, partendo dagli spigoli della scatola. La domanda forse se devo proiettare prima gli spigoli della scatola sula piano dello schizzo del coperchio ?
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: SolidEdge
Regione: Friuli Venezia Giulia
La domanda è: lo schizzo del coperchio è relazionato alla scatola? Sono in qualche modo collegati (che abbiano lo stesso piano è in questo specifico caso poco importante)?
Non staresti meno ad allegare il file?
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx 2019 - R2W2019 - Composer 2019
Regione: Veneto
Per essere certo che esistano relazioni tra i due dovresti avere dei riferimenti esterni. Quando in una funzione sono presenti riferimenti esterni, alla fine della funzione vedi il simbolo "->". Se il simbolo è come scritto il riferimento è corretto e funziona. Se il simbolo è così "->?" significa che il riferimento esiste, ma non è risolto e quindi non funziona. Se non è risolto significa che hai fatto qualche errore nella gestione dei riferimenti esterni (tanto utili ed affidabili quanto "delicati" da gestire). Metti uno screenshot, così non capiamo la situazione.
 

Giancesa

Utente Junior
Professione: progettista meccanico
Software: SOLIDWORKS 2020
Regione: veneto
Ho provato ma non riesco. Ho provato a fare con converti entità ma non si lega. Dovrei vedere tutta la procetura corretta passo passo, non so sai dove posso trovare un tutorial "creare parte dall'interno dell'assieme.
 

MassiVonWeizen

Utente Senior
Professione: disegnatore
Software: SolidEdge
Regione: Friuli Venezia Giulia
Se tu allegassi il file, come già detto, sarebbe più facile.
Converti entità collega crea dei riferimenti è imprescindibile. Se non te lo fa non hai fatto la procedura correttamente.
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx 2019 - R2W2019 - Composer 2019
Regione: Veneto
Ho provato ma non riesco. Ho provato a fare con converti entità ma non si lega. Dovrei vedere tutta la procetura corretta passo passo, non so sai dove posso trovare un tutorial "creare parte dall'interno dell'assieme.
se alleghi i files ci do un occhio, altrimenti è troppo complesso aiutarti. Uso i riferimenti esterni in modo pesante dalla V99 ed hanno sempre funzionato perfettamente, non sono mai stati oggetto di bug che ne compromettessero l'affidabilità. Vanno capiti e bisogna imparare a gestirli, tutto qui. Per caso... giusto per fare delle ipotesi, hai abilitato il comando di assieme "nessun riferimento esterno" ?
 

Giancesa

Utente Junior
Professione: progettista meccanico
Software: SOLIDWORKS 2020
Regione: veneto
Ho rifatto i passaggi, e ora funziona: coperchio e scatola sono collegati.
 

Staff online

Statistiche forum

Discussioni
55,255
Messaggi
472,304
Utenti registrati
95,086
Ultimo utente registrato
daviss

Top