• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Zombie in assembly

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#1
Salve a tutti,

Mi è capitato sotto mano un assieme in cui uno dei par di cui e composto viene visualizzato in maniera errata, nello specifico quando visualizzo l'assieme mi fa vedere il pezzo con una determinata forma(ipotizzo, che questa fosse la forma di una vecchia revisione del pezzo), ma se provo ad aprirlo me lo fa vedere nella sua forma corretta; ho provato ad aggiornare e a verificare eventuali errori con i comandi del menu strumenti, ho anche provato a sostituire il par con una copia di se stesso rinominata con revision manager, ma all'apertura dell'assieme continua a visualizzare il par con un'altra forma rispetto quella visibile all'interno del par.

A qualcuno e mai capitata una cosa simile???
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#2
Salve a tutti,

Mi è capitato sotto mano un assieme in cui uno dei par di cui e composto viene visualizzato in maniera errata, nello specifico quando visualizzo l'assieme mi fa vedere il pezzo con una determinata forma(ipotizzo, che questa fosse la forma di una vecchia revisione del pezzo), ma se provo ad aprirlo me lo fa vedere nella sua forma corretta; ho provato ad aggiornare e a verificare eventuali errori con i comandi del menu strumenti, ho anche provato a sostituire il par con una copia di se stesso rinominata con revision manager, ma all'apertura dell'assieme continua a visualizzare il par con un'altra forma rispetto quella visibile all'interno del par.

A qualcuno e mai capitata una cosa simile???
Non sarà che il pezzo contiene una versione "semplificata" ed in assembly viene mostrata questa ?
 

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#3
Mhhh, ho verificato, purtroppo no, il par non include neanche delle geometrie semplificate Zombi in assembly.JPG
 

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#5
Vedo che nell'assieme ci sono delle feature di assieme, probabilmente una di queste lo va a "modificare".

Ciao
Purtroppo anche questa strada è già stata provata: cancellate tutte... salvato, riaggiornato, ma il pezzo rimane sempre visualizzato errato, l'unica soluzione sembra essere cancellarlo e reinserirlo, allora lo visualizza in maniera corretta, pero poi è da vincolare di nuovo :frown: :frown: :frown:.

Avevo sentito parlare di questa problematica ma non mi ci ero mai scontrato fino ad ora.

Grazie comunque per il tuo aiuto, molto apprezzato.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#6
Purtroppo anche questa strada è già stata provata: cancellate tutte... salvato, riaggiornato, ma il pezzo rimane sempre visualizzato errato, l'unica soluzione sembra essere cancellarlo e reinserirlo, allora lo visualizza in maniera corretta, pero poi è da vincolare di nuovo :frown: :frown: :frown:.

Avevo sentito parlare di questa problematica ma non mi ci ero mai scontrato fino ad ora.

Grazie comunque per il tuo aiuto, molto apprezzato.
A volte le feature di assieme si comportano in modo strano, solitamente è sufficiente chiedere e riaprire l'assieme per forzare un aggiornamento (se le hai eliminate\ modificate).

Ciao
 

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#7
A volte le feature di assieme si comportano in modo strano, solitamente è sufficiente chiedere e riaprire l'assieme per forzare un aggiornamento (se le hai eliminate\ modificate).

Ciao
Si a volte e un pò "ignorantino":smile::smile::smile:, detto con affetto

Grazie alla prossima

Alex
 

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#8
Se fa l'ignorante, io proverei con l'assieme chiuso ad aprire il part (o tutti), per forzare un ricalcolo della geometria: alle volte è sufficiente un salva, altre volte siesegue una doppia modifica a una quota della prima feature (cioè modifico una quota , lascio ricalcolare le feature, reimposto il valore iniziale).
Se non ci sono collegamenti, non ci sono famiglie di assiemi dovrebbe essere una operazione sufficiente.
All'interno del file la "geometria" ha una sua sorta di versione/data ; che consente ai file collegati "asm" e "Dft" di conoscere se il part ha subito modifiche alla geometria oppure è semplicemente stato copiato e rinominato. Per questo con la prova che hai fatto con revision manager la copia si è comportata come l'originale.
 

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#9
Se fa l'ignorante, io proverei con l'assieme chiuso ad aprire il part (o tutti), per forzare un ricalcolo della geometria: alle volte è sufficiente un salva, altre volte siesegue una doppia modifica a una quota della prima feature (cioè modifico una quota , lascio ricalcolare le feature, reimposto il valore iniziale).
Se non ci sono collegamenti, non ci sono famiglie di assiemi dovrebbe essere una operazione sufficiente.
All'interno del file la "geometria" ha una sua sorta di versione/data ; che consente ai file collegati "asm" e "Dft" di conoscere se il part ha subito modifiche alla geometria oppure è semplicemente stato copiato e rinominato. Per questo con la prova che hai fatto con revision manager la copia si è comportata come l'originale.
Salve Vespa,
Grazie per il tuo contributo, ho provato a editare il par "incriminato" e ad effettuare nuovamente il salvataggio (ho poi provato a effettuare la stessa procedura su tutti gli altri par), purtroppo anche questa maniera non ha generato nessun effetto in ambiente assembly, per il resto l'assembly è "pulito", nel senso: è salvato in locale e non ha collegamenti di nessun tipo, o famiglie di assieme, o parti semplificate, o dft.

L'unica cosa di cui mi sono accorto operando la tua procedura (editare e risalvare) analizzando il pathfinder, è che il pezzo (la forma) che viene visualizzato in ambiente assembly non è minimamente presente tra le feature delle lavorazioni, sembra che il par visualizzato in assembly sia completamente estraneo a quanto effettivamente disegnato dentro il par

Rimango perplesso :frown::frown::frown:

Comunque grazie per il tuo supporto :36_1_11:

Alex
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#10
Puoi postare l'assieme e tutte le sue parti o si tratta di materiale riservato ?
 

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#11
Puoi postare l'assieme e tutte le sue parti o si tratta di materiale riservato ?
L'assieme zippato è di circa un paio di MB, se non è troppo pesante non credo sia un problema

Prima di postarlo aggiungo anche un'errata corrige, di cui mi scuso per non aver controllato prima, sul par incriminato non ci sono feature d'assieme operanti, ma se comunque le cancello tutte e salvo l'assembly, allora aggiorna il pezzo.
 

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#12
Nella definizione delle feature d'assieme puoi specificare quali pezzi deve tenere in considerazione.

Se noti che cancellando le feature d'assieme, risolvi il problema, valuta se hai bisogno delle feature a livello di assieme o puoi metterle a livello di parte, oppure valuta se rifarle, magari da nuove non danno problemi.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#13
La mia idea è che la parte incriminata era un tempo interessata dalle feature di assieme.
Le feature di assieme generano geometria all'interno dell'assieme stesso, geometria che va a rimpiazzare quella delle parti interessate.

Il tuo problema è la geometria dell'assieme (generata dalle feature di assieme) che non si è rigenerata.

Come dice Vespa, ricreando le feature di assieme dovresti risolvere il problema.

Ciao
 

A.Lelli

Utente Junior
Professione: impiegato ufficio tecnico
Software: Siemens UGS NX 6, SolidWorks, Autocad, Solid Edge
Regione: Emilia Romagna
#14
Nella definizione delle feature d'assieme puoi specificare quali pezzi deve tenere in considerazione.

Se noti che cancellando le feature d'assieme, risolvi il problema, valuta se hai bisogno delle feature a livello di assieme o puoi metterle a livello di parte, oppure valuta se rifarle, magari da nuove non danno problemi.
Oki, ne terro conto, per ora spero vada bene cosi.

Grazie mille a tutti

Alex