• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Uso generatori di Telai

gil

Utente Senior
Professione: Scarabocchiatore
Software: Cadsauro (il cad con la clava)
Regione: Italia
#1
Ciao
Usando il generatore di telai per costruire un telaio metallico tubolare ho notato il seguente problema.
Nella messa in tavola quando genero una tabella con la lista parti, queste non vengono compuate correttamente.

Se ad esempio il telaio è un seplice rettangolo di lati 2m e 1m mi aspetto di vedere qualcosa tipo
Quantita, lunghezza, tot lunghezza
n°2pz, 2000mm, 4000mm
n°2pz, 1000mm, 2000mm

Ed invecce appare un generico
Quantita, lunghezza, tot lunghezza
n°1pz, varie, 6000mm

Il problema non si presenta se realizzo il telaio con parti singole senza generatore.

Sbaglio da qualche parte, oppure il generatore ha questa limitazione?
 

Jarno

Utente Junior
Professione: e
Software: SE ST5, Inventor, Me10, Swx 2009
Regione: e
#2
no, sbagli qualcosa tu.
Ora perdonami ma in ufficio ho solo una rel. veccha di Inv e quindi devo andare a memoria.
In Assieme, prendi la distinta componenti e verifica che siano tutti computati, che abbiano codici di parte diversi e che sia attiva la BOM ... non mi ricordo... insomma hai 3 tipi di BOM, solo in 2 modalità puoi vedere i singoli tubolari, però non ricordo bene il settaggio, dovrei farlo, cmq la chiave di volta è quella
 

gil

Utente Senior
Professione: Scarabocchiatore
Software: Cadsauro (il cad con la clava)
Regione: Italia
#3
Grazie
Se creo la lista dal modello assieme come dici te, il problema non si presenta.
Se invece provo a creare la lista dal file di disegno "idw", succede come detto sopra.
 

Jarno

Utente Junior
Professione: e
Software: SE ST5, Inventor, Me10, Swx 2009
Regione: e
#4
E' così perchè di default la BOM diventa in modalità "tutto in calderone". Qualcosa si riesce a fare anche direttamente dall IDW, ma è meglio che ti abitui a lavorare la BOM dallo IAM : + potente e + certi i risultati.
ciao
 

Tarkus

Utente Senior
Professione: Progettista,Disegnatore
Software: Autocad Mechanical,Inventor 2017,HyperMill2012
Regione: Toscana
#6
Ciao
Usando il generatore di telai per costruire un telaio metallico tubolare ho notato il seguente problema.
Nella messa in tavola quando genero una tabella con la lista parti, queste non vengono compuate correttamente.

Se ad esempio il telaio è un seplice rettangolo di lati 2m e 1m mi aspetto di vedere qualcosa tipo
Quantita, lunghezza, tot lunghezza
n°2pz, 2000mm, 4000mm
n°2pz, 1000mm, 2000mm

Ed invecce appare un generico
Quantita, lunghezza, tot lunghezza
n°1pz, varie, 6000mm

Il problema non si presenta se realizzo il telaio con parti singole senza generatore.

Sbaglio da qualche parte, oppure il generatore ha questa limitazione?
Io mi trovo bene cosi':
-clic Dx sull'elenco parti nella messa in tavola,
-scegli" modifica elenco parti" (N.B. non "stile elenco parti)
nella finestra che appare, clic sulla prima icon in alto a sinistra per scegliere le colonne dell'elenco:
Aggiungi le proprietà:
-Quantità di base
-Quantità elementi.
Falle scorrere in alto prima di "quantità"
chiudi il tutto.
Adesso in elenco hai quanti pezzi hai per tipo e per lunghezza e la lunghezza complessiva dei ogni tipo :smile:
Se fai molte messe in tavola di telai fatti con FG, non sarebbe da scartare di farti un template .idw con l'elenco parti ad hoc.
 

gil

Utente Senior
Professione: Scarabocchiatore
Software: Cadsauro (il cad con la clava)
Regione: Italia
#7
Risultato che ho ottenuto con il meodo suggeto da tarkus
Quantità | Quantitò di base | Quantità elementi | Descrizione
6000mm | *varie* | 4 | *varie*

Modificando da "editor stili" o da "modifica elenco parti" non mi pare cambi la cosa in modo sostanziale.
 

Catafratto

Utente Standard
Professione: Disegnatore/progettista
Software: Inventor 2016
Regione: Veneto
#8
A suo tempo, se non ricordo male, per risolvere detto problema, mi ero fatto una copia modificabile della libreria dei profili e modificato le impostazioni in modo che il numero di parte fosse collegato alla lunghezza, ed impostando nella distinta i raggruppamenti in base al numero di parte. Insomma, un tubo rett. 100x50x2 con taglio (G_L) = 1000 sarà TR(100x050x02)x1000. La distinta li raggrupperà tutti. Allego esempio.
 

Allegati

Tarkus

Utente Senior
Professione: Progettista,Disegnatore
Software: Autocad Mechanical,Inventor 2017,HyperMill2012
Regione: Toscana
#9
Risultato che ho ottenuto con il meodo suggeto da tarkus
Quantità | Quantitò di base | Quantità elementi | Descrizione
6000mm | *varie* | 4 | *varie*

Modificando da "editor stili" o da "modifica elenco parti" non mi pare cambi la cosa in modo sostanziale.
Bho, a me funziona bene,non mi mette nessun voce "Varie"
 

gil

Utente Senior
Professione: Scarabocchiatore
Software: Cadsauro (il cad con la clava)
Regione: Italia
#10
Ho verificato che il problema era dovuto all'uso di profili personalizzati, creati male.
Ringrazio tutti per l'assistenza e la pazienza. Grazie alle vostre indicazione ho potuto scartare le divrse possibilità e recuperare l'errore.