Trailing zero / zero finali

etc

Utente Junior
Professione: 3D Hobbist
Software: Blender
Regione: Sicilia
#1
Gentili utenti,
Ho un piccolo grattacapo con gli zeri finali in NX, modulo di modellazione.
In pratica, vorrei utilizzare 3 cifre decimali, ma omettere gli zeri.
Benché abbia provato qualsiasi settaggio, NX non sembra voglia darmi questa soddisfazione.

Inoltre ho pure il fastidioso ( per me ) problema che, se ho ad esempio una quota di 10.46 mm.. l'arrotonda a 10.5... :confused:

Qualcuno può chiarirmi le idee ? poiché non sono riuscito a trovar nulla online, ed ho cercato parecchio.

Thanks.
 

ceschi1959

Utente Standard
Professione: progettista
Software: UG 11 - NX11 TC10
Regione: veneto
#2
Gentili utenti,
Ho un piccolo grattacapo con gli zeri finali in NX, modulo di modellazione.
In pratica, vorrei utilizzare 3 cifre decimali, ma omettere gli zeri.
Benché abbia provato qualsiasi settaggio, NX non sembra voglia darmi questa soddisfazione.

Inoltre ho pure il fastidioso ( per me ) problema che, se ho ad esempio una quota di 10.46 mm.. l'arrotonda a 10.5... :confused:

Qualcuno può chiarirmi le idee ? poiché non sono riuscito a trovar nulla online, ed ho cercato parecchio.

Thanks.
Se parli di modellazione devi andare su questo pannello e settare i valori appropriati.

Ciao
 

Allegati

etc

Utente Junior
Professione: 3D Hobbist
Software: Blender
Regione: Sicilia
#3
Intendo, quando creo gli sketch per le varie features.
Se ad esempio ho una quota di 6.035
esempio.png
perchè mi viene visualizzato solo 6.0 ?

@ceschi1959
Ho guardato al pannello che mi hai detto te, le impostazioni sono identiche, avevo già trovato qualcuno, su altro forum, che puntasse allo stesso pannello ma non è cambiato nulla.

Ho settato le impostazioni delle Annotazioni come segue
trailings.png dimensions.png

L'opzione Trailing Zero, disattivata, dovrebbe omettere gli zeri finali.
Inoltre dovrebbero essere mostrate 3 cifre decimali.

Gli zeri finali non vengono nascosti e le quote vengono mostrate con arrotondamento in eccesso o difetto.
il 6.035 diventa 6.0 :confused:
Dev'esserci qualcosa che mi sfugge.
Grazie per la risp cmq ;)
 

The_Matrix

Utente Senior
Professione: Industry Leader - Automotive & Machinery
Software: NX10/TC10/4GD
Regione: Mi piacerebbe lavorare in California... Invece sto in Piemonte. Pazienza...
#4
Io ho 3 decimali e le quote degli sketch mi vengono correttamente visualizzate:
- 3 decimali nel caso di quota "decimale" (80.777)
- 0 decimali in caso di quota "esatta"
Ho la NX8.5.1 e la NX9Ph7

Unica cosa che ho visto è che se nella quota dello sketch (mettiamo sia 200) metto:
- 200 : OK
- 200.111 : OK
- 200 : Viene visualizzato 200.000, anche se ho disattivato i Trailing zero
 

ceschi1959

Utente Standard
Professione: progettista
Software: UG 11 - NX11 TC10
Regione: veneto
#5
Scusa il ritardo nella risposta ma ho avuto una settimana un po' piena. Il settaggio che è mostrato nella seconda immagine l'hai settato nei customer default o in locale?
 

etc

Utente Junior
Professione: 3D Hobbist
Software: Blender
Regione: Sicilia
#6
@ceschi1959
Buongiorno, no problem per il "ritardo", nessun ritardo ;)!
L'unico posto in cui ho potuto settare quelle impostazioni è stato in
Customer Default -> Drafting -> General -> Drafting Standard
ed in
Preferences -> Annotations