Tasto decimale

delki

Utente Standard
Professione: Tecnical Support e Formazione su Solid Edge e SolidRules
Software: Solid Edge, Visual Basic .NET, SolidRules: InCentro, Desk, Configurator Manufactoring, Studio
Regione: Veneto
#21
IBm distribuiva la famosa "italia 142", quello che si è diffuso è la tastiera "Italia" puoi controllare tu stesso nel pannello di controllo.
Sia la tastiera inglese che la tastiera americana hanno un layout differente per tutti i simboli.
Quello che è scritto nel pannello di controllo non conta. Posso impostare quello che voglio. Le tastiere le definiacono a layout italiano
 

delki

Utente Standard
Professione: Tecnical Support e Formazione su Solid Edge e SolidRules
Software: Solid Edge, Visual Basic .NET, SolidRules: InCentro, Desk, Configurator Manufactoring, Studio
Regione: Veneto
#22
Se son pochi basterebbe imbrogliare :biggrin: (in buona fede e per una nobile causa) nel numero di richieste.
Dite alla siemens che tutti i vs. clienti richiedono che venga sistemato il problemino del punto decimale sul tastierino numerico.
Non ho idea della complessità di programmazione, ma non penso che ci perdano più di tanto tempo ad implementare su un prossimo maintenance pack una cosa del genere.
Purtroppo non funziona cosi, ogni singolo chiente deve aprire un IR.
 

delki

Utente Standard
Professione: Tecnical Support e Formazione su Solid Edge e SolidRules
Software: Solid Edge, Visual Basic .NET, SolidRules: InCentro, Desk, Configurator Manufactoring, Studio
Regione: Veneto
#23
Potrebbe essere interessante aprire un post dove ogni uno posta i propri ER e cosi altri utenti possono richiederne la sottoscrizione al proprio rivenditore, non so però che forza di "impatto"possano esprimere gli utenti del forum
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#24

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#25
io cambio il layout: -123'456'789.00
Per la solid edge trascurare il separatore delle migliaia e interpretare sempre come separatore sarebbe molto semplice.
In molti siti se inserisci un numero decimale, sia che metti una virgola o un punto ti accettano il valore (bravo il programmatore!).

Vi segnalo per conoscenza un problema che ho avuto con questi problemi di locazione.
Ho fatto un file di Excel e poi l'ho caricato in Google Drive, per condividerlo a un fornitore
Mi ha trasformato tutte le celle con valori decimali (e tutte le formule derivate) in "orari"
1.50 --> 1.50.00

non se ne esce più!


Attenzione e occhi sempre aperti!
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#26
io cambio il layout: -123'456'789.00
Per la solid edge trascurare il separatore delle migliaia e interpretare sempre come separatore sarebbe molto semplice.
In molti siti se inserisci un numero decimale, sia che metti una virgola o un punto ti accettano il valore (bravo il programmatore!).

Vi segnalo per conoscenza un problema che ho avuto con questi problemi di locazione.
Ho fatto un file di Excel e poi l'ho caricato in Google Drive, per condividerlo a un fornitore
Mi ha trasformato tutte le celle con valori decimali (e tutte le formule derivate) in "orari"
1.50 --> 1.50.00

non se ne esce più!


Attenzione e occhi sempre aperti!
Stessa cosa che dicevo io al messaggio 9.
 

ApeGana

Utente Standard
Professione: Progettista
Software: Solid Edge ST8
Regione: Marche
#27
In 10 anni ho sempre lavorato con la soluzione "barbara" :tongue: di scambiare virgola e punto tra separatore decimale e separatore migliaia nel pannello di controllo di windows.
Ora con il nuovo gestionale che abbiamo comprato abbiamo problemi ad usare il punto per i decimali e allora ho tentato la strada della tastiera italiana 142, descritta qui.

Due giorni fa, appena modificate le impostazioni, sembrava funzionare tutto correttamente.
Oggi Solid Edge, senza apparente motivo, ha ripreso ad interpretare il tasto del tastierino numerico come punto e non come virgola... e quindi non funziona perché a questo punto lui vuole la virgola!! :mad:

Ho ricontrollato le impostazioni in pannello di controllo e sembrano tutte corrette. Con Notepad il tastierino numerico mi dà una virgola, come in effetti dovrebbe; con Word pure. Boh! :confused:

Qualche suggerimento?
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#28

ApeGana

Utente Standard
Professione: Progettista
Software: Solid Edge ST8
Regione: Marche
#29
Ok, grazie.
Credo proverò a rimappare, anche perché con la tastiera ITA 142 c'è anche il grosso fastidio che si "spostano" parecchi simboli: parentesi quadre, chiocciola.....
Ciao
 

D4nielsan

Utente Junior
Professione: Tech
Software: 3D
Regione: Veneto
#30
Io ho risolto con il mio programma preferito per le Macro :
e vale solo per SE

AutoHotKey

in 3 semplici righe aggiunte al mio script abituale:

;~ - Solo se attivo SolidEdge
#IfWinActive ahk_class EngineFrame
.::, ; Sostituisci punto con una virgola
;~ #IfWinActive ; This puts subsequent remappings and hotkeys in effect for all windows

Buona sperimentazione a tutti!

D4nielsan.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#31
Io ho risolto con il mio programma preferito per le Macro :
e vale solo per SE

AutoHotKey

in 3 semplici righe aggiunte al mio script abituale:

;~ - Solo se attivo SolidEdge
#IfWinActive ahk_class EngineFrame
.::, ; Sostituisci punto con una virgola
;~ #IfWinActive ; This puts subsequent remappings and hotkeys in effect for all windows

Buona sperimentazione a tutti!

D4nielsan.
E se devi inserire un testo in un disegno dove ti occorre il punto ?