SW 2012 SOTTOASSIEME FLESSIBILE IN CONFLITTO

Professione: progettista
Software: sw
Regione: vicenza
#1
Ciao a tutti,
da molto tempo ho questo problema che neanche l'assistenza tecnica di sw mi ha risolto.
Nel nostro uff tecnico lavoriamo con 2 stazioni.
Se inseriamo in un assieme un assieme impostando la proprietà 'flessibile', come per esempio può capitare con la cerniera di una porta, la cui 'flessibilità' dovrebbe essere la rotazione sul proprio perno.
Se ci capita di avere in entrambe le postazioni due assiemi aperti diversi tra loro ma che entrambi contengono la nostra amata cerniera nascono i problemi:
1) errori anzi avvertimenti sugli accoppiamenti ma che in realtà non dovrebbero avere conflitti
2) il primo che chiude l'assieme riceve la richiesta di salvare il sottoassieme anche se non è stato modificato ma da un errore perchè dice che è aperto in sola lettura perchè aperto anche dall'altro utente
3) chiudendo e riaprendo l'assieme padre gli errori sugli accoppiamenti scompaiono ma dopo un po' appaiono misteriosamente

Abbiamo provato a fare varie prove con assiemi padre semplici e abbiamo capito che il problema si ripresenta in modo sistematico

1° soluzione: smontare il sottoassieme e gestirlo come parti separate (fin che si tratta di una cerniera lo si può anche fare ma non mi sembra corretto)

Il problema diventa più pesante quando si maneggiano cilindri pneumatici.
Se in un assieme ha 2 cilindri entrambi collegati allo stesso pezzo cosa accade? Io di solito ha i cilindri con 3 configurazioni: aperto, chiuso, libero. Un cilindro lo mantengo aperto o chiuso e l'altro libero in modo che segua il primo. Ma se il mio collega ha aperto un assieme che contiene lo stesso cilindro perchè lo condividiamo dalla libreria dei commerciali, si ripresenta lo stesso problema descritto sopra per la cerniera.

Vi è mai capitato qualcosa di simile?
Scusare se sono stato prolisso :)
Grazie per l'attenzione
 
Professione: progettista
Software: sw
Regione: vicenza
#2
Abbiamo fatto delle prove assiemi simili con inventor e il problema non si presenta .... :(
Abbiamo scelto il programma sbagliato
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#5
Grazie per l'interessante consiglio, sembra che ora tutto funzioni !!
Non c' è di ché !

Strusa con le opzioni, c' è un mondo in quelle paginate.
So che può portare a pensare che è ingarbugliato, ma se lo palleggi bene puoi crearti diversi profili di settaggi in base alle
esigenze di uno specifico progetto.
 
Professione: progettista
Software: sw
Regione: vicenza
#6
Me ne sto rendendo conto, molte volte si ha fretta di andare aventi coi progetti e non ci si rende conto dell'importanza di usare bene gli strumenti di lavoro.
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2017 sp2.0, autocad2013, pochino solidedge st7, draftsight
Regione: Lombardia
#7
ciao a tutti mi collego a questa discussione per dire che io ho riscontrato gli stessi problemi di eugenio 78 ma in locale, cioè faccio degli assiemi li inserisco in un assieme e li rendo flessibili il programma si incasina mi da errori su errori di accoppiamento.
Contattato l'assistenza mi dicono che è normale e che gli assiemi flessibili non funzionano!!!!!!!!!!!!!!!!! vado su tutte le furie ma non c'è stato nessuno in grado di risolverlo questo problema io mi sa che ho sbagliato cad qualcuno ne sa qualcosa o succede solo a me????
chiedo c'è un software che non lo fa?

ciao grazie
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#8
ciao a tutti mi collego a questa discussione per dire che io ho riscontrato gli stessi problemi di eugenio 78 ma in locale, cioè faccio degli assiemi li inserisco in un assieme e li rendo flessibili il programma si incasina mi da errori su errori di accoppiamento.
Contattato l'assistenza mi dicono che è normale e che gli assiemi flessibili non funzionano!!!!!!!!!!!!!!!!! vado su tutte le furie ma non c'è stato nessuno in grado di risolverlo questo problema io mi sa che ho sbagliato cad qualcuno ne sa qualcosa o succede solo a me????
chiedo c'è un software che non lo fa?

ciao grazie
Dubito fortemente che l' assistenza di possa aver detto una cosa del genere, o forse era il portinaio del palazzo della solidworks ?...
Senza polemica.
Gli assiemi flessibili vanno "montati" con un certo criterio se non è logico
che gli accoppiamenti vanno in casino.
Posta un file che ti crea problemi e poi ne riparliamo.
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#10
Abbiamo fatto delle prove assiemi simili con inventor e il problema non si presenta .... :(
Abbiamo scelto il programma sbagliato
ciao a tutti mi collego a questa discussione per dire che io ho riscontrato gli stessi problemi di eugenio 78 ma in locale, cioè faccio degli assiemi li inserisco in un assieme e li rendo flessibili il programma si incasina mi da errori su errori di accoppiamento.
Contattato l'assistenza mi dicono che è normale e che gli assiemi flessibili non funzionano!!!!!!!!!!!!!!!!! vado su tutte le furie ma non c'è stato nessuno in grado di risolverlo questo problema io mi sa che ho sbagliato cad qualcuno ne sa qualcosa o succede solo a me????
chiedo c'è un software che non lo fa?
"io mi sa" che avete sbagliato assistenza e in più non vi hanno insegnato a usarlo.:cool:
Ah, casomai aggiorna il tuo profilo e indica che usi SWX 2013 così si evita di scaricare assiemi che poi non si possono aprire o gestire perchè in possesso di una versione precedente.
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#11
ovvio che ti dia errori... metti accoppiamenti un tanto al chilo.
controlla bene, ma proprio bene, quelli dei due sottoassiemi flessibili e fai mea culpa.
ti consiglio di riassemblare tutto usando vincoli di distanza solo se strettamente necessario
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#12
ciao a tutti mi collego a questa discussione per dire che io ho riscontrato gli stessi problemi di eugenio 78 ma in locale, cioè faccio degli assiemi li inserisco in un assieme e li rendo flessibili il programma si incasina mi da errori su errori di accoppiamento.
ovvio che ti dia errori... metti accoppiamenti un tanto al chilo.
C.V.D. :rolleyes:
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2017 sp2.0, autocad2013, pochino solidedge st7, draftsight
Regione: Lombardia
#13
scusa o propio controllato bene ma non capisco cosa c'è che non va :confused:
poi cosa vuol dire di usare accoppiamenti di distanza solo se strettamente necessario?

grazie ciao
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#14
ad esempio il sottoassieme MR15MN è una guida forata alloggiata su una sede forata. hai messo una distanza fra i piani e poi una concentricità fra due fori. che senso ha? metti concentrici altri due fori e togli quella distanza e per magia no problem.
quando assembli in officina due pezzi simili li avviti o li saldi ad una X distanza?
poi vedo la metà degli accoppiamenti sospesi (e non ci sono configurazioni); distanze parrallellismi... se non servono si cancellano.
tieni a mente anche che più accoppiamenti hai più il software deve elaborare nella ricostruzione. ruoti l'assieme e deve rielaborare, sospendi una parte e deve rielaborare, muoci una parte flessibile e deve rielaborare...
non ho controllato ma fai attenzione anche hagli accoppiamenti rindondanti come ad esempio coincidenza e parallelismo.
ripeto il consiglio cancella tutti gli accoppiamenti e rifai il montaggio come fossi in officina. e la flessibilità mettila per ultima. una assieme completamente statico che non dò errori difficilmente li darà se lo trasformi in dinamico
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#15
Ringrazio chi è intervenuto, oggi per me è stata una giornata campale.
stasera a casa gli darò un' occhiata.
Per gli accoppiamenti vale la regola che bisogna usarli con molta parsimonia e non eccedere
con accoppiamenti che potrebbero sovradefinire il montaggio.
Ad esempio due accoppiamenti "coincidente" di due facce possono essere alternati
con un accoppiamento su uno spigolo e l' altro tenerlo accoppiato sulle facce.
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#16
@TESEO

Come promesso ho guardato il file e rimarco ciò che ti è stato consigliato anche dagli altri utenti.
Ho creato un piccolo video, potrà aiutarti. (Disponibile a breve)
Considera che per trovare l' accoppiamento che dava problemi ho sospeso tutti i componenti riattivandoli uno alla volta
partendo dall' alto, logicamente.
Nel video vedrai dunque solo le ultime operazioni che ho fatto per eliminare l' errore.
Ho semplicemente convertito l' accoppiamento "distanza" con "parallelo", nulla di più.
Infatti la distanza è dettata dai due fori che hanno la concentricità e quindi mantengono la giusta
posizione, l' accoppiamento "distanza" sovradefiniva il tutto.
Ciao

[video=youtube_share;AwU2v6IrtdY]http://youtu.be/AwU2v6IrtdY[/video]
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2017 sp2.0, autocad2013, pochino solidedge st7, draftsight
Regione: Lombardia
#17
grandissimiiiii grazie
scusate ma nessuno mi aveva detto di andarci piano con gli accoppiamenti!!!!:frown:
e poi io ero convinto che il programma mi dicesse quando ero sovradefinito nel senso che c'erano più accoppiamenti di quelli necessari; non sarebbe bello che questo lo implementassero????

grazie ora faccio un c..o così all'assistenza.. e pensate che è da un paio d'anni che vado avanti così... e ho chiesto a più di una persona

grazie ciao
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2017 sp2.0, autocad2013, pochino solidedge st7, draftsight
Regione: Lombardia
#18
e quasi dimenticavo è normale che l'accoppiamento di tangenza salti di 180° mentre giro la camme non c'è un modo di bloccarlo(risposta dell'assistenza di oggi) bohh ci dobbiamo pensare, è meglio usare il simulation!!!!!:bekle:
 

eugenio_78

Utente Junior
Professione: progettista
Software: sw
Regione: vicenza
#19
e quasi dimenticavo è normale che l'accoppiamento di tangenza salti di 180° mentre giro la camme non c'è un modo di bloccarlo(risposta dell'assistenza di oggi) bohh ci dobbiamo pensare, è meglio usare il simulation!!!!!:bekle:
? Io non ho mai ricevuto risposte cosi
 

teseo

Utente Standard
Professione: Cantinaro
Software: solidworks2017 sp2.0, autocad2013, pochino solidedge st7, draftsight
Regione: Lombardia
#20
un'altra domanda se non vi sembra troppo l'ordine degli accoppiamenti è importante?