• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Sviluppo lamiera personalizzato

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#22
Mi piaceva la proposta di mettere le pieghe a 90° e poi addrizzare a mano il pezzo, magari come membro di una Famiglia di Parti.
 

Luca70b16

Utente Junior
Professione: Progettista meccanico
Software: Solidedge V20
Regione: Marche
#23
purtroppo non ho sottomano una copia di st8 per fare la prova.
ho seguito le istruzioni passo passo ma esce sempre il solito errore.
in poche parole ho fatto:
registrato la .dll
modificato il file .txt inserendo i valori di spessore, raggio piega, angolo, e allungamento
inserito il valore "ISOTABLE.PZL" nella tabella del materiale

però questo ultimo passaggio non va a buon fine restituendo l'errore di prima.

Ho provato ad avviare solid edge come amministratore, ad usare la funzione lembo al posto di lembo multiplo, ma non cambia
Procedura eseguita e funzionante con V20 x86 su windows 7 x64
1 -verificare se installato Microsoft.NET\Framework\v4.0.30319 (obbligatorio)
2- andare nella cartella C:\Program Files\Solid Edge ST9\Custom\sheetmetal\ISOTable (per SE x64)
2- modificare valori isotable.txt per le proprie esigenze
3- ricompilare la DLL eseguendo Build_Step_1.bat e Build_Step_2.bat, e' utile inserire l' ultima riga con scritto "Pause" nei due file per controllare il corretto funzionamento. Utilizzare versione bit corretta
4 - registrare la DLL con Register32.bat o Register64.bat
5 - avviare solidedge e inserire isotable.pzl nel template .psm

Allego istruzioni tradotte dal txt della V20
 

Allegati

pod

Utente Junior
Professione: -
Software: ST2-ST8
Regione: Toscana
#24
la ricompilazione del dll non posso farla. nella ST2 non so presenti quei file build_step_*.bat
per il resto ho fatto tutto ma esce sempre il solito errore
errore_se.png
 

Luca70b16

Utente Junior
Professione: Progettista meccanico
Software: Solidedge V20
Regione: Marche
#25
Un passo alla volta, i file build_step_*.bat servono per compilare la dll con i tuoi valori personalizzati, senza di quelli registreresti la dll standard con i valori di defaul e non ti servirebbe a niente.Ho cotrollato e sono presenti anche sulla demo dell St9, cio' mi lascia pensare che la procedura sia rimasta invariata; controlla bene o al limite usa quelli della st8 che vedo hai installato.Mi vengono in mente problemi di installazione,quale sistema operativo?,32 o 64 bit?, SE 32 o 64 bit?
PS esegui sempre come amministratore.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#26
Un passo alla volta, i file build_step_*.bat servono per compilare la dll con i tuoi valori personalizzati, senza di quelli registreresti la dll standard con i valori di defaul e non ti servirebbe a niente.Ho cotrollato e sono presenti anche sulla demo dell St9, cio' mi lascia pensare che la procedura sia rimasta invariata; controlla bene o al limite usa quelli della st8 che vedo hai installato.Mi vengono in mente problemi di installazione,quale sistema operativo?,32 o 64 bit?, SE 32 o 64 bit?
PS esegui sempre come amministratore.
Sulle versioni più recenti non è più necessario fare tutto questo in quanto è possibile impostare Solid Edge per leggere i valori da un foglio excel; è la natura evoluzione della funzione senza dover imprecare con problemi di registrazioni DLL.
 

Luca70b16

Utente Junior
Professione: Progettista meccanico
Software: Solidedge V20
Regione: Marche
#27
Concordo sul foglio excel, ma l' utente pod sembra utilizzi ST2 e non so se in quella versione era gia' sviluppata questa funzione, mentre la dll c' e' di sicuro
 

pod

Utente Junior
Professione: -
Software: ST2-ST8
Regione: Toscana
#28
scusate il ritardo. sono stato molto impegnato.
tornando a noi.
non posso utilizzare i file della st8 in quanto non l'abbiamo più installata.
solo per un periodo c'era una macchina con questa versione per fare delle prove ma poi è stata abbandonata.

tutte le operazioni fatte fino ad ora le ho sempre fatte come amministratore.
la nostra versione di solid edge è la ST2 64bit e abbiamo due macchine con windows 8.1 e una con windows 7. tutte e tre a 64bit.
ho provato a fare questa operazione anche sulla macchina con windows 7 ma il problema persiste:frown:
 

Luca70b16

Utente Junior
Professione: Progettista meccanico
Software: Solidedge V20
Regione: Marche
#29
Puoi postare l' immagine del contenuto della cartella C:\Program Files\Solid Edge ST2\Custom\sheetmetal\ISOTable e C:\Program Files\Solid Edge ST2\Custom\sheetmetal\ISOTable\bin ed eventualmente anche il readme delle istruzioni?