Sviluppo lamiera in un assieme

m_arquati

Utente Junior
Professione: Progettista
Software: SW2003
Regione: Emilia Romagna
#1
Ciao a tutti,

ho creato una lamiera, e assemblato altre lamiere su questa. Ora per fissare le altre lamiere ho inserito dei perni filettati (che ho modellato io come parti) usando la ripetizione guidata da funzione e come funzione ho usato quelle dei fori delle altre lamiere.
Tutto in un unico assieme. Ho quindi i perni cche si adagiano sulla lamiera di base e sono concentrici con i fori delle altre che ci stanno sopra.
Tutto ok!

Ma quando devo fare la messa in tavola della sola lamiera di base con la posizione dei perni e lo sviluppo?

Avete già trovato una soluzione?

Grazie mille!
Marco
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#2
Ciao a tutti,

ho creato una lamiera, e assemblato altre lamiere su questa. Ora per fissare le altre lamiere ho inserito dei perni filettati (che ho modellato io come parti) usando la ripetizione guidata da funzione e come funzione ho usato quelle dei fori delle altre lamiere.
Tutto in un unico assieme. Ho quindi i perni cche si adagiano sulla lamiera di base e sono concentrici con i fori delle altre che ci stanno sopra.
Tutto ok!

Ma quando devo fare la messa in tavola della sola lamiera di base con la posizione dei perni e lo sviluppo?

Avete già trovato una soluzione?

Grazie mille!
Marco
Lavoro con lamierati tutti i giorni, però non mi è chiaro il tuo problema.
Posta il file o l' immagine...

Se sei riuscito a fare le altre lamiere non capisco
come mai hai problemi a tracciare la posizione dei grani da sparo.
 

m_arquati

Utente Junior
Professione: Progettista
Software: SW2003
Regione: Emilia Romagna
#3
Ciao,

il mio problema non è posizionare, ma fare in modo che, messa in tavola la lamiera sviluppata, mi si vedano i perni sparati!
I perni sono parti e le ho inserite nell'assieme (insieme alla lamiera che si vede nell'immagine).
Ora, per fare lo sviluppo, devo aprire la parte (la lamiera) e svilupparla.
Ma essendo una parte (che non contiene i perni), non vedo la posizione dei perni e giustamente nemmeno i perni stessi!
Qualche tempo fa facevo delle estrusioni sulla lamiera a simulare i perni, ma non posso farne la distinta...

Grazie
Ciao
Marco
 

Allegati

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#4
Ciao,

il mio problema non è posizionare, ma fare in modo che, messa in tavola la lamiera sviluppata, mi si vedano i perni sparati!
I perni sono parti e le ho inserite nell'assieme (insieme alla lamiera che si vede nell'immagine).
Ora, per fare lo sviluppo, devo aprire la parte (la lamiera) e svilupparla.
Ma essendo una parte (che non contiene i perni), non vedo la posizione dei perni e giustamente nemmeno i perni stessi!
Qualche tempo fa facevo delle estrusioni sulla lamiera a simulare i perni, ma non posso farne la distinta...

Grazie
Ciao
Marco
Devi agire facendolo con una configurazione nella quale attivi la spianatura delle pieghe interessate.
Logicamente devi "prelevare" l' assieme e non solo la lamiera per la
messa in tavola.
 

m_arquati

Utente Junior
Professione: Progettista
Software: SW2003
Regione: Emilia Romagna
#5
Cacchio!!!!

Praticamente bisogna fare un assieme per ogni lamiera con perni sparati?

Ho provato ad inserirli nella parte in lamiera (creando una parte mlticorpo) e usando la ripetizione guidata da schizzo per il posizionamento... funziona perfettamente... ma quando sviluppo la lamiera, i perni non seguono i piani della lamiera aperta ma quelli della lamiera piegata... quindi rimangono nella posizione in cui sarebbero a pezzo finito e non sviluppato (immagine)...

Credo che ritornerò a fare le estrusioni!


Azz!
 

Allegati

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#6
Cacchio!!!!

Praticamente bisogna fare un assieme per ogni lamiera con perni sparati?

Ho provato ad inserirli nella parte in lamiera (creando una parte mlticorpo) e usando la ripetizione guidata da schizzo per il posizionamento... funziona perfettamente... ma quando sviluppo la lamiera, i perni non seguono i piani della lamiera aperta ma quelli della lamiera piegata... quindi rimangono nella posizione in cui sarebbero a pezzo finito e non sviluppato (immagine)...

Credo che ritornerò a fare le estrusioni!


Azz!
Prima di inserire (modellare) i perni come parti multicorpo Distendi la tua lamiera; poi "spara" i perni, fai tutte le operazioni (foratura, ripetizione ecc.) che ti servono e quidi puoi Ripiegare la lamiera.
A sto punto tutti i perni mantengono la loro posizione sia nel piegato che nell'appiattito (anche in tavola) e tutto funziona.

Saluti
Marco
 

m_arquati

Utente Junior
Professione: Progettista
Software: SW2003
Regione: Emilia Romagna
#7
Mitico metodo, ma...

Sai che non mi funziona!!!

Ho la parte Perno M4x10 e la posiziono dopo la funzione ripetizione piatta nell'albero delle features.
mi chiede di fare una parte derivata e si avvia il dialogo di spostamento in cui io imposto i vincoli come se fossi in un assieme... quindi gli dico che la base del perno va sulla faccia della lamiera e che il centro deve essere concentrico con un punto di uno schizzo che giace sulla faccia stessa. tutto ok fin quando disativo la ripetizione piatta: si ripiega tutto ma i perno resta in posizione di quando era piagata...

Manca qualcosa?
Grazie
 

Allegati

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#8
Mitico metodo, ma...

Sai che non mi funziona!!!

Ho la parte Perno M4x10 e la posiziono dopo la funzione ripetizione piatta nell'albero delle features.
mi chiede di fare una parte derivata e si avvia il dialogo di spostamento in cui io imposto i vincoli come se fossi in un assieme... quindi gli dico che la base del perno va sulla faccia della lamiera e che il centro deve essere concentrico con un punto di uno schizzo che giace sulla faccia stessa. tutto ok fin quando disativo la ripetizione piatta: si ripiega tutto ma i perno resta in posizione di quando era piagata...

Manca qualcosa?
Grazie
Ho provato il tuo file e col sistema che ti dicevo funziona benissimo... ma non ho capito come lo hai messo tu il perno. Io l'ho tolto ed ho rifatto "alla mia maniera":biggrin:
Però aspetta:
non devi usare la ripetizione piatta, ma proprio il comando Distendi per aprirla e fare le lavorazioni (inserire perni, features varie ecc.) e poi Piega per richiuderla quando hai finito. Nel feature manager sono chiamate Spiegare e Piegare (e nel tuo Feat Man non c'erano).

Ti riallego il tuo file con i perni inseriti (ne ho messo uno e gli altri con ripetizione, sempre con la lamiera aperta):
View attachment Lamiera 01.rar

Saluti
Marco
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#9
... quindi gli dico che la base del perno va sulla faccia della lamiera e che il centro deve essere concentrico con un punto di uno schizzo che giace sulla faccia stessa.
Poi perchè ti complichi la vita con <<..punto di uno schizzo che giace sulla faccia stessa..>>?
Io ho dato semplicemente la concentricità al perno col foro, non servono schizzi "d'appoggio".

Saluti
Marco
 

m_arquati

Utente Junior
Professione: Progettista
Software: SW2003
Regione: Emilia Romagna
#10
Grazie!

Visto, ma io i perni li devo mettere sulla faccia forellata della scatola...
Alla base, visto che è la faccia base anche nelle operazioni di piega, non succede mai nulla ed anche i perni rimangono sempre corretti perchè la faccia di base non si muove mai... sono le altre che subiscono le pieghe!

Nel file che ho riallegato ho già posizionato i perni nei punti corretti usando come base punti di uno schizzo.
Quando pieghi e spieghi la posizione cambia di brutto!

Nella base, invece, convengo con te che non è necessario perchè puoi usare la concentricità con i fori!


Grazie ancora!
Marco
 

Allegati

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#11
Grazie!

Visto, ma io i perni li devo mettere sulla faccia forellata della scatola...
Alla base, visto che è la faccia base anche nelle operazioni di piega, non succede mai nulla ed anche i perni rimangono sempre corretti perchè la faccia di base non si muove mai... sono le altre che subiscono le pieghe!

Nel file che ho riallegato ho già posizionato i perni nei punti corretti usando come base punti di uno schizzo.
Quando pieghi e spieghi la posizione cambia di brutto!

Nella base, invece, convengo con te che non è necessario perchè puoi usare la concentricità con i fori!


Grazie ancora!
Marco
Hai ragione, scusa.. Pensavo che preparassi la lamiera con dei prefori per i perni. Sì che "dal vero" sparandoli si "autofora", ma qui nel programma avresti compenetrazione di materiale senza il foro. E poi nella realtà i perni li metti prima della piegatura? Altrimenti non sarebbe più consono fare un assieme col piegato finito ed i perni inseriti successivamente?

Se i perni invece di inserirli come parte li modelli direttamente nella parte sulla faccia di interesse (sempre con la lamiera spiegata) allora funziona. Ma comunque anche gli schizzi d'appoggio devi farli sulla faccia con la lamiera aperta.

Saluti
Marco
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#12
....
Se i perni invece di inserirli come parte li modelli direttamente nella parte sulla faccia di interesse (sempre con la lamiera spiegata) allora funziona. Ma comunque anche gli schizzi d'appoggio devi farli sulla faccia con la lamiera aperta...
... e devi "unire i risultati". Insomma non può essere un multicorpo, e fino alla 2009 è normale che sia così visto che la lamiera non gestisce i multicorpo.
Mi spiace; ti può andare bene lo stesso in questo modo?

Guarda le modifiche che ora funziona davvero (forse:biggrin:):
View attachment Lamiera 02.rar

Saluti
Marco:smile:
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#13
... ti può andare bene lo stesso in questo modo?
..forse no, perchè è vero che volevi la distinta.
Ma allora si torna all'assieme ed i perni li inserisci lì come parti a se stanti (come effettivamente sono).
Per le posizioni nella singola lamiera potresti fare come ti dicevo prima dei prefori o mettere solo degli assi come "tacche di centratura".

Saluti
Marco
 

m_arquati

Utente Junior
Professione: Progettista
Software: SW2003
Regione: Emilia Romagna
#14
Grazie Marco per l'interesse!!! Fin troppo!:finger:

Si, prima modellavo i perni direttamente nella parte, ma non li avevo in distinta e soprattutto essendo corpo unico, nelle operazioni di taglio passanti, se il taglio incontra un perno lo sega... o lo taglia via tutto o ne taglia dei pezzi o lascia dei refusi... che se non stai attento, poi vanno al laser che al posto dei perni sparati fa dei fori con forme strane!!!!

Inserirli in assieme significa fare un sottoassieme per ogni lamiera...:frown:
Quando cominici ad avere 100 lamiere diverse con 50 perni l'una son cavoli da gestire...

Ecco il motivo della richiesta...

Provo come mi hai detto di fare gli schizzi d'appoggio sulla lamiera aperta... anche se non capisco perchè quando si "sposta" la faccia la parte non la segua.

Altro metodo è: aggiungi i perni come parte (per non modellarli tutte le volte) e con il comando abbina li unisci alla parte... il risultato è lo stesso...


Grazie mille, ancora!
Marco