Stampa insolita dei PDF in ProE

Michele_F

Utente Junior
Software: Ptc Creo 3.0, Siemens NX, Catia V5
Regione: Italia, Veneto - Emilia Romagna
#1
Ciao a tutti

A me questa doveva ancora capitare di vederla. Ammetto di non aver mai stampato PDF con ProE Wildfire ma in seguito ho avuto modo di fare prove e realizzare che il risultato che ottengo è davvero insolito... :confused:

In pratica la stampa in PDF di una messa in tavola (premetto che stili di linea e configurazione del drawing sono praticamente quelli di default) avviene come segue:

Rette stampate con tratto medio
Archi stampate con tratto cinque volte più grosso :confused:
Spigoli tangenti stampati con tratto grigio cinque volte più grosso :confused:

Ancor più insolito tutto ciò se considerato che in una recente nuova installazione di Wildfire M100 ciò non accade e le stampe sono un gioiello :eek:

Signori, che devo fare?? E' un problema di configurazione o procedo "alla informatico" cancellando e reinstallando??

Grazie a tutti dell'aiuto!
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#4
Hai configurato il pen table file ?
Se la risposta è si devi inoltre settare la seguente opzione del config.pro

pdf_use_pentable yes
 

matacad

Utente poco attivo
Professione: Impiegato tecnico
Software: Catia V5, PRO/E WF5
Regione: Campania (NA)
#6
Salve, scusa se riesumo questa discussione di molti anni fa. Abbiamo lo stesso problema con WF5.

Una macchina a 32bit fa genera pdf perfetti, mentre le macchine a 64bit non riconoscono al momento della generazione del pdf non riconoscono i caratteri true tipe e lo spessore delle linee è vistosamente maggiore.

Quindi la domanda è, questo problema si risolve con l'utilizzo del file pe_table?

grazie
 

painaz

Utente Standard
Professione: ingegnere
Software: proe
Regione: veneto
#7
se il file della pen_table è a posto come sembra essere (la stampa normale è ok) prova:

pdf_use_pentable YES

io con i pdf l'unico problema che ho avuto era con i testi del cartiglio, venivano più larghi e alcuni sbordavano dalle celle della tabella cartiglio.

risolto con:

Immagine.jpg
 

painaz

Utente Standard
Professione: ingegnere
Software: proe
Regione: veneto
#8
per i caratteri può di pendere da quali font sono installati.

WF ha un suo set di font, può darsi sul sistema a 32bit coincida con quello del sistema operativo, mentre i set di font del 64bit è diverso.

La soluzione più rapida è l'opzione che ho fatto vedere nel commento precedente. Capita anche con altri cad quando stampano in PDF per lo stesso motivo. Alcuni cad, mi viene in mente autocad, quando girano fanno vedere al sistema operativo anche il loro set font per risolvere il problema (te ne accorgi dal task manager, viene creato un processo che mi pare si chiami presentation font true type).

Per lo spessore linee, se non ne venite a capo nemmeno con l'opzione use_pen_table YES, installate una stampante virtuale tipo "pdf creator" o pdf995.

Io con la vecchia WF I, che non traduceva in pdf, usavo la stampante virtuale pdf995 e i risultati erano eccellenti.
 
Ultima modifica:

matacad

Utente poco attivo
Professione: Impiegato tecnico
Software: Catia V5, PRO/E WF5
Regione: Campania (NA)
#9
Painaz, grazie per la risposta. Per quanto riguarda i caratteri ho risolto utilizzando un carattere diverso, in particolare quello chiamato "font", così posso utilizzare i caratteri true type.

Per quanto riguarda le linee, ho impostato pdf_use_pentable YES e settato le varie penne da 1 ad 8.
Cattura.PNG

Anche cambiando i numeri inseriti, lo spessore delle linee non cambia.
 

matacad

Utente poco attivo
Professione: Impiegato tecnico
Software: Catia V5, PRO/E WF5
Regione: Campania (NA)
#10
Piccolo aggiornamento: se faccio la stampa con la stampante virtuale pdf (doPdf, Acrobat X pro) le linee vengono con lo spessore impostato, ma il foglio è decentrato.
Mentre se esporto in pdf direttamente da pro-e l'errore rimante.
 

painaz

Utente Standard
Professione: ingegnere
Software: proe
Regione: veneto
#11
Foglio decentrato...

hai l'opzione per mettere la data di stampa?

Immagine.jpg

Ultima risorsa prova la stampante virtuale pdf995, se non ricordo male con altre (pdf creator) avevo avuto anche io problemi.

E' shareware, se non paghi l'obolo a ogni stampa esce fuori un banner da chiudere.

Ultima cosa, te la dico solo per scrupolo perché sicuramente l'avete già fatto.

questo l'avete settato?

zz.jpg
 

matacad

Utente poco attivo
Professione: Impiegato tecnico
Software: Catia V5, PRO/E WF5
Regione: Campania (NA)
#12
Painaz, grazie per le risposte, in verità il file .pnt non lo abbiamo settato.

Abbiamo creato il txt con i lavori delle pen, ma non abbiamo capito come fare a caricarlo. Forse devo incollare il percorso del file nel rigo di canto al flag?

Inoltre, se deseleziono il flag "File tabella" dovrebbe leggere i lavori delle pen presenti nel file config?
I valori impostati di questo file li ho riportati nella immagine di cattura nel messaggio precedente.
 

painaz

Utente Standard
Professione: ingegnere
Software: proe
Regione: veneto
#13
prova a togliere/cancellare i settaggi del pen_size che hai mostrato in figura del tuo config.

poi prova queste opzioni nel confi.pro:

plot_linestyle_scale 1
pen_table_file <vostra start directory>\table.pnt

poi assicuratevi che ci siano questi due file nella <vostra start directory> (vedi allegato)

ms_print_mgr.pcf
table.pnt

ms_print_mgr.pcf editatelo per adattare i percorsi alla vostra installazione.

Se avete ancora problemi... ...non saprei che dire. A quel punto è meglio passare la palla all'assistenza.

Ah, dimenticavo: l'etichetta della data di stampa va DE_selezionata, altrimenti decentra la squadratura del foglio.
 

Allegati

  • 1,013 bytes Visualizzazioni: 12