Spline normale agli estremi

Loutenr1

Utente Standard
Professione: Impiegato
Software: SW 2012
Regione: italia
#1
Ciao a tutti. Sto cercando di creare una molla il cui profilo si sviluppa non su un asse ma su una curva. Ora sto avendo difficoltà a creare gli occhielli alle estremità della molla. In particolare vorrei sapere se esiste un modo per creare una spline 3d tra i punti A e B in modo che tale spline sia normale alle curve proprio in quei punti, in modo da avere il percorso che unisce le due eliche il più fluido possibile.
Consigli?
Grazie a tutti
 

Allegati

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#2
vorrei sapere se esiste un modo per creare una spline 3d tra i punti A e B in modo che tale spline sia normale alle curve proprio in quei punti, in modo da avere il percorso che unisce le due eliche il più fluido possibile.
Mi riesce difficile pensare a una spline che unisce i punti A e B, che sia "normale" alle curve e contemporaneamente crei una transizione fluida tra splinbe e curva.
Forse volevi scrivere "tangente"? Forse non ho capito di cosa hai bisogno? :smile:

Io quelle due curve le unirei con una spline semplice, senza nessun punto intermedio, poi metterei un vincolo di tangenza tra spline e curva da ciascun lato.

Ah, quando i files sono semplici e non contengono segrati industriali o militari per cui toccherebbe poi uccidere chi ne viene a conoscenza:rolleyes:, sarebbe bene allegarli per facilitare le varie proposte di soluzione ai problemi
 

Loutenr1

Utente Standard
Professione: Impiegato
Software: SW 2012
Regione: italia
#3
Mi riesce difficile pensare a una spline che unisce i punti A e B, che sia "normale" alle curve e contemporaneamente crei una transizione fluida tra splinbe e curva.
Forse volevi scrivere "tangente"? Forse non ho capito di cosa hai bisogno? :smile:

Io quelle due curve le unirei con una spline semplice, senza nessun punto intermedio, poi metterei un vincolo di tangenza tra spline e curva da ciascun lato.

Ah, quando i files sono semplici e non contengono segrati industriali o militari per cui toccherebbe poi uccidere chi ne viene a conoscenza:rolleyes:, sarebbe bene allegarli per facilitare le varie proposte di soluzione ai problemi
Hai ragione, mi sono espresso male. Le spline devono essere normali al piano che c'è sui punti A e B (piano a sua volta normale alle curve che terminano in A e B).
Voglio proprio fare quello che dici, mettere la tangenza tra la spline semplice e le curve (mi sembrava si potesse fare), ma non riesco a farlo.
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#4
Hai ragione, mi sono espresso male. Le spline devono essere normali al piano che c'è sui punti A e B (piano a sua volta normale alle curve che terminano in A e B).
Voglio proprio fare quello che dici, mettere la tangenza tra la spline semplice e le curve (mi sembrava si potesse fare), ma non riesco a farlo.
perchè non posti il file?
 

Loutenr1

Utente Standard
Professione: Impiegato
Software: SW 2012
Regione: italia
#5
Eccolo. non mi sembrava importante, visto il poco che c'è sopra per adesso. Sono ripartito da capo
 

Allegati

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#6
Eccolo. non mi sembrava importante, visto il poco che c'è sopra per adesso. Sono ripartito da capo
Visto il file, peccato che manchino i due elicoidi da unire con la spline, proprio perchè hai rifatto tutto...
Ti chiedevo il file della prima immagine per evitare di perder tempo a disegnare geometrie che avevi già fatto tu.
Adesso però devo scappare. Magari interviene qualcun'altro
 

Loutenr1

Utente Standard
Professione: Impiegato
Software: SW 2012
Regione: italia
#7
Ecco il file coi 2 elicoidi. Non mi riesce di dare la tangenza all'elica fatta col comando "elica/spirale". Con l'altra curva sono riuscito.
 

Allegati

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#9
Ecco il file coi 2 elicoidi. Non mi riesce di dare la tangenza all'elica fatta col comando "elica/spirale". Con l'altra curva sono riuscito.
SWX non prende il vincolo di tangenza con la curva spirale. Non ho mai capito il perchè.
Crea uno schizzo 3D, selezioni la spirale, poi clicca su "converti entità" ed esci dallo schizzo 3d. Nascondi la curva-spirale e usa questo nuovo schizzo e vedrai che riesci a dare il vincolo di tangenza tra la spsline e le due spirali.
Non ti posto il file perchè non ho la versione 2008 quindi tu non riusciresti ad aprirlo.
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#10
Si, io.... leggi di seguito.

SWX non prende il vincolo di tangenza con la curva spirale. Non ho mai capito il perchè.
Crea uno schizzo 3D, selezioni la spirale, poi clicca su "converti entità" ed esci dallo schizzo 3d. Nascondi la curva-spirale e usa questo nuovo schizzo e vedrai che riesci a dare il vincolo di tangenza tra la spsline e le due spirali.
Non ti posto il file perchè non ho la versione 2008 quindi tu non riusciresti ad aprirlo.
Ha ragione a non fartelo fare tangente :wink:, il piano dove giace lo schizzo della seconda spirale è mal posizionato.
Ti posto il file, spiegartelo a gesti è un casotto :rolleyes:.
Casomai, considerato che sei :36_3_11: più forbito del sottoscritto e magari hai ancora una versione si solidworks compatibile con Loutenr1, spiegagli
i passaggi che ho fatto io.
Non chiedermi come ho fatto a rendere coincidente la spirale lunga con quella corta ... ho zoomato e pregato... :wink:
allego il file in 2013... View attachment molla-Mike.zip Molla.JPG
 
Ultima modifica:

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#11
marcof ha detto:
SWX non prende il vincolo di tangenza con la curva spirale. Non ho mai capito il perchè.
Ha ragione a non fartelo fare tangente :wink:, il piano dove giace lo schizzo della seconda spirale è mal posizionato.
Io però avevo capito che il nostro amico avesse bisogno di congiungere le due spirali con una breve spline in tangenza, non di far partire una spirale in tangenza all'altra.
Quello che ho constatato è che se fai la spline in uno schizzo 3d e l'attacchi alla curva-spirale (quella che SWX ti mostra in azzurro a differenza degli schizzi normali) poi selezionando entrambi non compaiono i vincoli disponibili. Idem se cerchi di collegare qualsiasi altra entità: non permnette di applicare vincoli facendo la doppia selezione. Prende solo il vincolo di coincidenza mentre crei il primo punto della linea, della spline ecc.
Per queste rogne qando mi è capitato di dover usare la curva-spirale l'ho sempre riportata su un nuovo schizzo 3d con converti entità

Mike1967 ha detto:
Ti posto il file, spiegartelo a gesti è un casotto :rolleyes:.
(cut)
allego il file in 2013...
ci faccio la birra con il fine in formato 2013. Meriteresti che ti chiedessi di convertirmelo nella versione 2012. Anzi, lo facco:smile::
[mode utente a rischio ban ON]
Non ho la 2013, potresti salvarmi il file nella versione 2012? Grazie per la disponibilità!
[mode utente a rischio ban OFF]
:tongue:
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#12
Io però avevo capito che il nostro amico avesse bisogno di congiungere le due spirali con una breve spline in tangenza, non di far partire una spirale in tangenza all'altra.
Quello che ho constatato è che se fai la spline in uno schizzo 3d e l'attacchi alla curva-spirale (quella che SWX ti mostra in azzurro a differenza degli schizzi normali) poi selezionando entrambi non compaiono i vincoli disponibili. Idem se cerchi di collegare qualsiasi altra entità: non permnette di applicare vincoli facendo la doppia selezione. Prende solo il vincolo di coincidenza mentre crei il primo punto della linea, della spline ecc.
Per queste rogne qando mi è capitato di dover usare la curva-spirale l'ho sempre riportata su un nuovo schizzo 3d con converti entità



ci faccio la birra con il fine in formato 2013. Meriteresti che ti chiedessi di convertirmelo nella versione 2012. Anzi, lo facco:smile::
[mode utente a rischio ban ON]
Non ho la 2013, potresti salvarmi il file nella versione 2012? Grazie per la disponibilità!
[mode utente a rischio ban OFF]
:tongue:
Vous ne pouvez pas, vous devez disposer de la version 2012 ont 5 sp pour ouvrir le dessin... :biggrin:
Scusa il francesismo....

oltretutto mi sa tanto che perderesti anche l' albero delle funzioni....

Ps: speravo che tu fossi già alla 2013 e che il tuo profilo fosse in "ritardo" d' aggiornamento... :finger:
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#13
ci faccio la birra con il fine in formato 2013. Meriteresti che ti chiedessi di convertirmelo nella versione 2012. Anzi, lo facco:smile::
[mode utente a rischio ban ON]
Non ho la 2013, potresti salvarmi il file nella versione 2012? Grazie per la disponibilità!
[mode utente a rischio ban OFF]
:tongue:
Vous ne pouvez pas, vous devez disposer de la version 2012 ont 5 sp pour ouvrir le dessin...
Scusa il francesismo....
merde! Je ne me souviens pas de cette option...
Sono talmente abituato al fatto che indietro non si torna che ormai lo considero impossibile di dafault
oltretutto mi sa tanto che perderesti anche l' albero delle funzioni....
in effetti è come avere aperto uno step. Non riordo cosa rimane di compatibile, forse i vincoli negli assiemi?

Ps: speravo che tu fossi già alla 2013 e che il tuo profilo fosse in "ritardo" d' aggiornamento... :finger:
ho la scatoletta con i DVD sulla scrivania... dici che è ora e ormai "l'ordigno fine di mondo" l'hanno disinnescato con l'ultimo SP disponibile e posso installarlo?:rolleyes:
 

Loutenr1

Utente Standard
Professione: Impiegato
Software: SW 2012
Regione: italia
#14
Grazie a tutti e due. Effettivamente Marcof ha ragione, avevo chiesto come fare per collegare le due spirali con una spline. Questo però perchè non sono capace di far partire una spirale nel punto finale dell'altra :confused:
All'altra estremità della parte curva della molla, ho riprovato facendo un'altra spirale e riprovando ad unirle con spline. Qui sono riuscito a mettere da entrambe le parti il vincolo di tangenza, probabilmente era un problema di posizione del piano come ha detto Mike.

Edit: mi sono accorto che parlavate di me riguardo sw 2008, ho aggiornato le mie info :rolleyes:

Già che ci siamo spiegatemi come far partire una nuova spirale nel punto finale di un'altra :cool::cool:
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#15
Grazie a tutti e due. Effettivamente Marcof ha ragione, avevo chiesto come fare per collegare le due spirali con una spline. Questo però perchè non sono capace di far partire una spirale nel punto finale dell'altra :confused:
All'altra estremità della parte curva della molla, ho riprovato facendo un'altra spirale e riprovando ad unirle con spline. Qui sono riuscito a mettere da entrambe le parti il vincolo di tangenza, probabilmente era un problema di posizione del piano come ha detto Mike.

Edit: mi sono accorto che parlavate di me riguardo sw 2008, ho aggiornato le mie info :rolleyes:

Già che ci siamo spiegatemi come far partire una nuova spirale nel punto finale di un'altra :cool::cool:
Il problema è proprio nel piano di partenza della seconda spira.
Io ho fatto in modo che il piano stesse "normale" (di 90° ndr) alla spira verticale.
Poi ho fatto coincidere la partenza della seconda spira con l' inizio di quella verticale.
Per questo motivo non ho usato la spline: le due spire sono tangenti, ora.
Se ho tempo ti faccio un video su come ho posizionato il piano.

Riguardo la tua ultima richiesta.... ho già risposto nel mio precedente intervento.
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#16
......
ho la scatoletta con i DVD sulla scrivania... dici che è ora e ormai "l'ordigno fine di mondo" l'hanno disinnescato con l'ultimo SP disponibile e posso installarlo?:rolleyes:
Allora: ho installato da poco e sono partito dal sp 2.0 (non installo più le versioni troppo acerbe) e devo dire che a parte qualche crash improvviso,
dove però non ho mai perso nulla in quanto il sw recupera tutto, non ho riscontrato grosse pecche.
L' unico problema un pò fastidioso (ho già aperto una chiamata in assistenza) l' h avuto con un assieme che conteneva un altro assieme nel
quale avevo usato delle equazioni.
Nel fare il P&G di quell' assieme, al momento dell' apertura dell' assieme esportato, mi veniva comunicato che un' equazione era presente e che era
riferita ad un altro assieme e mi sollecitava a fargli modificare il nuovo file.
Una volta cliccato su OK il sw si chiude senza possibilità di appello.
Il rimedio consiste nell' aprire il nuovo assieme contenente l' equazione e salvarlo.
Per il resto devo dire che le lamiere multicorpo sono molto migliorate, anche se nelle ultime settimane sto usando poco solidworks.

Ciao :smile:
 

Loutenr1

Utente Standard
Professione: Impiegato
Software: SW 2012
Regione: italia
#17
Ma come fai a far partire la spira proprio nel punto finale dell'altra spira? Quando la creo a me chiede solo un cerchio da cui partire, ma non mi riesce di gestire il punto iniziale. Al massimo cambiando i gradi riesco ad avvicinarmi abbastanza, ma ovviamente in questo caso non serve a nulla
 
Professione: Disegnatore
Software: Solidworks
Regione: Lombardia
#18
Buon giorno , mi trovo davanti ad un problema ed è il seguente. Non è esattamente quello trattato nella discussione...
Dovrei creare un serpentino ricavato da tubo di Ø x da mettere all'interno di un serbatoio, con l'ingresso e l'uscita posizionate perpendicolarmente alla direzione della spirale. Tracciata la spirale, tracciate le linee di ingresso ed uscita, dovrei creare il raccordo di raggio Y tra i due. Il raccordo in realtà sarà una curva oppure il tubo piegato. Posso fare tutto in ambiente part, oppure sarebbe opportuno farlo come tubazione (piping)?
Spero che qualcuno mi sia di aiuto.
Buona giornata