Sostituzione di un componente

Parceval

Utente Junior
Professione: Progettista meccanico
Software: Solidworks
Regione: Padova
#1
Ciao a tutti!
Ho un problema con SW2005 sp5. Devo sostituire un componente in un assieme, con un'altra configurazione dello stesso componente.
Con la sp.0 andavo su sostituisci componente->lasciavo selezionato il componente originale e davo ok->selezionavo dalla finestra che compariva la versione desiderata.
Ora mi dice che non posso sostituire un componente con un altro avente lo stesso nome!!
Come posso fare?

Grazie e ciao a tutti!
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#2
Ciao a tutti!
Ho un problema con SW2005 sp5. Devo sostituire un componente in un assieme, con un'altra configurazione dello stesso componente.
Con la sp.0 andavo su sostituisci componente->lasciavo selezionato il componente originale e davo ok->selezionavo dalla finestra che compariva la versione desiderata.
Ora mi dice che non posso sostituire un componente con un altro avente lo stesso nome!!
Come posso fare?

Grazie e ciao a tutti!
Infatti, se hanno lo stesso nome non puoi sostituirli, questo anche nelle versioni successive (io uso 2007 sp5).. ed essendo, come dici, 2 configurazioni dello stesso chiaramente il "nome principale" è lo stesso.
Ma proprio perchè sono 2 configurazioni la cosa è ancora più semplice :):
clik destro sull'elemento da sostituire (o sul nome nell'albero), dal menù a tendina scegli Proprietà del componente, si apre una finestra con elencate tutte le configurazioni. Da lì scegli quella che ti serve, dai ok et voilà.. veloce ed indolore:D

Saluti
Marco
 

Parceval

Utente Junior
Professione: Progettista meccanico
Software: Solidworks
Regione: Padova
#3
E' proprio cosiì!! Grazie mille!!
... Ti offrirei una birra!!
 
Professione: Progettista meccanico
Software: SolidWorks, Autocad
Regione: Vicenza
#4
Uso solidworks 2009 sp.5
A volte se faccio sostituisce componente e si tratta di una assieme prima di concludere il comando quando stà elaborando per inserirlo si chiude istantaneamente sw senza bloccarsi o dare messaggi di errore.
Ho notato che capita sopratutto se il sottoassieme da sostituire era risolt in modo flessibile.
Meglio salvare prima e mettere "modo risolto" - rigido.

Un saluto a tutti ciao