Solidworks blocca la rotazione di pezzi negli assemblati

Professione: Studente
Software: SolidWorks 2009
Regione: Piemonte
#1
Ciao a tutti, ho un problema, per la mia tesi mi sono trovato a dover costruire il modello 3D di un rover lunare.
Ho assemblato sospensioni, ruote, chassis e tutto il resto, in modo da permettere alle ruote di poter ruotare attorno al proprio asse e ai bracci che le collegano allo chassis di poter ruotare attorno al perno dellp chassis.
Ho poi costruito un terreno, e importato delle curve costruite apposta con matlab per le traiettorie che devono seguire 4 punti dello chassis e 4 punti dei bracci-ruote.
Il problema è che, quando ho fatto un ulteriore assemblato per mettere insieme terreno, rover e traiettorie, le ruote del rover non girano più, e neanche i bracci!
Come è possibile??
Ho cercato di vedere se sw ha aggiunto qualche vincolo...ma non ne ho trovati di nuovi!
E' però fondamentale che tutto si muova per poi poter creare l'animazione, e poter immettere i vincoli accoppiamento-percorso!
Qualcuno sa darmi una mano?
 

maca75

Utente Standard
Professione: disegnatore
Software: autocad - solidworks - inventor
Regione: veneto
#2
Se tu importi un assieme come sotto-assieme in un altro assieme i vincoli che ti erano rimasti liberi non li vedi più perchè quello che stai inserendo per solidworks è un blocco unico e quindi di conseguenza rigido . Se vuoi recuperare la libertà che avevi nell'assieme originale devi fare in modo che il tuo assieme sia un sotto-assieme flessibile ( una volta inserito nell'assieme finale -tasto dx - proprietà - in basso a destra trovi rigido e flessibile). Attenzione che a volte questo può crearti dei problemi di stabilità dell'assieme dove hai inserito il sottoassieme.
Spero di esserti stato utile
 
Professione: Studente
Software: SolidWorks 2009
Regione: Piemonte
#3
grazie mille per la veloce risposta.
ho fatto come mi hai detto e ha funzionato, ora però ho un altro problema, ovvero che nell'analisi del movimento, dopo aver messo un motore lineare per muovere il rover, e 4 motori rotatori alle ruote per farle girare (ovviamente solo come effetto grafico, perchè il motore principale è quello lineare), appena avvio il calcolo dell'animazione mi da il seguente messaggio:
"Spostamento della parte Part2^Rover completo-1 sospeso:
impossibile calcolare la massa, a causa di geometria solida mancante.
La massa può essere personalizzata nelle Proprietà della parte per superare l'uso della geometria solida."
Calcola i primi 2 secondi dell'animazione e poi non va più avanti.
Premesso che non capisco cosa c'entri la massa (visto che non uso la gravità), ho provato ad impostare manualmente la massa dall'albero delle feature, ma non è cambiato nulla. Ho guardato anche nell'help ma non dice niente a riguardo...
cosa posso fare?
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#4
grazie mille per la veloce risposta.
ho fatto come mi hai detto e ha funzionato, ora però ho un altro problema, ovvero che nell'analisi del movimento, dopo aver messo un motore lineare per muovere il rover, e 4 motori rotatori alle ruote per farle girare (ovviamente solo come effetto grafico, perchè il motore principale è quello lineare), appena avvio il calcolo dell'animazione mi da il seguente messaggio:
"Spostamento della parte Part2^Rover completo-1 sospeso:
impossibile calcolare la massa, a causa di geometria solida mancante.
La massa può essere personalizzata nelle Proprietà della parte per superare l'uso della geometria solida."
Calcola i primi 2 secondi dell'animazione e poi non va più avanti.
Premesso che non capisco cosa c'entri la massa (visto che non uso la gravità), ho provato ad impostare manualmente la massa dall'albero delle feature, ma non è cambiato nulla. Ho guardato anche nell'help ma non dice niente a riguardo...
cosa posso fare?
Ciao! Controlla sulla guida in linea ma mi pare che non si possono fare gli studi di movimento in sottoassiemi nemmeno flessibili. Idem per Inventor. Stesso problema. La cinematica deve risiedere tutta nello stesso livello di assieme
 
Professione: Studente
Software: SolidWorks 2009
Regione: Piemonte
#5
quindi cosa dovrei fare, modificare unicamente il primo assieme del rover e costruire da li il terreno e tutte le traiettorie?il problema è che anche le ruote sono sottoassiemi, idem per chassis, barre di torsione e tutto il resto!
mi sembra strano che non si possa fare!che c'entra con la massa?
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#6
Ciao! Controlla sulla guida in linea ma mi pare che non si possono fare gli studi di movimento in sottoassiemi nemmeno flessibili. Idem per Inventor. Stesso problema. La cinematica deve risiedere tutta nello stesso livello di assieme
Io gli studi di movimento non li uso, ma se fosse davvero così sono inusabili e si possono buttare direttamente nel cesso e servono solo per avere qualche icona da pigiare in più. Stai a vedere che mi devo fare un assieme unico per fare una simulazione di movimento... :cool:
 

davide510

Utente poco attivo
Professione: studente
Software: autocad 2009
Regione: campania
#8
ciao a tutti ho un problema con autocad 2009 su vista sto andando fuori di testa chiedo il vostro aiuto, il problema è un errore che mi da mentre lo uso ed è questo : unhandled access violation writing 0xdbf2000 exception at 772f9b2bh sto uscendo pazzo mi potreste aiutare????
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#9
ciao a tutti ho un problema con autocad 2009 su vista sto andando fuori di testa chiedo il vostro aiuto, il problema è un errore che mi da mentre lo uso ed è questo : unhandled access violation writing 0xdbf2000 exception at 772f9b2bh sto uscendo pazzo mi potreste aiutare????
Ma ti sei accorto di dove ti trovi? Ti sembra il forum di AutoCAD questo?? E ti sembra una discussione inerente alla tua domanda?
Come primo messaggio non c'è male, complimenti..
Poi da nuovi utenti sarebbe obbligatorio leggere il regolamento che spiega molte cose. E prima di postare così a casaccio sarebbe opportuno farsi un giro intorno per imparare a conoscere il forum, tutte le sue sezioni ed il modo di comportarsi (che è poi uguale a quello di tutti i forum della rete).
Anche una breve presentazione sarebbe gradita.. leggi il regolamento e riprova.
Grazie

saluti
Marco
 

davide510

Utente poco attivo
Professione: studente
Software: autocad 2009
Regione: campania
#10
guarda che non c'è bisogno di essere cosi' maleducati dovrebbero bannarti subito da questo forum perchè questa è maleducazione
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#11
dubito che sia così...qualcuno mi sa dare una mano a risolvere questo problema???
Ho verificato questa mattina. Assieme con un po' di parti sparse e una decina di assiemi flessibili. Per lo STUDIO DI MOVIMENTO funziona tutto correttamente e si scambiano le grandezze cinematiche.

Andrebbe verificato se funziona anche con le SIMULAZIONI FISICHE oppure se il limite è definito in questo tipo di studio.

Prova a creare un nuovo studio di movimento, metti di nuovo i motori e quello che serve e riprovi. Alle volte capita un click al posto sbagliato e si blocca tutto.
 
Professione: Studente
Software: SolidWorks 2009
Regione: Piemonte
#12
un ultimo piccolo aiuto ragazzi...sono riuscito a fare un'animazione (anche se ogni tanto le ruote "scattano" in avanti, saltando qualche cm, non so perchè)...qualcuno mi sa dire come posso mettere una telecamera fissa sul modello che avanza?
vorrei fare un piccolo video che mostri quello che vede la telecamera montata sul rover mentre questo avanza...è possibile?e farla ruotare mentre il veicolo va avanti, sempre però fissa sulla torretta?vi prego, devo finirlo oggi!!!!!!:(
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#15
Vai nell'help alla voce Studi di movimento/Tecniche basate sulla videocamera
Non l'ho mai fatto, ma ho dato (io... :rolleyes:) una scorsa veloce all'help e secondo me se animi contemporaneamente modello e videocamera si può fare. Se dalla videocamera non hai la necessità di inquadrare parti del rover non dovrebbe proprio essere un problema. Io almeno ci porverei.
 

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#16
...sono riuscito a fare un'animazione (anche se ogni tanto le ruote "scattano" in avanti, saltando qualche cm, non so perchè)...qualcuno mi sa dire come posso mettere una telecamera fissa sul modello che avanza?
vorrei fare un piccolo video che mostri quello che vede la telecamera montata sul rover mentre questo avanza...è possibile?e farla ruotare mentre il veicolo va avanti, sempre però fissa sulla torretta
...io che non sono mai riuscito a fare cose simili, mi prenoto per vedere il video e sopratutto (se possibile) per i file da studiare :D

PS: Che swx hai? 2009 2010 base, professional, ...