solidi non allineati agli assi

doking

Utente Standard
Professione: studentello
Software: autocad 2016 advance steel 2015.1 solidworks 2015
Regione: Salerno
#1
salve, ho un elemento importato e questo non mi risulta allineato agli assi, se lo metto in tavola la quotatura mi risulta falsata
come faccio ad allineare? ho provato il comando strumenti>funzioni> sposta/copia ma mi chiedevo se fosse l'unica soluzione in quanto dovrei cerare una linea di riferimento, annotare la quota dell'angolo di cui l'oggetto è ruotato e riportarlo manualmente nel box

grazie :)
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#2
inserisci la parte importata in assieme, usi gli accoppiamenti per posizionarla come ti serve rispetto ai piani principali quindi fai un salva con nome scegliendo però il formato .sldprt e ottarrai una nuova parte orientata correttamente.
 

doking

Utente Standard
Professione: studentello
Software: autocad 2016 advance steel 2015.1 solidworks 2015
Regione: Salerno
#3
grazie mille :)

ho provato, il pezzo riesco ad allinearlo però perdo le funzioni...
e questo anche con le lamiere
si può ovviare?
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#4
grazie mille :)

ho provato, il pezzo riesco ad allinearlo però perdo le funzioni...
e questo anche con le lamiere
si può ovviare?
nel tuo primo post parlavi di "elemento importato" quindi pensavo a uno step proveniente da un'altro cad, ed è per questo che ti ho consigliato di ricrearlo partendo dall'assieme.
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#5
Nel comando sposta/copia c'è l'opzione vincoli che ti permette di dare vincoli come fossi in assieme:
Vincoli parte.png
Personalmente comunque ti consiglierei di valutare anche la correzione delle feature native; avresti un modello molto più lineare ma è un'operazione "rischiosa" e dipende da che ci devi fare. Se propendi per lo sposta/copia valuta che nella tavola non puoi usare le quote mostrate dal modello (sempre che ti servano).
 

doking

Utente Standard
Professione: studentello
Software: autocad 2016 advance steel 2015.1 solidworks 2015
Regione: Salerno
#6
si tratta di una file step fatto di tanti solidi su cui in un primo momento, su uno dei pezzi, ho calcato sopra una lamiera, adesso mi rendo conto avrei prima aprire il pezzo in questione, allinearlo come suggeriva marcof, calcare la lamiera e poi reinserirla nel file iniziale sotto forma di assieme
lica1669 ma per usare il comando sposta/copia devo comunque creare un solido con il piano allineato e usarlo come riferimento? perche riesco a usarlo solo così ma poi mi rimane e se lo cancello mi ritorna nella posizione originaria. in ogni caso se provo a realizzare la tavola, il pezzo che abbiamo appena allineato lo vedo sempre come se non avessi allineato
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#7
Il comando sposta/copia è una feature vera e propria che se cancelli tutto torna come prima. Mi sembra di capire che è un file ibrido (metà parametrico e metà importato) quindi, se il tuo problema è solo allinearlo per fare la tavola, potresti:
- orientare il pezzo come lo vorresti vedere in una vista del disegno (esempio fontale)
- usare il comando Visualizza>Modifica>Imposta vista corrente
- scegliere la vista da sostituire (nell'esempio frontale).
viste riorientate.png
In questo modo tutte le altre viste si adegueranno e potrai fare la tavola facilmente. Non mi fa impazzire come soluzione ma non ne vedo altre se non vuoi rifare la lamiera.
 
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#8
Basta fare dalla tavola: Inserisci/vista/relativa da modello....alta qualità...passi al 3d e scegli due facce ortogonali e clicchi sul foglio. Tutto indipendentemente dai piani di costruzione.
Poi se nel 3d ti servono puoi sempre aggiungere dei piani per vincolare in assieme
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#9
Basta fare dalla tavola: Inserisci/vista/relativa da modello....alta qualità...passi al 3d e scegli due facce ortogonali e clicchi sul foglio. Tutto indipendentemente dai piani di costruzione.
Fantastico! Non conoscevo questa opzione. Grazie!
 

doking

Utente Standard
Professione: studentello
Software: autocad 2016 advance steel 2015.1 solidworks 2015
Regione: Salerno
#10
Basta fare dalla tavola: Inserisci/vista/relativa da modello....alta qualità...passi al 3d e scegli due facce ortogonali e clicchi sul foglio. Tutto indipendentemente dai piani di costruzione.
Poi se nel 3d ti servono puoi sempre aggiungere dei piani per vincolare in assieme
non mi funziona, nella tavola vedo sempre il modello non allineato
allora apro il modello, creo un cubo, faccio inserisci> funzioni> sposta copia e allineo una faccia del mio elemento con una faccia del cubo e salvo
poi apro un disegno richiamo il mio file e clicco sul foglio dove mi visualizza il mio elemento ovviamente storto, faccio Inserisci> vista del disegno> relativa al modello clicco alta qualità selezione due facce sul mio modello primo orientamento> frontale e secondo orientamento destra, do conferma, passa automaticamente alla tavola ma è cambiato assolutamente nulla:confused:
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#11
non mi funziona, nella tavola vedo sempre il modello non allineato
io ho provato al volo con un pezzo qualsiasi e funziona. Bisogna scegliere la selezione giusta delle facce per riorentare il modello.
CAsomai allega il file...
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#13
Le facce che hai selezionato non sono ortogonali (come ti suggeriva meccanicamg). Prova ad usare le superfici che vedi nell'immagine: selezione.png