Serie geometerica

LuPo_81

Utente Junior
Professione: Progettazione
Software: Creo
Regione: Italia
#1
Ciao a tutti.

la maggior parte dei modelli che utilizzo sono settori angolari di un toroide, descritti da superfici. Per creare i modelli completi pertanto utilizzo le "serie geometrica". Questo metodo funziona correttamente con le superfici, ma non con i solidi. Nel dettaglio: ho importato un modello di superfici (da IGES) che rappresenta un settore angolare di 30°, ho chiuso le superfici aperte, ho unito il tutto e ho solidificato. Seleziono le superfici create e creo la serie: se imposto le ripetizioni a 30° la feature fallisce, mentre se imposto, ad esempio, le ripetizioni a 30.5° funziona.
Chi mi sa spiegare il perchè?
Come posso fare per creare il modello corretto (solido!)?

Allego un prt banale che illustra il problema.
 

Allegati

BerAnd

Utente Standard
Professione: diciamo che faccio...
Software: WF4,Creo3
Regione: Emilia Romagna
#2
Ciao.
hai provato a modificare la precisione assoluta della parte?
 

zimmy

Utente Standard
Professione: non l'ho mai capito
Software: icone e menu
Regione: lombardia
#3
Dipende dal fatto che hai lavorato per superfici. Se copi quelle superfici con un angolo di 30° le superfici copiate si "intersecano" e le operazioni di Merge ovviamente non può funzionare.
Prova a fare la prima feature di Revolve direttamente come solido ( perchè l'hai fatta come superficie ??) e poi fai la serie sul solido e tutto va benissimo usando qualsiasi valore di angolo.
Fai meno feature e tutto funziona !
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#4
Il tuo file non riesco ad aprirlo è fatto con la WF5 ?
Ti posto un esempio.
 

Allegati

LuPo_81

Utente Junior
Professione: Progettazione
Software: Creo
Regione: Italia
#5
( perchè l'hai fatta come superficie ??) e poi fai la serie sul solido e tutto va benissimo usando qualsiasi valore di angolo.
Fai meno feature e tutto funziona !
il modello lo importo da IGES ed è formato da superfici, quello che ho postato è solo un modello di esempio. Il vero modello è moooolto più complesso.

le operazioni di Merge ovviamente non può funzionare
però se rifai la serie sull'unione superfici (escludendo la feature "solidifica") e poi fai il merge di tutte le superfici create dalla serie il modello lo crea perfettamente, però l'operazione è lunga (immagina se ho una serie di centinaia di superfici) e poi mi tocca solidificare il tutto.

hai provato a modificare la precisione assoluta della parte?
ehmmm ... come verifico questa cosa? Se riesci puoi farlo con il modello che ho allegato?

Il tuo file non riesco ad aprirlo è fatto con la WF5 ?
Sì, è in WF5. Comunque l'offset non c'è, era solo per far capire che se metto come angolo della serie 30.5° funziona tutto, mentre se metto 30° (come dovrebbe essere) fallisce la generazione della feature. Posto un IGES di prova, chi riesce a fare il modello solido di tutta la serie di 80 ripetizioni?
 

Allegati

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#6
Quest'ultima me la spieghi ? La parte è completamente diversa dalla precedente.
 

LuPo_81

Utente Junior
Professione: Progettazione
Software: Creo
Regione: Italia
#7
Il problema non è su un modello in particolare, è su tutti. Se mi aiutate a farlo su uno qualsiasi è come se l'avessi fatto su tutti!