• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

rotazione componente

Professione: progettista
Software: SolidWorks
Regione: toscana
#1
scusate la domanda molto banale, ma mi sto avvicinando in questi giorni a SE ST4 e sul forum non ho trovato indicazioni.
in SW esiste la possibilità di ruotare un componente quando lo piazzo in un assieme (ovvviamente non vincolato), funzione che trovo molto comoda per pre-orientare il componente prima di montarlo oppure per vederlo nella sua interezza senza ruotare tutto l'assieme.
mi domando: ma in SE questa funzione non esiste? con il comando drag me lo fa solamente trascinare oppure lo posso ruotare solamente scegliendo uno spigolo, quindi non ho una rotazione libera..
qualcuno sa se si può fare su SE una rotazione libera di un componente in assieme?
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#2
ciao, quando inserisci il componente tieni premuto il tasto CTRL e contemporaneamente toccando il particolare con il click SX del mouse riesci a ruotarlo sul posto, appena rilasci il CTRL il componente viene spostato.
 
Professione: progettista
Software: SolidWorks
Regione: toscana
#3
ciao tequila,
ho provato a fare come suggerisci ma non mi funziona..
io prendo il componente da inserire dalla parts library. lo clicco e lo trascino nell'area grafica. una volta che lo lascio me lo posiziona sempre nel medesimo punto, è vincolato come fisso e ovviamente non me lo fa ruotare in nessun modo... non capisco dove sbaglio..
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#4
ciao tequila,
ho provato a fare come suggerisci ma non mi funziona..
io prendo il componente da inserire dalla parts library. lo clicco e lo trascino nell'area grafica. una volta che lo lascio me lo posiziona sempre nel medesimo punto, è vincolato come fisso e ovviamente non me lo fa ruotare in nessun modo... non capisco dove sbaglio..
se è il primo componente che inserisci all'interno di un assieme te lo vincola a terra e quindi ti risulta bloccato. Quelli che inserisci dopo se non hanno le relazioni automatiche impostate risultano liberi, per cui con CTRL+click riesci a ruotarli. Se anche ti presentassero delle relazioni automatiche non fai altro che premere ESC per uscire dal comando e poi come sopra CTRL+click lo ruoti.

Se è il primo componente che ti interessa ruotare devi cancellare il vincolo a terra e poi lo ruoti e lo rivincoli come vuoi.
 
Professione: progettista
Software: SolidWorks
Regione: toscana
#5
trovato! c'erano le relazioni automatiche da cambiare. quindi quando mettevo un componente in un assieme esistente me lo vincolava come fisso. modificata l'impostazione delle relazioni automatiche ora mi permette di ruotare e spostare il componente.
grazie del suggerimento!
 

ipotemusa

Utente Standard
Professione: Progettista
Software: Solid Edge e Solid Works
Regione: Veneto
#6
se è il primo componente che inserisci all'interno di un assieme te lo vincola a terra e quindi ti risulta bloccato. Quelli che inserisci dopo se non hanno le relazioni automatiche impostate risultano liberi, per cui con CTRL+click riesci a ruotarli. Se anche ti presentassero delle relazioni automatiche non fai altro che premere ESC per uscire dal comando e poi come sopra CTRL+click lo ruoti.

Se è il primo componente che ti interessa ruotare devi cancellare il vincolo a terra e poi lo ruoti e lo rivincoli come vuoi.
Eh? questa mi è nuova...
Ho provato e non funziona, se premo il ctrl trascinandolo me lo mette a terra, se lo premo dopo parte la selezione "rettangolare" ma di ruotarlo cliccandoci sopra nisba.
Si può fare? dove sbaglio? stiamo parlando di Solid Edge?????
Col volante riesco a ruotarlo ed a spostarlo, ma non "semplicemente" cliccandoci sopra e tirando...
 
Ultima modifica:
Professione: progettista
Software: SolidWorks
Regione: toscana
#7
Stiamo parlando di SolidEdge ST4.
Quando trascini un componente dalla parts library nell'area grafica e te lo mette vincolato a terra è perchè hai le impostazioni sulle relazioni automatiche impostate. Per toglierle devi: in Home vai al gruppo comandi Relate. All'interno trovi Assembly relationship assistant, cliccaci e ti apre il menu. Imposta come attivo Remove relationship on part in select set 1. Premi OK. A questo punto quando inserisci un componente nell'area grafica ed è trasparente lo puoi ruotare con i tasti che hai letto nei post precedenti. Se il pezzo è già nell'area grafica clicchi il tasto Assemble e poi il pezzo che vuoi muovere.
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#8
Eh? questa mi è nuova...
Ho provato e non funziona, se premo il ctrl trascinandolo me lo mette a terra, se lo premo dopo parte la selezione "rettangolare" ma di ruotarlo cliccandoci sopra nisba.
Si può fare? dove sbaglio? stiamo parlando di Solid Edge?????
Col volante riesco a ruotarlo ed a spostarlo, ma non "semplicemente" cliccandoci sopra e tirando...
Se hai il comando di vincoli automatici non riesci a ruotarlo. devi premere "esc" per uscire dal comando e poi se tieni premuto "ctrl+click sx" lo ruoti. Se è il primo componente che inserisci in un assieme te lo vincola a terra. Devi cancellare il vincolo e poi come sopra lo ruoti.

Questo almeno in ambiente ordinato, in ambiente sincrono presumo sia la stessa cosa.
 

ipotemusa

Utente Standard
Professione: Progettista
Software: Solid Edge e Solid Works
Regione: Veneto
#9
Se hai il comando di vincoli automatici non riesci a ruotarlo. devi premere "esc" per uscire dal comando e poi se tieni premuto "ctrl+click sx" lo ruoti. Se è il primo componente che inserisci in un assieme te lo vincola a terra. Devi cancellare il vincolo e poi come sopra lo ruoti.

Questo almeno in ambiente ordinato, in ambiente sincrono presumo sia la stessa cosa.
La divisione ordinato e sincrono in assembly praticamente non esiste più.
Cmq ho scoperto perchè non mi funzionava... va solo se hai flashfit attivato, ed io NON uso flashfit (dopo aver sistemato assiemi fatti da c....voli).
Quindi non ruoterò i pezzi all'inserimento ed amen.