Riflessi lucidi del colore mancanti su modello

arzigogolo

Utente Standard
Professione: Disegnatore
Software: INVENTOR PRO 2015, Pro/e w 5.0, Solidworks 2012
Regione: LOMBARDIA
#1
Ciao a tutti!

Leggendo una discussione qui sul forum questa http://www.cad3d.it/forum1/showthread.php?t=5588 ho provato per curiosità a scaricare il modello proposto da Sampom, questo: http://www.cad3d.it/forum1/attachment.php?attachmentid=4134&d=1214187660.

Poi l'ho aperto e mi sono accorto che i riflessi lucidi visualizzati sul suo modello, aprendolo nel mio solidworks non venivano visualizzati.

In pratica il modello viene visualizzato opaco invece di lucido come da immagine allegata.

Nella seconda immagine c'è il modello visualizzato correttamente da Sampom.

Ho provato a disattivare l'accelerazione hardware in Soildworks nel pannello opzioni -> "prestazione" per vedere se dipendeva da quello, ma invece niente.

Ho provato a modificare il colore aumentando il valore nella voce "riflessi", ma anche così non succede niente.

Ho provato a cercare su internet e sull'help in linea e ho visto che c'è un'opzione chiamata "Realview" che mi pare dovrebbe servire a questo, però nel menu "visualizza" è disattiva anche se non so per quale motivo.

Non so se dipenda dai drivers della scheda grafica, ma mi sembra strano, perchè all'infuori di questo problema, non mi crea nessun difetto di sorta. L'accelerazione harware è fluida e non ci sono artefatti strani sullo schermo ed in più anche Inventor e SolidEdge funzionano correttamente.

Insomma, non riesco a capire cosa possa essere.:frown:

La mia scheda grafica è più una scheda da videogiochi che per i programmi cad, è la la NVIDIA Geforce 280 Gtx AMP, la versione del driver è il "Forceware v. 196.21" però come ripeto, non mi ha mai dato nè mi dà nessun altro problema all'infuori di questo con Solidworks nè tantomeno con gli altri programmi cad.

Sapete da che cosa potrebbe dipendere?

Grazie a tutti!:smile:
 

Allegati

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#2
La mia scheda grafica è più una scheda da videogiochi che per i programmi cad, è la la NVIDIA Geforce 280 Gtx AMP, la versione del driver è il "Forceware v. 196.21" però come ripeto, non mi ha mai dato nè mi dà nessun altro problema all'infuori di questo con Solidworks nè tantomeno con gli altri programmi cad.

Sapete da che cosa potrebbe dipendere?
Caspita, sei andato ben a ritroso nel tempo per scovare quel vecchio thread :biggrin:

Comunque sì, è "colpa" della scheda grafica. Appunto una gaming e non una Pro certificata. Per rendere attivo il real view (a quella si devono i riflessi del mio modello) servono nVidia QuadroFX o ATI FireGL, schede che abbiano l'OpenGL "nativo via hardware", appositamente dedicate ai programmi CAD. Il tutto è spiegato all'inizio della guida e nel sito SolidWorks nella sezione tecnica riguardo all'hardware compatibile.

Però non disperare, si può in qualche modo aggirare il limite:biggrin:; non mi sembra che il tuo modello sia moddabile via sofware in Quadro FX, però nella discussione Risorse utili per gli utenti SWX trovi una semplice ed efficace Patch postata dall'ottimo SolidUser che permette di attivare la RealView e visualizzare i modelli "dal vero"... ovviamente con quella funzione il sistema rallenta, e molto per grandi e complessi assiemi. Provala.

Saluti
Marco:smile:
 

arzigogolo

Utente Standard
Professione: Disegnatore
Software: INVENTOR PRO 2015, Pro/e w 5.0, Solidworks 2012
Regione: LOMBARDIA
#3
Però non disperare, si può in qualche modo aggirare il limite; non mi sembra che il tuo modello sia moddabile via sofware in Quadro FX, però nella discussione Risorse utili per gli utenti SWX trovi una semplice ed efficace Patch postata dall'ottimo SolidUser che permette di attivare la RealView e visualizzare i modelli "dal vero"... ovviamente con quella funzione il sistema rallenta, e molto per grandi e complessi assiemi. Provala.

Saluti
Marco
Ciao Marco!

Grazie infinite per il suggerimento!:finger:
Appena posso, provo subito la soluzione che mi hai suggerito!
Si, anche se rallenta un po', sono curioso di vedere se mi visualizza i modelli come in schede certificate per Solidworks.
Ma comunque è sempre reversibile? Cioè posso ritornare indietro nel caso mi rallentasse troppo?

Sai com'è, lo so che non è una cosa importante, ma mi sembra come di avere un sistema "azzoppato" se non riesco a visualizzare i riflessi correttamente.:biggrin:

In effetti la mia scheda grafica nei videogiochi è una bomba! E' velocissima a qualsiasi risoluzione anche con gli ultimi titoli di sparatutto 3D, purtroppo il "prezzo" da scontare è una non perfetta compatibilità con alcuni software cad 3d.

Caspita, sei andato ben a ritroso nel tempo per scovare quel vecchio thread
Si, è perchè ho un problema che non riesco a risolvere e allora sono andato a vedere nelle discussioni precedenti del forum per vedere se trovavo la soluzione. Per adesso non l'ho ancora trovata, tenterò ancora per un po' da solo, poi se ancora non riesco, aprirò un nuovo thread qui sul forum.:biggrin:

Grazie ancora!:smile:

Ciao.

Lucio

P.S.

E' da poco tempo che utilizzo Solidworks, però mi piace come software e avendo già esperienza con Inventor, per adesso, riesco a cavarmela abbastanza bene. Vedo chè è molto flessibile in tutte le modalità (parte, assieme e messa in tavola) e soprattutto nella messa in tavola, mi ha colpito l'automatismo che ridispone le quote da solo quando ne cancelli qualcuna. Uno spasso!
 

arzigogolo

Utente Standard
Professione: Disegnatore
Software: INVENTOR PRO 2015, Pro/e w 5.0, Solidworks 2012
Regione: LOMBARDIA
#4
Funziona alla grande!!:finger:

Ottimo!

Adesso bisogna vedere quanto rallenta negli assiemi, però già così va benissimo.
 

Allegati

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#5
Funziona alla grande!!:finger:

Ottimo!

Adesso bisogna vedere quanto rallenta negli assiemi, però già così va benissimo.
Rallenta solo con la RealView attiva, quando la togli torna come prima.

Comunque puoi "disinstallare" completamente la patch (ma non ti dà fastidio, tienila pure); se ci hai fatto caso nella stessa finestra d'installazione c'è la possibilità di "tornare indietro".

Saluti
Marco

P.S. per l'altro problema chiedi pure tranquillamente.
 

arzigogolo

Utente Standard
Professione: Disegnatore
Software: INVENTOR PRO 2015, Pro/e w 5.0, Solidworks 2012
Regione: LOMBARDIA
#6
Rallenta solo con la RealView attiva, quando la togli torna come prima.

Comunque puoi "disinstallare" completamente la patch (ma non ti dà fastidio, tienila pure); se ci hai fatto caso nella stessa finestra d'installazione c'è la possibilità di "tornare indietro".

Saluti
Marco

P.S. per l'altro problema chiedi pure tranquillamente.
Ciao Marco.

Si, ho notato che nella finestra di dialogo della patch c'è la voce "restore", per cui basta cliccare e lui ripristina i valori precedenti la modifica.
Ma che tu sappia, la modifica interessa solo Solidworks o anche i giochi che fanno uso di librerie Opengl?

Comunque non la disinstallo perchè, come dici tu, basta attivarla e disattivarla alla bisogna che non c'è necessità di disinstallarla.:finger:

Grazie per la disponibilità, allora visto che non sono ancora riuscito ad ottenere il risultato che volevo, posto in una nuova discussione il problema che vorrei risolvere.

Ho chiamato la discussione "Curvare una superficie".

Ci vediamo lì.:smile:

Grazie.

Ciao
Lucio
 

SolidUser

Utente Senior
Professione: Progettista
Software: SolidWorks 2013 SP1.0
Regione: Veneto
#7
Ciao Marco.

Si, ho notato che nella finestra di dialogo della patch c'è la voce "restore", per cui basta cliccare e lui ripristina i valori precedenti la modifica.
Ma che tu sappia, la modifica interessa solo Solidworks o anche i giochi che fanno uso di librerie Opengl?
Riguarda solo SW.
Mette una stringa nei registri di Windows sotto una voce di SW che gli dice che la tua scheda video supporta il RV.
 

arzigogolo

Utente Standard
Professione: Disegnatore
Software: INVENTOR PRO 2015, Pro/e w 5.0, Solidworks 2012
Regione: LOMBARDIA
#8
Riguarda solo SW.
Mette una stringa nei registri di Windows sotto una voce di SW che gli dice che la tua scheda video supporta il RV.
Benissimo!:finger:
Era proprio quello che volevo sapere!

Mi sta bene così, almeno non fa pasticci con altre applicazioni.

Grazie mille!:smile:

Ciao.

Lucio