[Recuperato] principiante solidworks

Oldwarper

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Solidworks, Cimatron IT, Cimatron E, Rhino, AutoCAD, Logopress, Solidcam
Regione: Emilia Romagna
#1
-Discussione recuperata dalla cache di Google.
-I rispettivi moderatori sono autorizzati a cancellare o modificare la presente discussione dal proprio forum.
Grazie per la collaborazione.
Oldwarper.


Manca una pagina


25-09-2007, 18.33.45
serbring

grazie per la risposta...per quanto riguarda il fatto che il sottoassieme non si muove, i corpi se non fanno parte del sottoassieme si muovono senza problemi, ma quando creo il sottoassieme si bloccano eppure sono indicati come flessibili....quindi non penso che il problema sia dovuto ai vincoli errati



25-09-2007, 18.42.17
serbring

grazie per la risposta...il problema è che finchè non creo un sottoassieme si muovono bene...è quando lo creo che si bloccano eppure è flessibile



26-09-2007, 10.12.59
OldWarper

Non riesco a capire: cosa significa "finche' non creo un sottoassieme"?
Se crei un sottoassieme, quel sottoassieme lo puoi aprire come assieme a se' stante. In tal caso i pezzi si devono muovere tra di loro.
Se questo sottoassieme lo inserisci in un altro assieme, questo sottoassieme e' rigido, finche' tu non indichi nelle proprieta' del sottoassieme che deve essere "flessibile". A quel punto i particolari del sottoassieme si devono muovere come se tu li muovessi da dentro il sottoassieme stesso.
Se non hai chiara la cosa, ti conviene mettere tutti i pezzi in un assieme solo o fare sottoassiemi solo di pezzi rigidi e poi assemblarli. anche perche' i sottoassiemi flessibili sono un po' indigesti da gestire.



26-09-2007, 10.40.44
Alex_CM

Citazione:Originalmente inviato da OldWarper
...perche' i sottoassiemi flessibili sono un po' indigesti da gestire.
Personalmente, confermo. In realtà se fatti con un poco di criterio non danno troppi problemi, più che altro tendono a rendere il sistema "instabile" con crash frequenti. O almeno nel mio caso.
Saluti



28-09-2007, 18.28.22
serbring

Citazione:Originalmente inviato da OldWarper
Non riesco a capire: cosa significa "finche' non creo un sottoassieme"?
Se crei un sottoassieme, quel sottoassieme lo puoi aprire come assieme a se' stante. In tal caso i pezzi si devono muovere tra di loro.
Se questo sottoassieme lo inserisci in un altro assieme, questo sottoassieme e' rigido, finche' tu non indichi nelle proprieta' del sottoassieme che deve essere "flessibile". A quel punto i particolari del sottoassieme si devono muovere come se tu li muovessi da dentro il sottoassieme stesso.
Se non hai chiara la cosa, ti conviene mettere tutti i pezzi in un assieme solo o fare sottoassiemi solo di pezzi rigidi e poi assemblarli. anche perche' i sottoassiemi flessibili sono un po' indigesti da gestire.
dopo aver assemblato i vari componenti, questi si muovono senza problemi. Dopo averli selezionati, andato su inserisci, assieme, da elementi selezionati....e poi vado su propietà e lo rendo flessibile il sottoassieme non si muove più....spero di essere stato più chiaro



28-09-2007, 18.38.31
Pagnocco

C'è qualcosa che sbagli nei passaggi, si devono muovere le parti che compongono il sottoassieme. Ma una volta creato il sottoassieme, questo è vincolato a qualcosa? Non è che sia vincolato in modo che non riesca più a muoversi?



28-09-2007, 19.03.20
OldWarper

Citazione:Originalmente inviato da serbring
dopo aver assemblato i vari componenti, questi si muovono senza problemi. Dopo averli selezionati, andato su inserisci, assieme, da elementi selezionati....e poi vado su propietà e lo rendo flessibile il sottoassieme non si muove più....spero di essere stato più chiaro
Procedimento sbagliato.
I vincoli tra i particolari del sottoassieme vanno fatti NEL sottoassieme. Ovvero, prima fai il sottoassieme, con tutti i particolari richiesti e gli accoppiamenti relativi. POI inserisci questo sottoassieme nell'assieme principale, lo rendi flessibile e infine crei i vincoli tra i particolari dell'assieme e quelli del sottoassieme.
In gergo emccanico, monti i segmenti e la biella nel pistone, poi metti il tutto nel motore.
Inutile sperare che i vincoli tra pezzi nell'assieme vengano poi correttamente mantenuti nel sottoassieme e distinti da quelli che devono diventare esterni ad esso. In teoria possibile, ma in pratica impossibile.



01-10-2007, 14.18.01
serbring

vi ringrazio...



01-10-2007, 14.42.49
OldWarper

Specifico meglio quello del post precedente.
In teoria, prendendo un gruppo di parti in un assieme e creando con questo un sottoassieme, vengono mantenuti i vincoli tra le parti stesse, ma quelli tra una parte e l'altra che appartengono una al nuovo sottoassieme e l'altra che rimane nell'assieme origine vengono interrotti. Occorree ripristinarli in seguito come accoppiamenti tra sottoassieme e assieme. Non so se con le nuove versioni il comportamento e' migliorato, ma ne dubito (andrebbe contro la logica del montaggio: un accoppiamento di parte che dev'essere trasferito in un accoppiamento di assieme), ma chissa'...



02-10-2007, 14.22.00
serbring

mmm...nn mi è molto chiaro, ma adesso farò delle prove...il problema è che se io creo il sottoassieme con tutti i vincoli tra i componenti dell'assieme, poi quando lo inserisco nell'assieme principale esso mi prende tutto il sottoassieme come un blocco unico. Questo, oltre a non farmi muovere il sottoassieme, mi crea non mi permette di creare gli esplosi (a me seriverebbe anche riutilizzare gli esplosi del sottoassieme). Se invece, creo il sottoassieme senza vincoli, e poi mettendo il sottoassieme nell'assieme principale, non mi viene preso come un componente unico, posso selezionare singolarmente ogni componente del sottoassieme e posso fare anche gli esplosi, però non mi fà mettere i vincoli perchè mi dice che i vincoli devono essere fatti tra entità che appartengono ad elementi differenti.

Inoltre spiegami una cosa, ho una vista in sezione in cui devo quotare un raccordo. In tutti i raccordi non'ho problemi ma ce nè uno in particolare, nel quale mi scrive "R REALE" anzichè "R". Come mai?
 
Ultima modifica da un moderatore:

Oldwarper

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Solidworks, Cimatron IT, Cimatron E, Rhino, AutoCAD, Logopress, Solidcam
Regione: Emilia Romagna
#2
02-10-2007, 15.02.19
Alex_CM

Citazione:Originalmente inviato da serbring
mmm...nn mi è molto chiaro, ma adesso farò delle prove...il problema è che se io creo il sottoassieme con tutti i vincoli tra i componenti dell'assieme, poi quando lo inserisco nell'assieme principale esso mi prende tutto il sottoassieme come un blocco unico. Questo, oltre a non farmi muovere il sottoassieme, mi crea non mi permette di creare gli esplosi (a me seriverebbe anche riutilizzare gli esplosi del sottoassieme). Se invece, creo il sottoassieme senza vincoli, e poi mettendo il sottoassieme nell'assieme principale, non mi viene preso come un componente unico, posso selezionare singolarmente ogni componente del sottoassieme e posso fare anche gli esplosi, però non mi fà mettere i vincoli perchè mi dice che i vincoli devono essere fatti tra entità che appartengono ad elementi differenti.
Inoltre spiegami una cosa, ho una vista in sezione in cui devo quotare un raccordo. In tutti i raccordi non'ho problemi ma ce nè uno in particolare, nel quale mi scrive "R REALE" anzichè "R". Come mai?
Primo: per fare la vista esplosa, abbi cura di metter un flag nell'opzione "Seleziona componenti dei sottoassiemi" all'interno del Property Manager della funzione.
Secondo: R REALE compare quando il raccordo non è perfettamente ortogonale al tuo punto di vista. Esempio: se quoto un foro su di una superficie inclinata che NON E' ortogonale al mio punto di vista nella vista di disegno allora la quota risulterà come R REALE XXX.

Claro?
Saluti



02-10-2007, 15.03.24
alexskull

Citazione:Originalmente inviato da serbring
mmm...nn mi è molto chiaro, ma adesso farò delle prove...il problema è che se io creo il sottoassieme con tutti i vincoli tra i componenti dell'assieme, poi quando lo inserisco nell'assieme principale esso mi prende tutto il sottoassieme come un blocco unico.
tasto destro- proprieta - risolvi in modo flessibile
a quel punto il sottassieme si puo' muovere come se fosse aperto singolarmente

Citazione:Originalmente inviato da serbring
Questo, oltre a non farmi muovere il sottoassieme, mi crea non mi permette di creare gli esplosi (a me seriverebbe anche riutilizzare gli esplosi del sottoassieme).
se hai fatto l'esploso nel sottassieme, vai nell'assieme superiore e crea l'esploso, in basso nella finestra di esplosione ce il pulsante "riutilizzo esplosione sottassiemi"

Citazione:Originalmente inviato da serbring
Se invece, creo il sottoassieme senza vincoli, e poi mettendo il sottoassieme nell'assieme principale, non mi viene preso come un componente unico, posso selezionare singolarmente ogni componente del sottoassieme e posso fare anche gli esplosi, però non mi fà mettere i vincoli perchè mi dice che i vincoli devono essere fatti tra entità che appartengono ad elementi differenti.
questo e' un modo scorretto di procedere perche' i vincoli tra due oggetti di un assieme devono stare in quell'assieme (e non a livello superiore)

Citazione:Originalmente inviato da serbring
Inoltre spiegami una cosa, ho una vista in sezione in cui devo quotare un raccordo. In tutti i raccordi non'ho problemi ma ce nè uno in particolare, nel quale mi scrive "R REALE" anzichè "R". Come mai?
probabilemente e' in una vista in cui la proiezione non e' un arco e ti ribadisce il fatto che il Raggio e' Reale e non proiettato

Alex Skull



03-10-2007, 09.48.05
serbring

ragazzi vi ringrazio ora è andato bene....mi è rimasto un ultimo problema. Devo quotare un raggio di 500mm il cui centro è al di fuori della tavola. Lui automaticamente mi mostra la linea di quota che parte dal centro della circonferenza. Come posso fare in modo che la linea di quota sia tagliata e che non parta dal centro?



03-10-2007, 10.09.48
OldWarper

Seleziona la quota\tastoDX\opzioni di visualizzazione\Di scorcio
oppure
Proprieta'\Raggio accorciato
POI
\?\Guida in linea di Solidworks\Disegni.



03-10-2007, 12.02.58
serbring

GRAZIE MILLE!
un ultima domanda...
ho un profilo strano di un componente meccanico, già fatto. Pensavo di scanerizzare il componente meccanico, e di create un'immagine vettoriale del profilo. Ora c'è un modo con sw2005 di mettere il profilo in uno schizzo in modo da poterlo poi estruderlo e riavere il componente 3d? Ho cercato nella guida, ma non'ho trovato nulla...forse non'ho cercato con i termini giusti....



03-10-2007, 12.19.49
OldWarper

FAi uno schizzo.
Strumenti\strumenti dello schizzo\immagine dello schizzo.
Carichi l'immagine e "ricalchi" con entita' di schizzo l'immagine. Se invece l'hai gia' vettorializzata, la importi come DXF o DWG e con gli strumenti "da 2D a 3D" ottieni il pezzo.



05-10-2007, 18.33.13
vozzydriver

assieme di parti
Avendo un assieme di + parti come faccio ad esportare le singole parti in formato parasolid text?per ora apro una parte alla volta e le salvo manualmente...cè qualche procedura automatica? grazie



06-10-2007, 16.59.56
alexskull

solidworks task scheduler
lo trovi dentro gli strumenti solidworks sul menu di windows
puoi esportare intere directory nel formato che vuoi

Alex Skull
 
Ultima modifica da un moderatore: