Rappresentazioni di posizione/vincoli in conflitto.

russotto

Utente Junior
Professione: progettista
Software: inventor - autocad - solid edge
Regione: piemonte
#1
Buongiorno a tutti,
sto impazzendo dietro ad un assieme di inventor. Non c'è modo di far funzionare le rappresentazioni di posizione.

Ho (ri)creato l'azzieme da zero per essere sicuro di aver messo solo i vincoli strettamente necessari, ho eliminato tutti i vincoli di tangenza (pare che Inventor faccia fatica a digerirli) ho creato delle rappresentazioni di posizione in cui dei cilindri si portano da lavoro a riposo ma ogni volta c'è un vincolo diverso (e per niente interessato dal movimento in questione) che va in conflitto.
Qualche volta, per sviare il problema, basta trascinare un po' il modello per costringerlo a ricalcolare tutte le posizioni; altre volte, questa tecnica peggiora solo le cose.
Qualcuno può aiutarmi?
:36_1_4:
 

Catafratto

Utente Standard
Professione: Disegnatore/progettista
Software: Inventor 2016
Regione: Veneto
#3
Buongiorno a tutti,
sto impazzendo dietro ad un assieme di inventor. Non c'è modo di far funzionare le rappresentazioni di posizione.

Ho (ri)creato l'azzieme da zero per essere sicuro di aver messo solo i vincoli strettamente necessari, ho eliminato tutti i vincoli di tangenza (pare che Inventor faccia fatica a digerirli) ho creato delle rappresentazioni di posizione in cui dei cilindri si portano da lavoro a riposo ma ogni volta c'è un vincolo diverso (e per niente interessato dal movimento in questione) che va in conflitto.
Qualche volta, per sviare il problema, basta trascinare un po' il modello per costringerlo a ricalcolare tutte le posizioni; altre volte, questa tecnica peggiora solo le cose.
Qualcuno può aiutarmi?
:36_1_4:
A volte capita quando l'assieme è sottovincolato; magari prova a fissare tutto quello che non si muove e vedi un po' che succede.
 

russotto

Utente Junior
Professione: progettista
Software: inventor - autocad - solid edge
Regione: piemonte
#4
Potrei provare, ma, se anche fosse così, non risolverei il problema. Di fatto, già ora, ciò che non deve muoversi è completamente vincolato. A parte le viti che possono girare (prima avevo vincolato anche la rotazione ma erano i primi vincoli ad impazzire).
 

Catafratto

Utente Standard
Professione: Disegnatore/progettista
Software: Inventor 2016
Regione: Veneto
#7
Vedo nella che nell lista dei tuoi software non c'è Inventor, quindi suppongo non sia il tuo cad di preferenza e perciò ti faccio una precisazione magari inutile: fissato non vuol dire vincolato. Leggo che "trascini" l'assieme... comunque almeno qualcosa è fissato all'origine, vero? Altrimenti ciò che ti accade è "normale"...
 

stefanobruno

Moderatore
Staff Forum
Professione: Progettazione caotica e notturna e Seguace Anonimo di Shiren :)
Software: Inventor 2016 - Autocad ( read only ) - Rhino un pochino
Regione: Piemonte,Torino
#8
Capire cosa succede è già difficile nel iam che ho sul mio monitor, figuriamoci quando capita a miglia di distanza.
Comunque i motivi possono essere :
- l' assieme è sotto vincolato.
- le viti girano.
- hai vincolato le viti con gli imate.
- il commerciale ( cilindri, snodi ecc. ) scaricato dal sito del produttore è malfatto ( ce n'è più di quanto si pensi ).
- hai proprio sbagliato qualche vincolo.

Ciao
 

russotto

Utente Junior
Professione: progettista
Software: inventor - autocad - solid edge
Regione: piemonte
#9
Chiedo scusa a tutti per aver tralasciato questo post. Rispondo velocemente ai vostri messaggi:
Inventor non compariva nella lista solo perché questa non era aggiornata, di fatto da ottobre 2011 ci lavoro a tempo pieno.
Il telaio di base della macchina era completamente vincolato ai piani di origine.
I cilindri sono stati modellati nell'azienda presso la quale mi trovo (e li ho anche controllati senza trovare errori)
Il fatto di aver sbagliato qualche vincolo è l'unica (e anche la più plausibile) delle spiegazioni.

Soluzione:
alla fine ho ricostruito l'assieme da zero.
 

pompeo79

Utente Standard
Professione: Digital Prototyping
Software: Inventor - Autocad - Showcase
Regione: Piemonte-Liguria
#10
Capire cosa succede è già difficile nel iam che ho sul mio monitor, figuriamoci quando capita a miglia di distanza.
Comunque i motivi possono essere :
-1 l' assieme è sotto vincolato.
-2 le viti girano.
-3 hai vincolato le viti con gli imate.
-4 il commerciale ( cilindri, snodi ecc. ) scaricato dal sito del produttore è malfatto ( ce n'è più di quanto si pensi ).
- hai proprio sbagliato qualche vincolo.

Ciao
Interessante , mi puoi spiegare meglio i punti 2 e 3? Grazie!!
 

stefanobruno

Moderatore
Staff Forum
Professione: Progettazione caotica e notturna e Seguace Anonimo di Shiren :)
Software: Inventor 2016 - Autocad ( read only ) - Rhino un pochino
Regione: Piemonte,Torino
#11
Interessante , mi puoi spiegare meglio i punti 2 e 3? Grazie!!
2 - evitare che le viti ( e le rondelle collegate ) girino sul loro asse, bloccandole una riferita all' altra
3 - gli imate funzionano benissimo come primo posizionamento, quando cominci a cambiare il passo od il numero di fori usati dalle viti, i guai sono in agguato.

2bis - vale per tutto il resto, cuscinetti, tubi, alberi, tutto quello che in realtà è giusto che giri, per Inventor è meglio che sia bloccato.
Se vuoi vedere qualcosa che gira, gli metti un vincolo angolare e lo piloti con " animazione vincoli ".
 

russotto

Utente Junior
Professione: progettista
Software: inventor - autocad - solid edge
Regione: piemonte
#12
Ciao Pompeo79,
provo io a spiegare:
punto 2; le viti girano: solitamente le viti vengono fissate con i soli vincoli di concentricita tra la vite ed il foro e di coincidenza tra la testa della vite e la superficie su cui la testa stessa deve fare battuta. Resta ancora la possibilità per la vite di girare. (non è che giri da sola)
punto 3; viti vincolate con gli Imate: gli Imate, come tutte le opzioni che semplificano la vita di chi lavora, creano più problemi che vantaggi.
Spero di aver soddisfatto a sufficienza la tua curiosità.
 

pompeo79

Utente Standard
Professione: Digital Prototyping
Software: Inventor - Autocad - Showcase
Regione: Piemonte-Liguria
#13
2 - evitare che le viti ( e le rondelle collegate ) girino sul loro asse, bloccandole una riferita all' altra
3 - gli imate funzionano benissimo come primo posizionamento, quando cominci a cambiare il passo od il numero di fori usati dalle viti, i guai sono in agguato.

2bis - vale per tutto il resto, cuscinetti, tubi, alberi, tutto quello che in realtà è giusto che giri, per Inventor è meglio che sia bloccato.
Se vuoi vedere qualcosa che gira, gli metti un vincolo angolare e lo piloti con " animazione vincoli ".
Grazie Stefano!
Ok gli iMate, ma le bullonerie se girano sul proprio asse come interferiscono sul cambio di rapp di posizione?
 

stefanobruno

Moderatore
Staff Forum
Professione: Progettazione caotica e notturna e Seguace Anonimo di Shiren :)
Software: Inventor 2016 - Autocad ( read only ) - Rhino un pochino
Regione: Piemonte,Torino
#14
le bullonerie se girano sul proprio asse come interferiscono sul cambio di rapp di posizione?

il programma non fa differenza tra tipo di vincoli.
Se è tutto definito, calcola le varianti e basta, se c'è dell' incertezza nel vincolo questa genera iterazioni inutili.
Non lo dico perchè conosco nell' intimo il programma, è solo una ipotesi che faccio, ma è sostenuta da quanto ho verificato negli anni e da quanto vedo ogni giorno.

Ciao.