Problema tra relazioni e parametri

Daniele-san

Utente Standard
Professione: Mechanical Design Engineer
Software: ProEngineer/Wildfire/Creo 2.0/Creo 3.0/Creo 4.0
Regione: Marche
#1
Buongiorno a tutti,
Purtroppo ho un problema e non riesco a risolverlo senza il vostro aiuto!
Ho dovuto per forza riapriate una nuova discussione perché forse la precedente ha avuto un calo di importanza.
Si parlava dello stesso argomento e lo rigetto qua:

Ciao Ragazzi,
mi sono accorto di avere un problema appena faccio un cambio formato disegno (anche reimmettendo lo stesso formato) collegato ad una prt/asm con le seguenti relazioni:

if EDIZIONE_01==YES
DRAWING_ED01="02"
else
DRAWING_ED01="-"
endif

questa relazione non funzione e nella tabella del drw devo ridifitare manualmente il parametro ad essa collegato
cioè: DRAWING_ED01

facendo un passo indietro e partendo dal template start_part.prt/asm con drw associato tutto funziona a dovere.

Il problema praticamente si presenta quando faccio un cambio formato (anche reimmettendo lo stesso formato)

sapete aiutarmi?
Se avete necessità di ulteriori info al riguardo fatemi sapere
Scusate ancora se sono ripartito con una nuova discussione

Ciao

grazie
ciao
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#2
Potresti allegare un prt,drw,frm con il problema? Perchè fatto così al volo a me sembra funzioni anche con la sostituzione cartiglio.
 

Daniele-san

Utente Standard
Professione: Mechanical Design Engineer
Software: ProEngineer/Wildfire/Creo 2.0/Creo 3.0/Creo 4.0
Regione: Marche
#3
Potresti allegare un prt,drw,frm con il problema? Perchè fatto così al volo a me sembra funzioni anche con la sostituzione cartiglio.
ciao luca1669
grazie per la tua risposta e perdonami il ritardo della risposta.
ti allego quanto richiesto.
il problema a me capita quando dopo aver creato una parte o assieme con la start part o asm andando successivamente a sostituire il formato devo riscrivere tutto quello che dovrebbe fare in automatico con le relazioni
 

Allegati

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#4
Ciao, ti allego un formato dove ho sostituito i riferimenti ai parametri con delle regioni di ripetizioni(sempre riferiti ai parametri). Quando usavo Pro/E wf2 era il modo migliore per fare i cartigli; adesso, sinceramente, nemmeno con la tua tabella mi da gli errori che trovi tu.
Nei drw che ti danno problemi ci sono più modelli(asm o prt) visualizzati?Hai aggiunto le relazioni anche nel modello degli assiemi? Se riesci a riprodurre il problema sistematicamente mi potresti dire la procedura: io ho provato a fare 2 parti, un assieme e poi fare un disegno dove ho sostituito più volte il cartiglio e i modelli rappresentati ma mi funziona sempre correttamente.
Ciao
 

Allegati

Daniele-san

Utente Standard
Professione: Mechanical Design Engineer
Software: ProEngineer/Wildfire/Creo 2.0/Creo 3.0/Creo 4.0
Regione: Marche
#5
ciao luca1669,
ti ringrazio del formato con le correzioni che hai postato
scusa il ritardo ma riesco a malapena il sabato a fare delle prove. :redface:
ho visto che in ogni tabella hai aggiunto "&mdl.top_generic.mio parametro"
ho fatto una prova e sembra che funzioni alla perfezione. :finger:
Mi spiegheresti a cosa serve quel "prefisso"?

grazie?
Buon week End
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#6
Ciao sono tante regioni di ripetizioni (non le ho editate manualmente ma con il comando apposito). Sono tabelle che possono servire a molteplici utilizzi. Fra quelli che mi ricordo ci sono estrapolare dati da family table e dati dal modello in modo più stabile rispetto al classico & soprattutto sui disegni multimodello. Questo è quel poco che ricordo (non lavoro con proe da 5 anni). Ciao
 

Daniele-san

Utente Standard
Professione: Mechanical Design Engineer
Software: ProEngineer/Wildfire/Creo 2.0/Creo 3.0/Creo 4.0
Regione: Marche
#7
Ciao sono tante regioni di ripetizioni (non le ho editate manualmente ma con il comando apposito). Sono tabelle che possono servire a molteplici utilizzi. Fra quelli che mi ricordo ci sono estrapolare dati da family table e dati dal modello in modo più stabile rispetto al classico & soprattutto sui disegni multimodello. Questo è quel poco che ricordo (non lavoro con proe da 5 anni). Ciao
Ciao luca1969,
nonostante i 5 anni di lontananza non sei arrugginito :p
Mi indicheresti la procedura per la creazione di quel comando?
Crei una regione di rip. semplice clicchi due volte e scegli il comando che precede il parametro?
Ciao
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#9
Nel dettaglio quando fai doppio click devi scegliere mdl poi scegli top_generic poi user defined e digiti il parametro. Non ho sotto mano il cad forse qualche voce non sarà proprio quella esatta.