• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Problema salvataggio....

Professione: piegatore e disegnatore notturno...
Software: Solidworks 2012 sp5
Regione: Toscana
#1
Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

Grazie a tutti, a presto.
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#2
Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

Grazie a tutti, a presto.
Ciao PS :smile:

..non ho capito bene che tecnica hai usato per copiare/salvare quei files..

Hai provato facendo un Pack & Go dall'assieme? Puoi aggiungere pre o suffissi (o cambi i nomi uno ad uno se ne hai voglia), trasferisci tutto in una cartella creata appositamente ed i file richiamati dal "nuovo" assieme dovrebbe ripescarli tutti da lì senza problemi.

Saluti
Marco
 
Professione: Studio ingegneria
Software: AutoCad, SW
Regione: Nordest
#3
Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

Grazie a tutti, a presto.

Fai così:
Salva con nome
Clicca Riferimenti
Cambia la vecchia cartella con quella nuova
Eventualmente aggiungi dei Prefissi/Suffissi
Clicca Salva tutto come copia
Clicca "Salva tutto".
 
Professione: piegatore e disegnatore notturno...
Software: Solidworks 2012 sp5
Regione: Toscana
#4
Fai così:
Salva con nome
Clicca Riferimenti
Cambia la vecchia cartella con quella nuova
Eventualmente aggiungi dei Prefissi/Suffissi
Clicca Salva tutto come copia
Clicca "Salva tutto".
Si esatto anche io ho fatto cosi,cioè ho aperto l'assieme ed ho fatto come mi dici tu ma il risultato è che nella nuova cartella mi salva solo il file di insieme e non i singoli file dei particolari. Dove sbaglio? Quando poi apro il nuovo file di assieme nella nuova cartella e poi decido di aprire uno dei particolari in esso contenuto, solidworks mi apre si il file ma nella vecchia cartella...

C'è qualcosa che non va...!
 

Oldwarper

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Solidworks, Cimatron IT, Cimatron E, Rhino, AutoCAD, Logopress, Solidcam
Regione: Emilia Romagna
#5
Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

Grazie a tutti, a presto.
Allora, gia' ti dovrebbe essere chiaro che nei files di assieme e' inserita la posizione dei files che lo compongono. Se salvi come semplice copia, i riferimenti non verranno cambiati, perche' non sa che degli altri files ne esiste una copia corrispondente. Per questo MAI copiare tramite Esplora risorse se non per motivi di backup.

Il Salva come copia in Solidworks non fa altro che salvare lo STESSO file con gli STESSI riferimenti con un altro nome, senza pero' aggiornare il riferimento nell'assieme padre.

I modi corretti per copiare un assieme sono i seguenti;
1) Utilizzare Solidworks Explorer e usare la funzione Pack and Go, in cui potrai aggiungere anche un prefisso/suffisso in automatico a tutti i file e/o rinominare le singole parti/assiemi copiate mantenendo aggiornati i riferimenti nei particolari/assiemi che fanno riferimento ad esso.
2) In Esplora Risorse di Windows, tasto DX, menu Solidworks, Pack and Go, vedi sopra
3) In Solidworks, File\Trova riferimenti\Copia file e ci si trova ancora in una schermata uguale a quella del Pack and Go.

Il modo scorretto per copiare un assieme e' il seguente:
1) copia tutto l'assieme e i particolari in un'altra cartella
2) rinomina la cartella originale in modo da non farla piu' trovare dall'assieme
3) apri l'assieme copiato e digli di volta in volta dove trovare i file che non trova piu' (molte volte una volta indicato il primo di una cartella poi trova gli altri)
4) Rinomina la cartella originale al nome originale.

In questo modo rischi che alcuni file non vengano sincronizzati, in quanto alcuni riferimenti di singole parti non vengono aggiornate.

Capita inoltre che sia con pack and go che copia bruta alcuni files (parti derivate, offset di superfici nel contesto) vadano a pallino i riferimenti e il nuovo assieme peschi ancora nel vecchio. Per questo a volte faccio packandgo e rinomina di cartella, poi apro il nuovo assieme e lo ricostruisco, specie i sottoassiemi e le parti derivate, per scoprire se qualche riferimenti e' rimasto indietro.
 
Professione: piegatore e disegnatore notturno...
Software: Solidworks 2012 sp5
Regione: Toscana
#6
Grazie ragazzi ho provato con pack & go ed ho risolto tutto. Mi pare che l'altra volta avevo fatto salva cambiando riferimenti ma forse ricordo male!

Grazie ancora, a presto.

Marco.
 
Professione: Studio ingegneria
Software: AutoCad, SW
Regione: Nordest
#7
Grazie ragazzi ho provato con pack & go ed ho risolto tutto. Mi pare che l'altra volta avevo fatto salva cambiando riferimenti ma forse ricordo male!

Grazie ancora, a presto.

Marco.
Infatti... avevi seguito quello che ti dicevo io più sopra.
Il pack & go è stato inserito recentemente, fin prima si faceva tranquillamente con il Save as...