• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Problema quotatura pezzi con family table

emameme

Utente poco attivo
Professione: Disegnatore/Progettista
Software: Catia V5-Inventor-Autocad 2D-Catia V4-SolidEdge-Solidworks-
Regione: Lombardia
#1
Ciao ragazzi, è da qualche settimana che ho iniziato ad utilizzare pro-e wf4 e devo dire che è molto macchinoso. Attualmente il mio compito è quello di mettere in tavola i pezzi che il cliente mi fornisce e con alcuni di essi ho davvero dei problemi. Certi sono creati con le family table, quindi parto a mettere in tavola il "padre"(*492.prt), salvo il .drw e poi lo chiudo. Per velocizzare il lavoro copio il .drw appena creato con il nome del "figlio"(*493.drw), lo apro e faccio: File\proprietà\sostituisci modello\ e gli imposto il "figlio"(*493, che è creato come family table). Faccio Fine, aggiusto le quote che hanno perso i punti di appoggio(quelle di colore viola), aggiungo se necessario qualche quota e infine salvo. Chiudo tutto, riapro il "padre"(*492.drw) e questo ha perso quelle quote che avevo aggiustato/creato sul "figlio"(*493). Se provo a sistemarlo le perdo sull'altro. Sapete dirmi come mai? Rimane qualche associamento strano anche se ho due .drw nominati diversamente??

Grazie!
 

calacc

Utente Standard
Professione: Product Development Engineering Specialist
Software: CREO Parametric 2.0 M230
Regione: Emilia Romagna
#2
Scusa, ma è proprio necessario per il tuo lavoro che metti in tavola il padre? Io di solito faccio il giochino del "salva copia" e "sostituisci modello" solo sulle instance e non ho mai avuto di questi problemi...
Se a mio avviso le family table sono create a modo, il *.prt generico è solo un modello di appoggio per creare le varianti, ma non è da mettere in tavola!
Cioè, se ho un prt generico con x instance da mettere in tavola io faccio così: faccio il drw della prima instance (E NON DEL GENERICO!!!), poi salva copia col nome della instance 2 e sostituisci modello. Questo giochino poi lo ripeto per quante volte sono le instance...
 

emameme

Utente poco attivo
Professione: Disegnatore/Progettista
Software: Catia V5-Inventor-Autocad 2D-Catia V4-SolidEdge-Solidworks-
Regione: Lombardia
#3
Eh si il padre la hanno creata come instance e non come modello di appoggio...non sono stati molto dei geni ^_^. E sto problema non so come risolverlo.
Cmq ora provo ad usare il "salva copia"\"sostituisci modello" che magari è meglio del mio copia\incolla :)
 

DANI-3D

Utente Senior
Professione: PROGETTISTA MECCANICO
Software: PRO-E WF5
Regione: TOSCANA
#4
Ciao,
Hai provato con un rinomina in sessione del drw? E poi sostituisci il prt.
 

calacc

Utente Standard
Professione: Product Development Engineering Specialist
Software: CREO Parametric 2.0 M230
Regione: Emilia Romagna
#5
Eh si il padre la hanno creata come instance e non come modello di appoggio...non sono stati molto dei geni ^_^. E sto problema non so come risolverlo.
Cmq ora provo ad usare il "salva copia"\"sostituisci modello" che magari è meglio del mio copia\incolla :)
Se ti è consentito, ti consiglio di aggiungere una riga di instance appena sotto il padre copiando la riga di tabella coi valori del generico e di partire da lì con le tue tavole. In questo modo eviteresti di incasinarti con la messa in tavola del padre. Dovresti prima magari sentirti al telefono col cliente e vedere se è d'accordo con questa soluzione, che a mio avviso è la più efficace (ancora non riesco a capire il perché utilizzino il generico come instance a tutti gli effetti ma boh :confused:). L'unico problema è che magari hanno già assemblato erroneamente il generico chissà dove, quindi nell'assieme dovrebbero far la fatica di fare tasto destro\ sostituisci componente\ family ecc... quindi potrebbero essere un po' scocciati da quello... Magari se gli scoccia proponi di passarti l'assieme e fallo te (magari con una macro).
Poi prova al posto del salva copia a fare il rinomina in sessione come suggerisce dani! Devi andare in file\gestisci file\rinomina\rinomina nella sessione (non nen disco!) poi gli metti il nome della variante successiva e ri-salvi. Molti progettisti ho sentito che lo preferiscono al salva copia ma non so il perché...
 

DANI-3D

Utente Senior
Professione: PROGETTISTA MECCANICO
Software: PRO-E WF5
Regione: TOSCANA
#6
Molti progettisti ho sentito che lo preferiscono al salva copia ma non so il perché...
La differenza sostanziale è che con il salvacopia fai semplicemente una duplicazione del file, ma tutti i riferimenti rimangono legati all' originale.
Mentre con il rinomina in sessione, oltre ad avere una copia fedele, tutti i riferimenti vengono legati al nuovo pezzo, e spesso la cosa è utile.
 

emameme

Utente poco attivo
Professione: Disegnatore/Progettista
Software: Catia V5-Inventor-Autocad 2D-Catia V4-SolidEdge-Solidworks-
Regione: Lombardia
#7
Ciao,
Hai provato con un rinomina in sessione del drw? E poi sostituisci il prt.
Ho appena provato a usare questo metodo, però non sono riuscito a risolvere il problema, continua a "danneggiare" l'altro 2D.
Appena posso, provo ad usare il metodo di Calac e vi faccio sapere. grazie raga
 

calacc

Utente Standard
Professione: Product Development Engineering Specialist
Software: CREO Parametric 2.0 M230
Regione: Emilia Romagna
#8
Mi permetto di insistere, scusa...
Ma non credo si risolva usando il metodo del salva-copia piuttosto del rinomina in sessione!
Anche io all'inizio ho avuto questo inconveniente e l'errore stava nell'interpretare il generico come instance. Per risolvere devi creare un'altra instance con le stesse caratteristiche del generico e partire da lì con le tue tavole (come suggerito sopra). Anche io mi incasinavo sempre con la messa in tavola del generico e da quando l'ho esclusa aggiungendo una riga di instance tutto è andato bene.
Oh poi vedi tu... Magari ero io che non ero abbastanza capace