Problema pubblicazione

marcofa

Utente Standard
Professione: Manager
Software: Autocad Catia
Regione: Liguria
#1
Stò cercando di mettere a fuoco la pubblicazione con successiva sostituzione di Part senza perdere i vincoli.
L'assieme di partenza è Product1.jpg
Effettuo quindi la sostituzione di Part2 corta con Part8 più lunga.
Il risultato è Product1.1.jpg dove si è persa la coincidenza degli assi
Sostituendo Part8 con Part2 cioè tornando indietro si ritorna a Product1.jpg dove la coincidenza è collegata nuovamente.
Allego anche i file CatiaR20.
Qualcuno può disimpantanarmi?
Marco
 

Allegati

Professione: Progettista meccanico
Software: Catia, Think3
Regione: Marche
#2
verifica se nella finestra di definizione del vincolo compare il nome dell'oggetto pubblicato.
se non avviene questo, la sostituzione non va a buon fine.
quando usi i vincoli pubblicati nell'esecuzione del comando usa le lebel sull'albero delle parti pubblicate.

In particolare quando hai a che fare con le coassialità, ti ritrovi con questo errore di svista;
quando usi il comando pubblica, il sistema pubblica la faccia cilindrica, mentre quando usi il comando coassialità viene utilizzato l'asse del foro e/o albero, per cui il sistema non utilizza l'oggetto pubblicato ma un'altro elemento che per forza di cose quando applichi la sostituzione viene persa.

cerca nei forum e troverai come pubblicare l'asse di un foro.

ciao
 

Allegati

marcofa

Utente Standard
Professione: Manager
Software: Autocad Catia
Regione: Liguria
#3
La pubblicazione del foro o dell'albero avviene correttamente:
click dx sul diametro, altre selezione, click su Asse.
Comunque nonostante ciò nella finestra del vincolo non compare il nome.

"quando usi i vincoli pubblicati nell'esecuzione del comando usa le lebel sull'albero delle parti pubblicate." COSA VUOL DIRE?

Non riesco in alcun modo a far comparire il nome nella finestra del vincolo, nonostante che nella finestra della pubblicazione compaia (vedi foto)
Marco
 

Allegati

marcofa

Utente Standard
Professione: Manager
Software: Autocad Catia
Regione: Liguria
#4
"quando usi i vincoli pubblicati nell'esecuzione del comando usa le lebel sull'albero delle parti pubblicate." HO CAPITO

Ma questo è mooooooolto antipatico
http://www-01.ibm.com/support/docview.wss?uid=swg1HD52232
In questo documento è affermato che il problema è risolto dalla R18

Vorrebbe dire che per creare qualunque vincolo, SOLO per gli assi bisogna andarsi a cercare nell'albero la label, invece per tutto il resto si può cliccare l'elemento.

La cosa strana è che accendendo l'asse della Part con la freccia, si illumina anche la label della pubblicazione, come viceversa. Perchè allora non funziona in tutti e due i modi come il resto dei comandi?
Marco
 
Professione: Progettista meccanico
Software: Catia, Think3
Regione: Marche
#5
La soluzione é più semplce di quello che stai cercando.

Se hai notato quando carichi una parte in un assieme noterai che le label dei pubblicati sono visulizzabili indipendentemente dalla geometria della parte, per cui, tu poi accoppiare le parti indipendentemente dalle geometrie, in particolare questo accade, quando accoppi una geometria molto grande con una molto piccola (es vite M5 su una piastra forata 5000x3000 mm con un foro che si trova su uno spigolo opposto al sistema di riferimento della piastra), a volte ti rovi in difficoltà a ritracciare le geometrie sul modello.
Per cui dall'albero accedi più facilmete alle informazione che non direttamente dalla geometria.
Il mio consiglio è che ti devi abituare a ricercare le informazioni sull'albero, più che sulla parte geometrica, perchè oltre tutto, a volte lavorando, ci si appoggia su geometria wire-frame che si tengono oltretutto nascoste.

ciao
 

marcofa

Utente Standard
Professione: Manager
Software: Autocad Catia
Regione: Liguria
#6
Hai ragione, però è altrettanto vero che in alcuni casi bisogna smazzare l'albero per scendere anche molti livelli per individuare il flag voluto.
Ho scoperto che replicando le pubblicazioni volute a livello di product (anche livelli multipli) i flag diventano accessibili subito senza smazzare.
Cosa ne dici?
Ciao
Marco
 
Professione: Progettista meccanico
Software: Catia, Think3
Regione: Marche
#7
Hai ragione, però è altrettanto vero che in alcuni casi bisogna smazzare l'albero per scendere anche molti livelli per individuare il flag voluto.
Ho scoperto che replicando le pubblicazioni volute a livello di product (anche livelli multipli) i flag diventano accessibili subito senza smazzare.
Cosa ne dici?
Ciao
Marco
Ho fatto delle prove, in effetti non avevo mai provato a replicare gli stessi pubblicati delle parti nel loro product ed effettivamente il comportamento è interessante, forse l'unica osservazione che posso sollevare (sempre che, io abbia seguito la tua strada stessa per replicare i vincoli), si fa un lavoro doppio nel replicare i pubblicati (una volta nelle parti e una volta nei product).
A volte io lo faccio quando alcuni di questi pubblicati li riutilizzo per posizionare un assieme in un assieme più grande, proprio per evitare di aprire troppe ramificazioni dell'albero.
Comuque è un comportamento molto interessante, sto continuando a creare delle casistiche ti farò sapere.

ciao
 

marcofa

Utente Standard
Professione: Manager
Software: Autocad Catia
Regione: Liguria
#8
Se la pubblicazione è fatta SOLO a livello di Product (cioè non prima nella part) si dupplica automaticamente anche nella part, quindi il lavoro non è doppio.
Marco