• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Problema dati condivisi

c.marcello

Utente Junior
Professione: Dipendente
Software: autocad-proE
Regione: Venezia Giulia
#1
Buongiorno,
ho provato a cercare sul forum ma non ho trovato nulla che potesse fare al caso mio e quindi vi pongo il quesito :)
premetto che utilizzo in azienda proe wildfire3.0 (da poco) ed ho un problema con i dati condivisi.
In pratica ho fatto tre parti distinte , parte 1 parte 2 e parte3, (dove il centro del sistema di coordinate corrisponde con il centro della figura...sono figure semplici e solamente per prova), poi assiemate. Ora il problema è che se apro la parte 1 ed uso il comando copia geometria (sotto dati condivisi) per copiare le superfici della parte 2 presente nell'assieme le superfici vengono copiate tenendo come assi di riferimento l'asse dell'assieme...indipendentemente se utilizzo l'opzione di selezione della parte (se non ho capito male, anche con la guida in linea, selezionavo l'asse della parte 1 nell'assieme e poi l'asse nella parte 1)o se utilizzo le coordinate di default.
In pratica fa sempre coincidere l'asse dell'assieme con l'asse della parte... ciò mi sta bene se parto dall'assieme e lavoro in top dawn (li creo la parte direttamente dove mi serve e il sitema di riferimento è sempre lo stesso) ma se mi serve in un caso particolare nel flusso di lavoro normae (non top dawn) mi sembra strano che non si possa fare.
Sbaglio qualcosa io o il sistema o versione non permette qualcosa di simile?
Grazie a tutti per l'aiuto
 

DANI-3D

Utente Senior
Professione: PROGETTISTA MECCANICO
Software: PRO-E WF5
Regione: TOSCANA
#2
Ciao.
Devo riconoscere che non ci ho capito molto nella tua richiesta. Ma quelli che chiami assi in realtà sono i piani di riferimento ? Non è la stessa cosa.
Se così fosse, ti consiglio di inserire i prt nell' asm con un vincolo di default, in questa maniera i piani dell' assieme coincidono con quelli del particolare.
 

c.marcello

Utente Junior
Professione: Dipendente
Software: autocad-proE
Regione: Venezia Giulia
#3
Grazie per la risposta Dani,
Quelli che io chiamo assi non sono i piani di riferimento, ma sono i sistemi di coordinate (CSYS_PART_DEF),
Il problema è che per inserirli con un vincolo di default devo già disegnarli nella posizione corretta (come appunto nel topdown) nel mio caso invece le parti inserite nell'assieme vengono posizionate con dei vincoli che vanno a modificare la posizione la loro posizione relativa...
 

DANI-3D

Utente Senior
Professione: PROGETTISTA MECCANICO
Software: PRO-E WF5
Regione: TOSCANA
#4
vengono posizionate con dei vincoli che vanno a modificare la posizione la loro posizione relativa...
In ogni caso, se lavori con pubblica e copia geometria, è meglio vincolare i prt utilizzando i piani, altrimenti rischi di avere dei riferimenti circolari che è una delle cose peggiori che possano capitare.
 

c.marcello

Utente Junior
Professione: Dipendente
Software: autocad-proE
Regione: Venezia Giulia
#5
Scusami dani, ma non riesco a capire l'ultima frase... cioè quando inserisco le parti nell'assieme le posiziono con l'allineamento di piani e facce (di solito).. quando faccio inserisci>dati condivisi>copia geometria nel campo dove seleziono le coordinate (modello rifmto) dopo avermi fatto scegliere il file dell'assieme mi fa selezionare solamente i sistemi di coordinate (o quelli delle singole parti o quello dell'assieme), non mi da la possibilità di selezionare piani...
 

DANI-3D

Utente Senior
Professione: PROGETTISTA MECCANICO
Software: PRO-E WF5
Regione: TOSCANA
#6

c.marcello

Utente Junior
Professione: Dipendente
Software: autocad-proE
Regione: Venezia Giulia
#7
si, l'opzione default c'è, ma come sistema di coordinate di riferimento va a prendere quelle relative all'assieme... quindi nella parte mi fa coincidere le coordinate dell'assieme alle coordinate della parte, solamente che nell'assieme le coordinate relative della parte non coincidono con le coordinate assolute dell'assieme...