• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Problema con Tabelle Dati - Equazioni

IngQualcuno

Utente poco attivo
Professione: studente
Software: Solidworks
Regione: italia
#1
Salve a tutti, sono un nuovo utente e sono anche alle prime armi con Solidworks.

Non sono bravo a parole ma cercherò di spiegare al meglio il mio problema, ho provato a cercare lo stesso problema all'interno del forum ma credo di non averlo trovato.

Ho un assieme composto da più file part. Le dimensioni di molte parti sono equazioni che dipendono dalle dimensioni del file part principale. Una volta completato l'assieme ho creato una tabella dati del file part principale con diverse configurazioni, successivamente ho creato una tabella dati dell'assieme andando a richiamare quella del file part principale.
Quando apro le diverse configurazioni, tutte le dimensioni delle altre parti che sono collegate attraverso equazioni al file part principale si aggiornano tranne una. Quest'ultima è l'unica ad essere una profondità di una estrusione, mentre le altre dimensioni che sono all'interno di schizzi si aggiornano senza problemi.

Per farla più chiara è come se avessi un parallelepipedo di dimensioni x per y estruso di una dimensione a. Poi ho una parte che ha come base uno schizzo qualsiasi e lo estrudo di una profondità x+2. Quando vado a creare una tabella dati del parallelepipedo andando a variare x e y, aprendo le diverse configurazioni, la profondità della seconda parte rimane la "x+2" della precedente configurazione richiamata.
Andando a richiamare modifica funzione e cliccando su ok senza variare nulla, la dimensione si aggiorna alla nuova configurazione.

Avete avuto problemi simili?
Vi ringrazio in anticipo.
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#2
Salve a tutti, sono un nuovo utente e sono anche alle prime armi con Solidworks.

Non sono bravo a parole ma cercherò di spiegare al meglio il mio problema, ho provato a cercare lo stesso problema all'interno del forum ma credo di non averlo trovato.

Ho un assieme composto da più file part. Le dimensioni di molte parti sono equazioni che dipendono dalle dimensioni del file part principale. Una volta completato l'assieme ho creato una tabella dati del file part principale con diverse configurazioni, successivamente ho creato una tabella dati dell'assieme andando a richiamare quella del file part principale.
Quando apro le diverse configurazioni, tutte le dimensioni delle altre parti che sono collegate attraverso equazioni al file part principale si aggiornano tranne una. Quest'ultima è l'unica ad essere una profondità di una estrusione, mentre le altre dimensioni che sono all'interno di schizzi si aggiornano senza problemi.

Per farla più chiara è come se avessi un parallelepipedo di dimensioni x per y estruso di una dimensione a. Poi ho una parte che ha come base uno schizzo qualsiasi e lo estrudo di una profondità x+2. Quando vado a creare una tabella dati del parallelepipedo andando a variare x e y, aprendo le diverse configurazioni, la profondità della seconda parte rimane la "x+2" della precedente configurazione richiamata.
Andando a richiamare modifica funzione e cliccando su ok senza variare nulla, la dimensione si aggiorna alla nuova configurazione.

Avete avuto problemi simili?
Vi ringrazio in anticipo.
Hai provato più volte a forzare il ricalcolo con i tasti CTRL/q ?
 

IngQualcuno

Utente poco attivo
Professione: studente
Software: Solidworks
Regione: italia
#3
Sono riuscito a risolvere il problema, a quanto pare dava problemi con equazioni all'interno del file part. Ho inserito la stessa equazione nel file Assembly togliendola dal file part e tutto si è risolto. Non so per quale motivo, ma ho risolto.