• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

PROBLEMA CON SWEEP e Swept

viper

Utente Junior
Professione: ingegnere
Software: pro/E
Regione: veneto
#1
Ciao a tutti, ho un grossissimo problema a simulare la superficie di una fresa a palla D32 con una lavorazione con fresatrice a 3 assi.
Mi spiego meglio:
Ho due linee guide, la principale che è quella del centro e la secondaria che è la tangenza sfera.

Se faccio una sweep mi genera uno spigolo e la puperficie nn risulta avere raggio R16 costante.

Se faccio una Swept stessa cosa....

Ho provato anche a fare una sweep utilizzando due binari attraverso cui far passare la circonferenza di D32 e imponendo la sezione variabile, ma ancora facenso un'analisi di curvatura non si mantiene il raggio costante!!! e quindi il CAM (Mastercam 10) nn riesce a lavorarmi la superficie.

Qualcuno riesce a darmi una dritta???
Thanks
 

Allegati

Prof.

Utente Standard
Professione: Lavoro con il CAD ed il CAE
Software: Pro-E e Creo
Regione: Lazio
#2
Forse non ho capito bene ma non puoi utilizzare il comando rivoluzione?
Inoltre cos'e lo swept?
 

viper

Utente Junior
Professione: ingegnere
Software: pro/E
Regione: veneto
#3
Ciao Prof!

Allora la swept è la sweep dove metti tu le sezioni dove vuoi per intenderci (allego immagine del pulsante)

Devo simulare l'andamento di una fresa con dei binari nello spazio, quindi non posso fare una rivoluzione!

Non so se son riuscito a spiegarmi. proverò ad allegare domani o lunedì un modello migliore per farti capire la problematica

Grazie dell'aiuto
 

Allegati

Prof.

Utente Standard
Professione: Lavoro con il CAD ed il CAE
Software: Pro-E e Creo
Regione: Lazio
#4
Quello che tu chiami Swept si chiama Blend di Sweep, comunque per fare ciò che ti serve potresti utilizzare il comando Sweep a sezione variabile.
Ciao.
 

viper

Utente Junior
Professione: ingegnere
Software: pro/E
Regione: veneto
#5
Ciao a tutti come promesso provo ad allegare un modello base per chiarire il problema:
Ho fatto 2 prove.

Parto dal presupposto che la fresa deve sempre essere ortogonale al piano TOP in questione.

1)Sweep a sezione variabile: lavoro con 2 binari, la sezione è una mezza circonferenza; in "section plane control" ho settato normal to proiection-->TOP.
Primo problema: sula superficie nasce uno spigolo.
Secondo problema: la superficie non risulta avere un raggio costante: sia facendo analisi curvatura con pro/E che con analisi raggio superficie di Mastercam si evidenzia che il raggio non è costante.

2)Blend di sweep: un solo binario 2 due sezioni.
sempre "section plane control" ho settato normal to proiection-->TOP.
In questo caso non nascono spigoli e la superficie appare perfetta, ma quando vado a far un'analisi raggio di curvatura varia da 14 a 11.89!!! Ergo la superficie non va bene!

Spero di aver chiarito un po' il problema.

Grazie dell'aiuto in anticipo

PS: ho diviso le 2 lavorazioni in gruppi e uno è soppresso
 

Allegati

LuPo_81

Utente Junior
Professione: Progettazione
Software: Creo
Regione: Italia
#6
Inutile dire che del modello non ho capito granchè di ciò che vorresti fare: vorresti generare una superficie come quella blu facendo in modo che abbia raggio sferico costante in modo tale che quando lo butti dentro Mastercam ti genera la lavorazione con un'unica passata? Ho capito bene?

Una domanda, la butto giù così: ma se vuoi una superficie costante perchè non fai un normalisimo sweep usando come unica sezione una circonferenza R16?

Comunque ho notato che nel file prova.prt c'è un blend di sweep in cui i due sketch hanno raggi diversi, quindi probabilmente la definizione delle traiettorie "centro fresa" e "tangenza fresa" non sono esatte. Infatti nello sweep a sezione variabile, scegliendo "sezione costante" la superficie creata non tange alla traiettoria di tangenza.

Poi nella ripresa del gruppo soppresso c'è la feature di merge che fallisce. L'hai lasciata tu così?
 

Allegati