problema con animazione

Francesco_I

Utente Junior
Professione: ingegnere in cerca di occupazione
Software: solid works, mechanical desktop, autocad
Regione: lazio
#1
Vorrei far rotolare la ruota sul binario (disegno allegato), come posso fare?
I vincoli che ho dato sono la coincidenza della superficie inferiore della ruota con il piano orizzontale del binario e la tangenza della superficie laterale della ruota con la parte verticale del binario (qui primo problema perchè mi seleziona solo la parte lineare del binario e non la parte curva, quindi provando a muovere la ruota in prossimità del tratto curvo attraverserà il binario).
Ho messo un motore per la rotazione, ma non riesco a capire come dargli la traslazione lungo la traiettoria.
Sono agli inizi e spero che mi aiutate a sbloccarmi
 

Allegati

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#2
Per la continuita' sulla curva, devi usare il vincolo camma invece di quello tangenza, per l'animazione con rotolamento devi aspettare che arrivi Be_on_edge!
 

Francesco_I

Utente Junior
Professione: ingegnere in cerca di occupazione
Software: solid works, mechanical desktop, autocad
Regione: lazio
#3
Per la continuita' sulla curva, devi usare il vincolo camma
Ci avevo provato, ma mi sembra di aver capito, come giustamente dovrebbe essere, che il percorso deve essere chiuso. Non so se c'è un modo per superare questo ostacolo
 

Leso

Utente Standard
Professione: Ufficiale tecnico
Software: Solid Edge ST9
Regione: Veneto
#4
Credo che si possa usare il vincolo ingranaggio scegliendo l'opzione rotazione-lineare.
Ma non sono sicuro sicuro...
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#5
Ci avevo provato, ma mi sembra di aver capito, come giustamente dovrebbe essere, che il percorso deve essere chiuso. Non so se c'è un modo per superare questo ostacolo
Non mi risulta. Io l'ho usato anche su profili aperti senza problemi.
 

Allegati

Francesco_I

Utente Junior
Professione: ingegnere in cerca di occupazione
Software: solid works, mechanical desktop, autocad
Regione: lazio
#6
Non mi risulta. Io l'ho usato anche su profili aperti senza problemi.
Allora ho sbagliato qualcosa nell'assegnazione del vincolo. Ci riprovo.
Grazie
 

Francesco_I

Utente Junior
Professione: ingegnere in cerca di occupazione
Software: solid works, mechanical desktop, autocad
Regione: lazio
#7
Finalmente sono riuscito ad usare la relazione camma grazie ad un esempio (se a qualcuno può interessare la discussione era questa: http://www.cad3d.it/forum1/showthread.php?p=62502).
Per usarla è stato necessario creare una superficie che identificasse il percorso (foto) della camma, non ho capito però perchè non gli andava bene la faccia del solido. E' giusta la procedura?
Adesso non rimane che risolvere il puro rotolamento. Aspetto consigli
 

Allegati