Problema con animazione molla

b243970

Utente Junior
Professione: studente
Software: solidworks SDK
Regione: lazio
#1
Salve a tutti,e' la prima volta che scrivo...sono relativamente neofita di solidworks qindi abbiate pazienza:)...ho un problema con l'animazione di una specie di variatore,che dovrebbe spostarsi dalla posizione Aperta a quella Chiusa delle quali allego le immagini. La lunghezza della molla e' legata tramite un equazione alla distanza delle facce delle due ruote che si allontanano, ed effettivamente funziona,nel senso che all inizio e alla fine dell'animazione se premo il semaforino per ricostruire l assieme,la molla si riadatta esattamente come vedete dalle due immagini,il problema e' che non lo fa durante l animazione..in parole povere e' come se solidworks non ricostruisse l'assieme ad ogni frame cosicche' la ruota si sposta ma la molla non viene ricostruita in base alla distanza alla quale e' legata e che sta variando frame dopo frame. Allora...c'e' un modo per dire a solidworks di ricostruire frame per frame??
Grazie a chi vorra sprecarci un po di tempo
Mi riservo a mia volta di aiutare qualcuno quando sarò un po piu competente:):)
Emilio
 

Allegati

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx2016-R2W2016-Power Surfacing 2.1-Creo 2.0- PDSU 2016 - Composer 2016
Regione: Veneto
#2
Secondo me potresti provare a creare la molla in modo diverso. Invece di fare l'elica e la sweep lungo l'elica fai una sweep lungo un linea con torsione del percorso.

Te ne allego una di esempio. In questa accoppi il piano 2 su un piano di appoggio, relazioni l'altro capo della linea dello schizzo lunghezza molla (vedi sweep1) all'altra superficie di appoggio e poi prova a lanciare la simulazione.
 

Allegati

b243970

Utente Junior
Professione: studente
Software: solidworks SDK
Regione: lazio
#3
ciao ...grazie della risposta:)..la molla effettivamente l avevo fatta con uno sweep attorno ad una linea, e la lunghezza di questa linea e' legata con un equazione alla distanza dalle due facce, ho provato anche a accoppiare la fine della molla con la seconda ruota (quella che si muove) ma la simulazione se ne "frega" altrettanto:)...Il fatto e' che la mia molla fa il suo lavoro..se vado avanti con la clip e ad ogni frame mi fermo e ricostruisco l assieme ottengo tutte le posizioni corrette...l unico problema e' che l assieme non viene ricostruito durante lo scorrimento della simulazione...ovvero frame per frame.PS il file che hai allegato nn me lo apre...io ho la versione studenti 2008 e mi dice che il tuo e' di una versione futura.. cmq grazie ancora.
 

b243970

Utente Junior
Professione: studente
Software: solidworks SDK
Regione: lazio
#4
parlo sempre troppo presto...li ho relazionati come dicevi tu (estremo dello schizzo attaccato alla ruota) e funziona...la molla cambia ad ogni frame...grazie genio:)
Pero' continuo a non capire perche nn funziona con un equazione..boh.
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx2016-R2W2016-Power Surfacing 2.1-Creo 2.0- PDSU 2016 - Composer 2016
Regione: Veneto
#5
Penso che le equazioni abbiano bisogno di una rigenerazione in più: una per sistemare i valori dell'equazione e l'altra per propagare al modello l'effetto di questa modifica. Mentre modelli dovresti premere due volte ctrl+q.

Io non uso molto le equazioni con solidworks, preferisco normalmente lavorare dallo schizzo.
 

Ste_d

Utente Standard
Professione: Ingegnere Meccanico
Software: Solidworks 2014 SP4
Regione: Toscana
#6
Secondo me potresti provare a creare la molla in modo diverso. Invece di fare l'elica e la sweep lungo l'elica fai una sweep lungo un linea con torsione del percorso.

Te ne allego una di esempio. In questa accoppi il piano 2 su un piano di appoggio, relazioni l'altro capo della linea dello schizzo lunghezza molla (vedi sweep1) all'altra superficie di appoggio e poi prova a lanciare la simulazione.
riporto in auge il topic perchè mi serve aiuto... sto cercando di simulare un freno a tamburo che ha una molla di richiamo per far avvicinare i 2 ceppi (poi posto il disegno). Tutto il freno è stato creato usando i blocchi e le relazioni nell'assieme layout perchè era imposta questa tecnica. ora per metterci dentro la molla creata da re_solidworks posso inserirla come un semplice componente? premetto che so come si modella la molla, conosco anche un paio di tecniche... però non capisco come simularla!
Inoltre non capisco come fare il comando che ho sottolineato... vabbè intanto mi creo le superfici di appoggio:finger:
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx2016-R2W2016-Power Surfacing 2.1-Creo 2.0- PDSU 2016 - Composer 2016
Regione: Veneto
#7
riporto in auge il topic perchè mi serve aiuto... sto cercando di simulare un freno a tamburo che ha una molla di richiamo per far avvicinare i 2 ceppi (poi posto il disegno). Tutto il freno è stato creato usando i blocchi e le relazioni nell'assieme layout perchè era imposta questa tecnica. ora per metterci dentro la molla creata da re_solidworks posso inserirla come un semplice componente? premetto che so come si modella la molla, conosco anche un paio di tecniche... però non capisco come simularla!
Inoltre non capisco come fare il comando che ho sottolineato... vabbè intanto mi creo le superfici di appoggio:finger:
Devi inserire la molla nell'assieme che contiene lo schizzo di layout con i blocchi (se non ho capito male lo hai fatto in questo modo) e successivamente vai ad accoppiare la molla nel tuo assieme. Una volta che la molla è accoppiata nell'assieme vai a rendere coincidente il punto di estremità della linea della molla con un'entità degli schizzi di layout che hai nel tuo layout. Esci dallo schizzo e la molla si adatterà alle condizioni del tuo layout.
 

Ste_d

Utente Standard
Professione: Ingegnere Meccanico
Software: Solidworks 2014 SP4
Regione: Toscana
#8
grazi mille, così leggendo non c'ho capito molto ma stasera provo a fare tutto con il pezzo davanti eheh! non dovrebbe essere difficile, più che altro mi pare di capire che in questo modo funziona sicuramente!
Quindi prima inserisco la molla in ambiente layout, la accoppio con le superifi d'appoggio e poi rendo coincidenti gli estemi della molla con gli appoggi in ambiente layout... vi faccio sapere, intanto ringrazio nuovamente per la disponibilità e precisione!
 

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#9
Come puro ambasciatore posto questo ....

[youtube]7PiuSpa-7QU[/youtube]

sperando possa aiutare qlc...
 

Ste_d

Utente Standard
Professione: Ingegnere Meccanico
Software: Solidworks 2014 SP4
Regione: Toscana
#10
Devi inserire la molla nell'assieme che contiene lo schizzo di layout con i blocchi (se non ho capito male lo hai fatto in questo modo) e successivamente vai ad accoppiare la molla nel tuo assieme. Una volta che la molla è accoppiata nell'assieme vai a rendere coincidente il punto di estremità della linea della molla con un'entità degli schizzi di layout che hai nel tuo layout. Esci dallo schizzo e la molla si adatterà alle condizioni del tuo layout.
non ci riesco... sono 2 giorni che ci smatto dietro ma niente da fare, ci sono troppi problemi e non fa quello che vorrei che facesse. Domani ne parlo col professore poi vi faccio sapere, è diventato un incubo questo maledetto freno... cioè questa maledetta molla!!! il brutto è che va anche simulato il movimento...
 

b243970

Utente Junior
Professione: studente
Software: solidworks SDK
Regione: lazio
#11
ciao, la molla che fai si torce lungo una linea di cui tu decidi la lunghezza, quando la metti nell'assieme modifichi lo schizzo della molla e metti una rralzione di congiunzione tra un estremo della linea della molla ed un punto dello schizzo del pezzo cui la molla deve restare attaccata, è chiaro cosi'? per me al tempo ha funzionato:)
http://www.youtube.com/watch?v=feC_XNPyJNA&feature=related
 

Ste_d

Utente Standard
Professione: Ingegnere Meccanico
Software: Solidworks 2014 SP4
Regione: Toscana
#12
ciao, la molla che fai si torce lungo una linea di cui tu decidi la lunghezza, quando la metti nell'assieme modifichi lo schizzo della molla e metti una rralzione di congiunzione tra un estremo della linea della molla ed un punto dello schizzo del pezzo cui la molla deve restare attaccata, è chiaro cosi'? per me al tempo ha funzionato:)
http://www.youtube.com/watch?v=feC_XNPyJNA&feature=related
è chiaro è chiaro!!! infatti FUNZIONA!!! saltavo un passaggio fondamentale :biggrin:
grazie ragazzi siete davvero troppo forti!:finger:
 

Split

Utente Junior
Professione: disegnatore
Software: Solidworks, Autocad
Regione: emilia romagna
#13
Chiedo scusa se tiro in ballo un questo argomento dopo un pò di tempo....
fin qui tutto chiaro, questo funziona se la molla è dedicata al singolo progetto forse, cioè se dopo aver spostato la parte vado a vedere la molla questa risulta accorciata e nel caso volessi riutilizzare la stessa molla in un altro assieme viene visualizzato il punto interrogativo che indica che sono presenti riferimenti esterni.
Quindi sono in difficoltà nel fare una libreria delle molle o a dover riutilizzare la stessa molla in assiemi differenti con compressioni diverse.
Come si fa ad avere la stessa molla che in un assieme ha compressione 15mm e in un altro 18mm?
 

Split

Utente Junior
Professione: disegnatore
Software: Solidworks, Autocad
Regione: emilia romagna
#15
Si in questo modo se non sbaglio però devo rinunciare a vedere adattare la molla al variare della compressione, non si adatta più ma diventa rigida pilotata dalla configurazione giusto? E per ogni volta che riutilizzo la molla debbo creare una configurazione se la compressione cambia.
Qualcuno ha esperienza in questi casi?
 

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#16
Non ho mai provato, ma se per ogni configurazione assegni una lunghezza e anche un proprio accoppiamento dedicato dovrebbe comportarsi proprio come una parte standard ...
Io proverò a farlo magari in agosto, da sotto l'ombrellone ... ;P