• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Problema CATIA V5 R19 visualizzazione componenti CATProduct

Gabber

Utente poco attivo
Professione: impiegato
Software: Catia V5; Creo 2.0
Regione: Piemonte
#1
Salve a tutti, sono un nuovo utente del forum.

Ho un assieme costituito da sottoassiemi e/o parti.
Se apro il sottoassieme dall'assieme principale in cui vado a nascondermi un qualsiasi componente dall'albero logico;
tornando nell'assieme principale i componenti sono visualizzati! Ma non dovrebbero essere nascosti in quanto si tratta dello stesso file!!!

E' come se il sottogruppo avesse differenti stati di visualizzazione dei componenti... a seconda della finestra in cui ci lavori

Com'è possibile che succeda questo? Il problema è che mi capita spesso anche in cat-product con molti sottogruppi e parti

Invio in allegato anche due immagini per chiarire meglio il mio problema


Grazie in anticipo,
Gabriele
 

Allegati

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#2
Nel Product, puoi inserire più Parti e più Prodotti, con la possibilità di metterli in posizione mediante i vincoli e modificarne le proprietà grafiche (colore, linea, trasparenza ecc.), senza che queste modifiche intervengano sulle parti o sui prodotti caricati, ma hanno effetto solo nell'ambito del prodotto Padre...

Per comprendere meglio come funziona, puoi provare a importare nuovamente nel prodotto Padre, quel sottoinsieme tubo ingresso completo, vedrai che questo nuovo caricamento manterrà il visualizza/nascondi che ti aspetti... prova poi a caricarlo ancora una volta e a colorare (solo l'ultimo) tutto di verde, vedrai che solo l'ultimo diventerà verde mentre gli altri mantengono le proprietà grafiche dei precedenti caricamenti.

Se la parte o i sottoinsiemi ereditassero direttamente le proprietà grafiche, queste visualizzazioni differenziate non sarebbero possibili.

Se invece esegui una modifica a una parte o a un prodotto, questo impatta immediatamente in quanto non si tratta di proprietà grafica.

Ciao
 

Gabber

Utente poco attivo
Professione: impiegato
Software: Catia V5; Creo 2.0
Regione: Piemonte
#3
Grazie per la pronta risposta,
Forse nel precedente messaggio non mi sono spiegato bene....

Come hai detto, le proprietà grafiche e il nascondi/visualizza le puoi modificare sull'assieme padre
lasciando il sottogruppo allo stato originale
Ma se io vado a modificarmi direttamente il sottogruppo, il prodotto padre dovrebbe "aggiornarsi" prendendo le modifiche effettuate precedentemente sul sottogruppo.

Inoltre questa anomalia non mi capita sempre per tutti i componenti...
per esempio...
Se riprendo lo stesso esempio del messaggio precedente, andando nel sotto gruppo e nascondendo il (tubo ingresso);
ritornando nel prodotto padre quello stesso componente me lo ritrovo nascosto
come giusto che sia.
Perchè questo non mi capita se faccio la stessa operazione con i "cavallotti"??

Se questa secondo voi non è un' anomalia,
ci può essere un' impostazione che mi renda il comando nascondi/visualizza "collegato" dal sottogruppo al prodotto padre e non viceversa?

Grazie,:smile:
 

gianni55

Utente Standard
Professione: Progettista
Software: CATIA V5
Regione: Piemonte
#4
Forse nel precedente messaggio non mi sono spiegato bene....
Come hai detto, le proprietà grafiche e il nascondi/visualizza le puoi modificare sull'assieme padre
lasciando il sottogruppo allo stato originale
Ma se io vado a modificarmi direttamente il sottogruppo, il prodotto padre dovrebbe "aggiornarsi" prendendo le modifiche effettuate precedentemente sul sottogruppo.
No, no, ti sei spiegato bene...
Alla prima creazione del prodotto e all'inserimento del sottogruppo, questo accade sicuramente... se tu fai modifiche nel sottogruppo, queste vengono aggiornate nel padre! (in quanto nel padre non hai modificato nessuna proprietà grafica, quindi le eredita dal figlio)

Inoltre questa anomalia non mi capita sempre per tutti i componenti...
per esempio...
Se riprendo lo stesso esempio del messaggio precedente, andando nel sotto gruppo e nascondendo il (tubo ingresso);
ritornando nel prodotto padre quello stesso componente me lo ritrovo nascosto
come giusto che sia.
Perchè questo non mi capita se faccio la stessa operazione con i "cavallotti"??
Probabilmente perché i cavallotti li avevi nascosti o visualizzati nel padre, quindi a questo punto per questione di gerarchia, la visualizzazione nel prodotto padre ha la priorità e quindi non recepisce la modifica del figlio (così come il figlio non recepisce la modifica del padre)

Se questa secondo voi non è un' anomalia,
ci può essere un' impostazione che mi renda il comando nascondi/visualizza "collegato" dal sottogruppo al prodotto padre e non viceversa?
La possibilità nel prodotto padre di visualizzare in modi diversi i componenti figli, non la considererei un'anomalia, ma una utilità...
Non credo si possa "collegare".
Quindi se vuoi evitare il problema, usa il nascondi/visualizza solo sul prodotto figlio aperto in un altra finestra, oppure copi e incolli il prodotto figlio, buttando via quello precedente.
Altrimenti nel caso tu abbia un prodotto con molti componenti e quindi un albero molto lungo e ti secca andare a recuperare quelli spenti, fai tasto dx sul prodotto e modalità selezione/figli ti seleziona tutti i figli e gli applichi il nascondi/visualizza