Pro/E nativo su Linux 64bit

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#61
Direi di finirla qui.
La domanda iniziale era elementare, qualcuno voleva sapere se Pro/E girava su distro Linux 64 bit, punto.
Invece ci siamo fatti prendere dalla guerra santa Linux>Vs. Windows.
Se qualcuno ha risposte attinenti la domanda bene, altrimenti non alimentiamo flame inutili.
 

Delysid

Utente Standard
Professione: Designer
Software: Rhinoceros, Pro/ENGINEER, CINEMA 4D
Regione: Toscana
#62
Caro Mr. Panda, hai parlato parlato ma non hai detto praticamente nulla.
Devi argomentare ciò che dici, di utenti come te che non sanno o non vogliono usare Linux per prigrizia, e che mi dicono che gli dava "problemi", ne conosco a decine.. :biggrin:
:finger:

comunque come dice maxopus siam finiti a far chiacchiere da bar, sarà meglio chiuderla qui...
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#63
Mr Panda e Trotto, avevo chiesto di tornare in topic.
Vi chiedo di non alimentare ulteriormente la polemica su un argomento non attinente la discussione.
 

Giovy1974

Utente poco attivo
Professione: Progettazione e sviluppo fuel cells
Software: ProEngineering
Regione: Sicilia
#64
Ciao,
ho letto con attenzione quanto avete scritto sull'istallazione del pro/E.
E' più di un anno che cerco di installare, a dir la verità a periodi e nei ritagli di tempo, il pro\e su Fedora: l'anno scorso provavo sul Fedora 12 ed adesso su Fedora 14.
Ho un sistema a 64 bit e, quindi, ho dovuto installare alcune librerie a 32 bit.
Ho fatto le seguenti operazioni:
1) installazione della libreria: tcsh-6.17-12.fc14.i686;
2) installazione della libreria: openmotif 2.3.3-1.fc14.i686;
3) link simbolico per la libreria libXm.so.3 mancante: ln -s /usr/lib/openmotif/libXm.so.4 /usr/lib/libXm.so.3;
4) installazione della libreria: compat-libstdc++-33-3.2.3-68.i686;
5) installazione della libreria: gtk+-1.2.10-70.fc13.i686;
6) installazione della libreria: rpcbind-0.2.0-8.fc14.i686.rpm;
7) installazione della libreria: xinetd-2.3.14-33.fc14.i686.
Solo in seguito all'installazione delle precedenti librerie, sono riuscito a completare l'installazione di Pro/E. Però cercando di lanciare il programma col comando:
LANG="" /usr/local/ptc/proeWildfire3.0/bin/proe o /usr/local/ptc/proeWildfire3.0/bin/proe
il programma non parte e dà il seguente errore (Giovanni74 è il mio nome utente):

WARNING: Giovanni74 appears to have the loopback address 127.0.0.1 as IP address
This may imply that processes on Giovanni74 may not be able to connect to non-local processes
Required GLX TrueColor Visual Not Available.
Recommend that you put "graphics x_windows" in your config.pro.
Serious internal error; cannot continue.

E' lo stesso tipo di errore che avevo con Fedora 12.
Come posso risolverlo?
Vi ringrazio anticipatamente, Giovanni.
 

Giovy1974

Utente poco attivo
Professione: Progettazione e sviluppo fuel cells
Software: ProEngineering
Regione: Sicilia
#65
Ciao,
sono sempre Giovanni.
Sono riuscito a far funzionare Pro/E su Fedora.
Per risolvere dell’errore che vi avevo descritto ho dato da terminale il seguente comando:

echo graphics x_windows > ~/config.pro;

e poi ho lanciato il programma con:

LANG=”” /usr/local/ptc/proeWildfire3.0/bin/proe

per non avere problemi con l’UTF-8.
Comunque, grazie ugualmente.
Grazie.
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#66
Ciao,
sono sempre Giovanni.
Sono riuscito a far funzionare Pro/E su Fedora.
Per risolvere dell’errore che vi avevo descritto ho dato da terminale il seguente comando:

echo graphics x_windows > ~/config.pro;

e poi ho lanciato il programma con:

LANG=”” /usr/local/ptc/proeWildfire3.0/bin/proe

per non avere problemi con l’UTF-8.
Comunque, grazie ugualmente.
Grazie.
Ciao, io uso Pro/e su Debian (32 bit) da qualche anno e onestamente devo dire che mi trovo ottimamente , probabilmente Fedora usando i pacchetti rpm ha una configurazione leggermente diversa, comunque io ho dovuto installare i seguenti pacchetti
csh
libmotif3 (ultimamente aggiornandolo a libmotif4 o dovuto creare il link a ibXm.so.3)
libgtk1.2
openbsd-inetd
portmap (per poterlo usare da utente normale) penso faccia la stessa cosa di rpcbind
libstdc++5
poi riconfigurare locales a "it_euro" (in luogo di UTF-8)
il problema da te avuto era una cosa per me sconoscuta non usando Fedora

p.s.
a proposito come funziona su Fedora ?
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#67
Alla fine l'ho installato sulla mia slackware a 64bit tramite le librerie di compatibilità a 32bit e va decisamente bene, ma per la localizzazione in italiano non sono riuscito a risolvere.
La variabile impostata a it_euro non funziona, come anche it_IT@euro.
Non è un grosso problema, visto che non si hanno vantaggi, anzi, è meglio averlo in inglese, ma mi piacerebbe vedere com'è nella nostra lingua.
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#68
Alla fine l'ho installato sulla mia slackware a 64bit tramite le librerie di compatibilità a 32bit e va decisamente bene, ma per la localizzazione in italiano non sono riuscito a risolvere.
La variabile impostata a it_euro non funziona, come anche it_IT@euro.
Non è un grosso problema, visto che non si hanno vantaggi, anzi, è meglio averlo in inglese, ma mi piacerebbe vedere com'è nella nostra lingua.
Scusa ma non ho capito se la variabile it_euro non riesci ha cambiarla a livello di sistema oppure è solo Pro/e che comunque anche con it_euro non viene localizzato in italiano (hai provato ha fare "ptcsetup" per vedere se hai installato la localizzazione in italiano di Pro/e)
purtroppo slackware l'avevo installata una vita fa ora non mi ricordo più nulla, comunque il file di configurazione di locales in Debian si trova in /etc/locale.gen
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#69
Si la lingua italiana è installata per Pro/E è installata, la variabile d'ambiente per il sistema è impostata, ma lui la ignora.
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#70
Si la lingua italiana è installata per Pro/E è installata, la variabile d'ambiente per il sistema è impostata, ma lui la ignora.
Prova dare un occhiata all'help di Pro/e nella sezione "supporto delle lingue" (può essere che magari hai qualche cosa di sballato nelle opzioni di configurazione)
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#71
La variabile è settata correttamente e con il valore giusto, ma l'errore permane.
Pro/ENGINEER could not initialize the specified locale "it_IT@euro" and has reverted to running in English.
Please check the locale settings before re-launching Pro/ENGINEER.
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#72
Però nel file /etc/locale.gen di Debian è scritto un questo modo
it_IT@euro ISO-8859-15

Probabilmante il problema è a livello di sistema (purtroppo Slackware non la conosco) hai provato ha dare un occhiata al file /etc/profile.d/lang.sh
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#73
Nel mio sistema la variabile di sistema LANG è impostata a it_IT@euro, non riesco a capire cosa diavolo cerchi Pro/E.
Tu lo hai in italiano su Debian?
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#74
Si è in italiano, hai dato un occhiata al file /etc/profile.d/lang.sh per vedere se la stringa è it_IT@euro oppure it_IT@euro ISO-8859-15
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#75
è it_IT@euro, ma non posso aggiungere altro o me lo prende come doppio valore e mi ritorna errore. Può essere un problema della mia versione di ProE perchè non ha nemmeno Pro Mechanica.
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#76
No pro/e non c'entra è solo una questione di sistema, per quanto riguarda Pro Mechanica probabilmente ti manccano dei pacchetti di slack, anche a mè all'inizio non mi funzionava ma poi con un installazione fatta con i pacchetti di default, non selezionati al minimo (ovviamente aggiungendo quelli citati per far funzionare l'installazione di Pro/e) ha funzionato anche Pro Mechanica (ho cercato poi di scoprire quali erano ma non ci sono riuscito)
comunque prova dare un occhio a questa discussione (anche se è parecchio caotica per i post che erano stati recuperati per un problema di server ko)
http://www.cad3d.it/forum1/showthread.php?t=190

Edit: scusa ho fatto un po' di confusione intendevo Mechanism non Pro Mechanica.
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#77
Quella discussione l'avevo già letta, ti ringrazio lo stesso, più che provare altre variabili fornite con la documentazione non saprei che fare.
Tra l'altro si dice solo che non supporta utf, ma non specifica se ci sono determinare codifiche da usare per far andare le localizzazioni.
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#78
Perchè non provate a contattare l'HELP di PTC ?
Questo è un problema abbastanza specifico e sono pochi gli utenti che usano Pro/E su Linux.
Di solito quando non trovo la dritta ad un problema mi rivolgo a loro e nella maggior parte dei casi i problemi te li risolvono e rapidamente.