• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Pro/E nativo su Linux 64bit

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#41
Linux non è "un" sistema operativo.
Ci saranno almeno 100 distribuzioni scaricabili da internet, e non puoi pretendere che un software giri bene su tutte le distribuzioni esistenti.
Se utilizzi una distribuzione Linux certificata PTC, tutti 'sti problemi non li hai.
La gente scarica da internet tutte le cose possibili e pretende che tutto giri su tutto ma, sappiamo tutti che non è così.
Stiamo andando OT ma noto alcune inesattezze, quindi perdonatemi se provo a correggerle. :smile:
Linux, ovvero il kernel, è il Sistema Operativo.
Quello che ci sta attorno - X11, alsa, init e compagnia bella - è un altro conto, tutto l'insieme forma una distribuzione, ma il kernel, cioè l'os è solo Linux.
Capisco benissimo che chi deve lavorare non può andare a vedere Linux o Microsoft, ma io nel limite del possibile cerco e cercherò sempre di non avere Microzozz di mezzo.
Windows anche se usato a dovere fa sempre pena, crea chiavi di registro anche per un file di word, dopo un pò si appensatisce e diventa inevitabile piallare, con una distro Linux ci sto secoli senza toccare nulla. :biggrin:
E se con il pc ci lavori mi pare sia un grosso vantaggio questo. :wink:
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#42
dopo un pò si appensatisce e diventa inevitabile piallare, con una distro Linux ci sto secoli senza toccare nulla
Mah! Queste sono le classiche leggende metropolitane.... Io ho reinstallato windows dopo tre anni ma solo per un lievissimo rallentamento, e il pc l'ho usato pesanemente aggiungendo e togliendo software moltissime volte.

Chiaro se poi vai su internet con account amministratore dopo non lamentarti, ma ti accadrebbe lo stesso lavorando come root su linux.

Piuttosto, conosci un metodo per usare driver propietari con la mia scheda ATI X700M? No perche' su linux non e' piu' supportata, mentre su windows va ancora benissimo...
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#43
Mah! Queste sono le classiche leggende metropolitane.... Io ho reinstallato windows dopo tre anni ma solo per un lievissimo rallentamento, e il pc l'ho usato pesanemente aggiungendo e togliendo software moltissime volte.

Chiaro se poi vai su internet con account amministratore dopo non lamentarti, ma ti accadrebbe lo stesso lavorando come root su linux.

Piuttosto, conosci un metodo per usare driver propietari con la mia scheda ATI X700M? No perche' su linux non e' piu' supportata, mentre su windows va ancora benissimo...
I driver open non ti piacciono? :biggrin:
http://www.x.org/wiki/RadeonProgram
La gpu della tua scheda dovrebbe essere un R400.
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#44
Io non sono un esperto di Linux, quindi faccio una domanda da ignorante in materia:
Se il sistema operativo è sempre lo stesso, come mai alcune distribuzioni sono certificate da PTC (o da altre sofware house) e altre no ?
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#45
Io non sono un esperto di Linux, quindi faccio una domanda da ignorante in materia:
Se il sistema operativo è sempre lo stesso, come mai alcune distribuzioni sono certificate da PTC (o da altre sofware house) e altre no ?
Perchè attorno al kernel ci cuciono a misura le librerie e i driver necessari a far girare in modo ottimale Pro/E.
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#46
I driver open non ti piacciono? :biggrin:
http://www.x.org/wiki/RadeonProgram
La gpu della tua scheda dovrebbe essere un R400.
I driver open sono di prestazioni assai inferiori a quelli propietari, per cui non c''e' verso di usare applicazioni complesse come Salome.

P.S. Prova a far girare Pro/E coi driver open poi dimmi come va, secondo me avrai brutte sorprese.
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#47
Io non sono un esperto di Linux, quindi faccio una domanda da ignorante in materia:
Se il sistema operativo è sempre lo stesso, come mai alcune distribuzioni sono certificate da PTC (o da altre sofware house) e altre no ?
Esistono piccole differenze fra una distribuzione linux e un'altra, per cui la PTC ha bisogno di restringere il campo possibile di combinazioni, in modo da poter dare risposte certe e rapide agli utenti che chiamano l'assistenza per risolvere dei problemi.

Con windows il problema si pone in maniera inferiore perche' l'ambiente windows e' abbastanza univoco. Facendo un'analogia, e' lo stesso motivo per cui i cad sonoc ertificati solo per alcune schede grafiche, le aziende non possono mettersi a testarle tutte.
 

Delysid

Utente Standard
Professione: Designer
Software: Rhinoceros, Pro/ENGINEER, CINEMA 4D
Regione: Toscana
#48
Questa è una mezza bufala.
Se la macchina è fatta "a mestiere" Pro/E non crasha in questo modo su winzozz (che io detesto).
Stesso computer, te lo garantisco! E tra la complessità delle superfici con cui lavoravo e la mia inesperienza nell'usarlo non era così raro che ciò avvenisse su windows.

Che il porting di Pro/E su Linux fa schifo è un dato di fatto, perchè persone che lo usano da anni mi dicono sempre questo dopo averlo provato su Linux.
Sei sicuro sicuro che l'abbiano effettivamente provato? Ribadisco che su Debian 4.0 era una spada. E con la 5.0 dove io ho incontrato problemi, come vedi, gio14 li ha risolti.

Tutto si puo' dire tranne che windows sia un sistema operativo scadente. Usato con le dovute competenze (come tutti gli strumenti di lavoro) fornisce eccellenti prestazioni.
Punti di vista, dal mio invece windows fa pietà di fronte a qualsiasi sistema unix. Con un po' di riserbo nei controntii di Suse Linux o Mac OsX.

Leggo che qualcuno sta denigrando linux... vediamo di non fare come la volpe e l'uva. :rolleyes:

Il kernel che uso è il 2.6.32.3 e i driver Nvidia 190.53, wf3 m80, ma comunque non credo che il problema sia questo perché ho cambiato parecchi Kernel e driver di Nvidia e non mi hanno dato mai problemi, l'unica volta che ho avuto problemi erano causati dalle libx11 (individuato poi dai messaggi di errore da terminale) in pratica se ridefinivi una features o la creavi per aprirsi le schede delle varie opzioni del nenù sulla barra ci metteva una vita, e in attesa che correggessero l'errore ho fatto il dowgrade, sono andato sul sito di Debian e mi sono scaricato i pacchetti della versione precedente libx11-6_1.0.3-7_i386.deb e libx11-data_1.0.3-7_all.deb (attualmente ho installato le libx11-6_1.3.3-1) al limite se vuoi fare il dovgrade (loggato come root) dai
dpkg -i nome_vecchio_pacchetto (anche se devi aggiornare la procedura è uguale l'importante che non ti dia problemi di dipendenze) per quanto riguarda le gtk-1.2 penso le utilizzi solo per il browser, più che altro mi sembra che usi le libmoti3
comunque se ti serve qualche cosa non c'è problema
Grazie, se ricapita l'occasione di far spazio ad una Debian ci riprovo... oppure tento di installare la WF3 sull'attuale Ubuntu 9.10 che ho già? Al momento però con i driver nvidia 185 mi freeza spesso il display (sia su 7950 GX2 che Quadro FX 1500) mi stanno dando problemi e tu usi i 190? Io pensavo di mettere le 173 visto che trattasi di hardware vetusto. Relativamente alla m80 ci potrebbero essere comunque differenze dalla m060.
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#49
Punti di vista, dal mio invece windows fa pietà di fronte a qualsiasi sistema unix. Con un po' di riserbo nei controntii di Suse Linux o Mac OsX.

Leggo che qualcuno sta denigrando linux... vediamo di non fare come la volpe e l'uva.
Non stavo dicendo che uno e' meglio dell'altro! Io li uso e conosco approfonditamente entrambi.
Volevo solo evitare che si continui ad insultare un sistema operativo molto buono come windows basandosi su dati incerti o parziali (chiamando microzozz per esempio). A me windows funziona benissimo, mai preso un virus, mai impiastricciato il registro, mai rilevato rallentamenti intollerabili, eppure il windows che uso io e' lo stesso che usano gli altri, per cui intendevo che windows, usato bene, fornisce prestazioni ottime. Usato male invece, crea problemi, ma sono gli stessi problemi che crea un linux usato male.

Del resto a me linux funziona altrettanto bene per le cose che ci faccio (uso server e analisi fem).
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#50
I driver open sono di prestazioni assai inferiori a quelli propietari, per cui non c''e' verso di usare applicazioni complesse come Salome.

P.S. Prova a far girare Pro/E coi driver open poi dimmi come va, secondo me avrai brutte sorprese.
I driver open stanno facendo passi da gigante.

Sei sicuro sicuro che l'abbiano effettivamente provato? Ribadisco che su Debian 4.0 era una spada. E con la 5.0 dove io ho incontrato problemi, come vedi, gio14 li ha risolti.
Intendevo il porting su Windows. :biggrin:
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#51
Non stavo dicendo che uno e' meglio dell'altro! Io li uso e conosco approfonditamente entrambi.
Volevo solo evitare che continui ad insultare un sistema operativo molto buono come windows basandosi su dati incerti o parziali. A me windows funziona benissimo, mai preso un virus, mai impiastricciato il registro, mai rilevato rallentamenti intollerabili, eppure il windows che uso io e' lo stesso che usano gli altri, per cui intendevo che windows, usato bene, fornisce prestazioni ottime. Usato male invece, crea problemi, ma sono gli stessi problemi che crea un liux usato male.

Del resto a me linux funziona altrettanto bene per le cose che ci faccio (uso server e analisi fem).
Voglio essere presuntuoso e insistere, Window$ è pessimo!!
Il registro si sporca facilmente anche se tu non lo vedi e i virus ci sono, anche se tu non li vedi.
Linux usato male funziona sempre!! :biggrin:
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#54
Linux usato male funziona sempre!! :biggrin:
E uno come me, che non vuole "usare" il sistema operativo (orrore solo all'idea..), e non prova nessun piacere fisico nell'installare driver opensource tenstandone l'efficienza (giramento di balle solo all'idea), ma vuole usare Solidworks per fare il suo lavoro (che non è "usare solidworks"), come farebbe con Linux? :rolleyes:

ciao
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#55
E uno come me, che non vuole "usare" il sistema operativo (orrore solo all'idea..), e non prova nessun piacere fisico nell'installare driver opensource tenstandone l'efficienza (giramento di balle solo all'idea), ma vuole usare Solidworks per fare il suo lavoro (che non è "usare solidworks"), come farebbe con Linux? :rolleyes:

ciao
Solidworks gira anche nativamente su Linux?
Se fate un certo tipo di lavoro perchè non comprate Nvidia? :confused:
 

gio14

Utente Standard
Professione: stampi
Software: Pro-e
Regione: BG
#56
Grazie, se ricapita l'occasione di far spazio ad una Debian ci riprovo... oppure tento di installare la WF3 sull'attuale Ubuntu 9.10 che ho già? Al momento però con i driver nvidia 185 mi freeza spesso il display (sia su 7950 GX2 che Quadro FX 1500) mi stanno dando problemi e tu usi i 190? Io pensavo di mettere le 173 visto che trattasi di hardware vetusto. Relativamente alla m80 ci potrebbero essere comunque differenze dalla m060.
Con Pro/e non ho mai avuto il minimo problema con una qualsiasi versione dei driver Nvidia sia con la Quadro 1500 che con la GF, purtroppo ho il vizio di ricompilare il kernel sempre alla versione più recente e di conseguenza devo pure aggiornare i driver Nvidia (altrimenti non mi funziona più il serverX) per quanto riguarda la m80 non penso che ci siano delle differenze sostanziali con la m60 (a meno che quest'ultima sia affetta da un bug)
 

enri

Utente Senior
Professione: Architetto
Software: Rhino-VectorWorks e altri
Regione: Italia
#57
Volevo solo dire che chi gira anni in Golf facilmente non ha avuto mai problemi.....ma cosa ben diversa è girare in Lamborghini...io non l'ho mai fatto, ma presumo che capirei subito la differenza. :biggrin:
 

Mr.Panda

Guest
#58
A me sulla Suse Pro/E era un autentica disperazione .....

Su XP64 va da dio e sono due anni che non formatto ...il registro si pulisce con ccleaner
e dove non arriva andate di regedit ....

Con linux passavo ore su forum blog per mettere apposto una cosa ... con windows penso solo a lavorare ...

Con l'antivirus su se non vai a cercarteli i virus .. non li prendi ... il PC di lavoro non lo puoi usare con 30000 programmi installati emule che va chat ... messegner ...29999 robe piratate ...

Io ho il sistema op. due cad con licenza , lo star office da 39 euro , l' antivirus originale , ccleaner gratis , cd-burner xp , e acrobat reader... STOP!

Non installo niente che non sia piratato non ho toolbar nei browser ne cazzate tipo skype ecc...
 

Mr.Panda

Guest
#59
Se Pro/E avesse avuto tanto successo su linux la PTC l'avrebbe sviluppato ancora ...invece lo ha abbandonato ....
Io lavoravo per una grande azienda che aveva tutto SU SPARC sia con pro/e che con UG ... con UNIX la WKS erano dei muli ( vabbè erano vecchie ...) ma non è vero che non si piantavano ...si piantavano eccome ...anzi ...
Due anni dopo siamo passati a WIN ...ho lavorato 2 anni su WIN senza che mi si piantasse mai la macchina ... al limite il cad ...sfiga uscivo da Teamcenter ...e facevo ripartire tutto ...

Ma la macchina non ha mai cioccato .... ho visto SUN SPARC tipo le blade 1000 BRUCIARSI!!! .... CIOCCARE la mia Blade 1000 che avevo i primi 3 mesi che ci lavoravo era sempre ferma ... poi mi hanno dato una un a 1500 ..piu' veloce ...si ..ma anche quella ogni tanto ..crash .. e poi avevo l'amministratore di rete li 3ore alla mattina che andava matto di modpro -v -g | grep qualcosa .... in 18 mesi ne ho cambiate 3 Sun Blade 1500 .....

Poi due anni e mezzo con un ultra 20 M2 Dual Optern XP32 e 3GB di RAM cio fatto 3 moto!

Qui c'è troppa gente che con linux ci gioca e non ci lavora come si fa in un azienda da 2000 dipendenti!

Le ore di fermo macchina con windows sono diminuite del 87% !!!!!!!!!!!
 

Trotto@81

Utente Standard
Professione: Nessuna
Software: Creo/Elements Pro 5.0
Regione: Calabria
#60
Caro Mr. Panda, hai parlato parlato ma non hai detto praticamente nulla.
Devi argomentare ciò che dici, di utenti come te che non sanno o non vogliono usare Linux per prigrizia, e che mi dicono che gli dava "problemi", ne conosco a decine.. :biggrin: