non mi fa fare le flangie su questo pezzo in lamiera

nikkke

Utente Standard
Professione: disegnatore
Software: Solidworks 2014 e 2016
Regione: piemonte
#1
salve, che santo devo pregare per poter creare le flangie con la funzione bordo flangia su questo pezzo?
mi capita spesso quando le faccie sono inclinate, ma ora ho questo esempio a portata di mano e posto questo.
l unico modo in cui riesco a metterle, usando solidworks, è aggiungere un solido sottostante a quello principale che mi esprima l ingombro delle flangie, e poi mentre faccio converti solido in lamiera clicco pure sulla faccia creata appositamente x le flangie che non vengono..
in una precedente discussione alcuni utenti mi consigliavano quando possibile di costruire pezzi usando le funzioni lamiera dedicate, tipo i loft.. ma poi se non mi fa aggiungere le flangie il problema è sempre li.
allego disegno e file

grazie saluti
 

Allegati

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#2
salve, che santo devo pregare per poter creare le flangie con la funzione bordo flangia su questo pezzo?
mi capita spesso quando le faccie sono inclinate, ma ora ho questo esempio a portata di mano e posto questo.
l unico modo in cui riesco a metterle, usando solidworks, è aggiungere un solido sottostante a quello principale che mi esprima l ingombro delle flangie, e poi mentre faccio converti solido in lamiera clicco pure sulla faccia creata appositamente x le flangie che non vengono..
in una precedente discussione alcuni utenti mi consigliavano quando possibile di costruire pezzi usando le funzioni lamiera dedicate, tipo i loft.. ma poi se non mi fa aggiungere le flangie il problema è sempre li.
allego disegno e file

grazie saluti

Ero curioso di provare e ho scaricato il file. Poi ho visto che era una varsione futura (ho la 2013). L'ho salvato come parasolid e riaperto. L'ho convertito in lamiera selezionando come facce fisse le due superiori (sono due corpi distinti). Ho creato la flangia a partire dal bordo che hai selezionato nell'immagine senza alcun problema.
Magari dipende dal resto delle funzioni di lamiera che hai nella tua parte e io non ho, oppure la versione 2013 va molto meglio della 2014 che a sua volta va meglio della 2015 oppure devi fare vedere la tua installazione a un esorcista :smile:
 

nikkke

Utente Standard
Professione: disegnatore
Software: Solidworks 2014 e 2016
Regione: piemonte
#3
dunque:
ho provato a fare una cosa simile a quella che hai fatto tu:
ho salvato il file parte allegato in precedenza in un file .step
l ho importato, riconosciuto le funzioni ecc.. convertito in lamiera con la funzione "inserisci piegature".. ora mi fa aggiungere le flange.
ho provato a creare lo stesso pezzo con le funzione "piegatura con loft".. e mi fa aggiungere le flange.. è quindi un bug che quando ci sono spigoli inclinati e si usa "converti solido in lamiera" dopo non si possano applicare flange con la funzione "flangia bordo"??
 

nikkke

Utente Standard
Professione: disegnatore
Software: Solidworks 2014 e 2016
Regione: piemonte
#4
chi usa solidworks principalmente per sviluppare lamiere ha notato miglioramenti o peggioramenti negli anni con le nuove versioni??
i bug li sistemano o se ne fregano? perchè anche questo problema non ha senso..
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#5
l ho importato, riconosciuto le funzioni ecc.. convertito in lamiera con la funzione "inserisci piegature".. ora mi fa aggiungere le flange.
ho provato a creare lo stesso pezzo con le funzione "piegatura con loft".. e mi fa aggiungere le flange.. è quindi un bug che quando ci sono spigoli inclinati e si usa "converti solido in lamiera" dopo non si possano applicare flange con la funzione "flangia bordo"??
Perhè non alleghi il file nella versione che non ti riesce così anche agli altri (esperti in lamiera) possono provare a capire i motivi del fallimento della feature ?
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#6
chi usa solidworks principalmente per sviluppare lamiere ha notato miglioramenti o peggioramenti negli anni con le nuove versioni??
i bug li sistemano o se ne fregano?
I bug se si segnalano di norma li sistemano, poi ci sono sempre le eccezioni. Tu comincia a segnalarlo


perchè anche questo problema non ha senso..
Ti dirò, al netto dei bug, delle volte ho l'impressione che tu voglia forzare SWX a lavorare come vorresti tu e non come lui è predisposto a lavorare, motivo per cui non arrivi alla soluzione desiderata.
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#7
è quindi un bug che quando ci sono spigoli inclinati e si usa "converti solido in lamiera" dopo non si possano applicare flange con la funzione "flangia bordo"??
Hai provato con un pezzo diverso, pur con facce inclinate? Mi verrebbe da dire che sia impossibile che nn funzioni la flangia del bordo quando da un pezzo convertito in lamiera se ci sono facce inclinate.
Il tuo, sarà un caso singolare.
 

nikkke

Utente Standard
Professione: disegnatore
Software: Solidworks 2014 e 2016
Regione: piemonte
#8
Hai provato con un pezzo diverso, pur con facce inclinate? Mi verrebbe da dire che sia impossibile che nn funzioni la flangia del bordo quando da un pezzo convertito in lamiera se ci sono facce inclinate.
Il tuo, sarà un caso singolare.
in questo argomento,http://www.cad3d.it/forum1/threads/42914-lamiera-problema-spigolo-chiuso-e-non-fa-aggiungere-flangie aperto sempre da me, avevo lo stesso problema con flange che non mi faceva creare su facce inclinate..
i casi in cui mi succede sono frequenti, in un modo o nell altro con qualche aggiramento tipo cquello detto in precedenza risolvo sempre..
ma questo mi sembra decisamente un problema di solidworks.
se qualche utente vuol partecipare provando in 15 sec ad aprire il mio file e tentare di aggiungere le flangie confermerebbe. e magari mi spiegherebbe pure il motivo.
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#9
Non ho idea del perchè ma a ben guardare, dopo la conversione in lamiera, quei bordi/facce inferiori (ma anche i superiori, mentre i laterali verticali no) non vengono più riconosciuti come piani/lineari e per questo la funzione flangia del bordo non li accetta:

prova1000.jpg

Uso poco il converti lamiera (non è mai stato il massimo secondo me), preferisco strumenti lamiera diretti, al limite superfici inspessite o piuttosto il vecchio "lacera/aggiungi pieghe". Però non ricordo che nelle precedenti versioni (pre '14) abbia mai dato sto problema.

Comunque...
riesci a metterci una pezza rifilando sopra e sotto con un taglio estruso. Quei bordi tornano piani e vengono riconosciuti dalla funzione Flangia del bordo che funziona:

prova1000_sampom.jpg

View attachment prova1000_sampom.rar
 

nikkke

Utente Standard
Professione: disegnatore
Software: Solidworks 2014 e 2016
Regione: piemonte
#10
gracias :)
ottima trovata, a me non dispiace il "converti lamiera", a parte il fatto che pecca se mando gli spessori all' interno come detto piu volte. Ma non sono un esperto di solidworks.
superfici ispessite non è la stessa cosa che svuotare un solido? dopo lo converti in lamiera con aggiungi pieghe?
il lacera mi da anche lui problemi sugli spigoli di facce inclinate..
in questo caso necessitavo di creare quel dente sul fianco e 1 volta disegnato lo schizzo e usato come linea di divisione con il converti lamiera me lo ritrovavo già fatto sulla flangia laterale.
e poi con l'aggiungi pieghe non so come si fa ad ottenere 2 corpi separati come ho fatto io..