multi body e flatten

ballino

Utente Junior
Professione: ingegnere
Software: swx epdm 2012
Regione: brianza
#1
Ciao a tutti,
un collega mi ha fatto notare un possibile baco e siccome non sono un espertone chiedo.

sw2009 sp2.0
Multibody part
Prima faccio il prismino (quindi body1)
Poi il carter (quindi body2)
attivo weldment
raggruppo per cutlist e vado in tavola

assieme "default" pallinato correttamente. ok

assieme "flatten" con pallinatura tutta a 1.
Qui viene il bello. Non riesco a gestire la numerazione per scegliere di mettere in tavola solo l’oggetto piatto

È un baco o vi è capita anche a voi e sbaglio approccio?


grazie,
ballino
 

Allegati

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#2
Non è un baco. Fino alla versione 2009 di SWX c'è la gestione di 1 solo corpo lamiera. Da swx 2010 multicorpo fatto di multilamiere e solidi.

Comunque se devi mettere in tavola SOLO 1 particolare, da messa in tavola scegli INSERISCI, VISTA RELATIVA, MODELLO ... vai nella parte, selezioni 2 piani, selezioni solo il corpo che vuoi e ritorni in talvola, clicchi e avrai solo quello che vuoi.

Per verificare la pallinatura, occorre vedere dove viene effettuata la scelta della distinta di taglio. Ovviamente avrai un assieme saldato e un assieme di default. Solo uno dei due ha la configurazione sviluppo.

Poi se hai solo 2 corpi, metti la vista dello sviluppo e clicchi sul secondo corpo, tasto destro, nascondi, nascondi componente.
 

ballino

Utente Junior
Professione: ingegnere
Software: swx epdm 2012
Regione: brianza
#3
Ciao meccanicamg,
Ti ringrazio per le indicazioni soprattutto per il 2010;
restando ancora per un pochino alla 2009 ed alla limitazione di un solo corpo spianabile ho fatto qualche prova.

Risultato:
se l’attivazione del comando “weldement enviroment” avviene prima della feature di creazione sviluppo” la pallinatura rimane corretta ( anche isolando la lamiera flatten); [e la cut list è unica e si riferisce sempre alla conf welded]

viceversa la pallinatura porta tutto a 1 e devo ricorrere a quello che hai suggerito tu ( configurazioni etc).

Ultima nota: il feature manager indipendentemente dall’ordine con cui si inseriscono le feature mostra sempre flatten in fondo.

Auguro una buona giornata “nonostante il bavaglio”
ballino
 

Allegati

ballino

Utente Junior
Professione: ingegnere
Software: swx epdm 2012
Regione: brianza
#4
scusate per l'intervento di prima.

su computer diversi ( pari versione e sistema operativo) il comportamento è diverso e aleatorio.

quindi nei multibody con un corpo lamiera ( prima o dopo attivazione weldment) non è possibile mantenere la numerazione della cut list.
vedi immagine avviso che rtiporta tutto a 1.

grazie,
ballino
 

Allegati

  • 221.1 KB Visualizzazioni: 12

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#5
scusate per l'intervento di prima.

su computer diversi ( pari versione e sistema operativo) il comportamento è diverso e aleatorio.

quindi nei multibody con un corpo lamiera ( prima o dopo attivazione weldment) non è possibile mantenere la numerazione della cut list.
vedi immagine avviso che rtiporta tutto a 1.

grazie,
ballino
Esatto. E' aleatorio. Dipende da come ci si muove... Comunqe la numerazione corretta la ottieni dopo aver fatto weldment e aver fatto in automatico l'aggiornamento distinta.

Alle volte comunque impazzisce con la numerazione. Dipende da quando e come si inseriscono le viste nella tavola. :finger:

Flatten in fondo è normale...sempre per ultimo.