• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

movimentazione nastro trasportatore

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#1
ciao a tutti, mi chiamo Stefano e sono al 3 anno di ingegneria meccanica. Devo realizzare un progetto animato per il corso "meccanismi" che prevede la realizzazione di un pick and place.
Sto realizzando il nastro trasportatore, però vorrei chiedere che vincoli mettere.
Tra le due sponde del nastro trasportatore ci sono degli "alberi" sui quali girano i rulli. Tuttavia, che vincoli devo mettere tra albero e rullo affinchè possano ruotare solidalmente? (è prevista l'installazione di un motore). Io ho messo coassialità tra albero e mozzo e in seguito coincidenza per spostare il rullo nella posizione corretta.
Mi escono un po' di errori: disegno sovravincolato ecc...e pure la cinghia da un sacco di errori. Dove sbaglio?
Scusatemi ma sto imparando ad utilizzarlo da solo, a scuola questi programmi non vengono minimamente accennati.
 

Allegati

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#2
Ciao Stefano, benvenuto tra noi. Ricordati di presentarti nell'apposita sezione e leggi il regolamento.

Per prima cosa, i vincoli che devi dare devono essere dati nel modo più sensato possibile, cioè sfruttando dapprima tutti i vincoli reali degli accoppiamenti che faresti in officina. Se un albero è montato all'interno di un rullo, ovviamene ci sarà la coassialità, una distanza di sporgenza (che può essere anche il vincolo di centrato) e per farli ruotare assieme occorre accendere i due piani passanti per il centro di entrambi i componenti e renderli coincidenti.

Se hai una marea di errori devi trovare dove c'è l'errore. Inoltre ti consiglio di lavorare con sottoassiemi il più possibile. Se non riesci a mettere apposto il tutto, posta zippato il materiale per intero (parti e assiemi) che vediamo di darci un'occhiata.

Così senza analizzare direttamente il modello non posso sapere che errori hai fatto. Poi indica che versione hai così vediamo anche se abbiamo disponibile la release compatibile per salvarti l'assieme eventualmente (credo sia SW 2011 x64 il tuo).

Non pensare di fare muovere la cinghia come nella realtà perchè è tempo sprecato. Se l'hai fatta con il sistema cinghia nell'assieme (comando dedicato) se fai girare l'albero motore gira anche il folle come se ci fosse una cinghia vera. Ma non ti avanza il nastro.

PS: io vengo dal mondo macchine per automazioni ed assemblaggio, pick and place pneumatici, elettrici, nastri trasportatori ecc.
 

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#3
non so perchè mi dia un solo messaggio (sarebbero 2 in realtà, 3 con questo) ma mi sono già presentato nell'apposita sezione.
Esatto utilizzo il 2011 x64.
Prima di approfittare del tempo altrui vedo di lavorarci sopra ancora un po' e sbatterci la testa.
La mia domanda a questo punto è una: che comando devo utilizzare per creare un nastro che trasporti poi effettivamente delle "scatole"? ho capito che il comando cinghia/catena serve solo per mettere in movimento più elementi con un solo motore ma non svolge il compito di nastro vero e proprio.
Ti ringrazio per la rapida risposta!
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#4
Allora, il sistema per far muovere il materiale su un nastro di quel tipo, credo (al 95%) non esista. Nel senso che se devi fare una semplice animazione, basta che metti un motore lineare al tuo pezzo da trasportare e questo lo vedrai muovere. Se effettivamente vuoi far muovere qualcosa devi fare un "nastro a tapparella" o una doppia "catena", cioè degli elementi come le maglie della catena che sono vincolati uno all'altro ed essendo montati su pignoni dovrai disegnare una traiettoria sulla quale far viaggiare le maglie. Poi sopra vincoli il tuo pezzo da trasportare. Ma il tutto diventa molto complicato.

Se devi fare un'animazione ti conviene struttare tutti gli strumenti di MOTION per muovere le cose e fare i conti per le velocità e le varie cose da far compiere al tuo sistema.

Per come ho capito avrai un nastro che fa avanzare dei pezzi, li dovrai prendere con un manipolatore e fargli fae qualcosa al ciclo. Bene, se devi realizzare solo l'animazione andrà fatta con particoalre attenzione perchè ci saranno tanti vincoli e configurazioni da far cambiare se vuoi fare il filmato con il suo motore interno cinematico. Altrimenti parametrizzi tutte le posizioni con excel, salvi le immagini e le monti successivamente con qualche programma esterno per fare filmati.
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#5
Ti allego un esempio fatto in 10 minuti molto alla buona, schema SWX e filmato compresso.
Ho disegnato un nastro trasportatore come parte unica con nessun cinematismo funzionante. Un cubo detto "pacco" da trasportare. Con motion attivo ho fatto muovere i pacchi e poi l'ho traslato alla fine. Infatti si vede la trasparenza... invece andrebbe soppressa nel filmato definitivo.
 

Allegati

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#6
non so veramente come ringraziarti, mi hai dato delle dritte importantissime!!!! questa sera mi metto al lavoro, ti ringrazio ancora un sacco!
 

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#7
finalmente ora posso dedicarmi a questo progetto. I file di matlab per la profilazione delle camme etc sono pronti, sto realizzando il 3d.
Ho un problema: come faccio a simulare il movimento intermittente? il mio pacco deve muoversi a "scatti" di 1 secondo coprendo circa 150mm.
ho provato tutte le funzioni del motore ma non ci riesco.
grazie
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#8
finalmente ora posso dedicarmi a questo progetto. I file di matlab per la profilazione delle camme etc sono pronti, sto realizzando il 3d.
Ho un problema: come faccio a simulare il movimento intermittente? il mio pacco deve muoversi a "scatti" di 1 secondo coprendo circa 150mm.
ho provato tutte le funzioni del motore ma non ci riesco.
grazie
Per fare il motore a intermettenza (a segmenti) guarda le opzioni. Io ho lasciato 0.5 secondi di fermo tra un movimento e l'altro. Il valore di spazio deve essere progressivo, mentre per le pause deve avere lo stesso valore del passo precedente.
 

Allegati

Exatem

Moderatore
Staff Forum
Professione: Commodoro
Software: Creo 3.0 - Microstation
Regione: N.D.
#9
non so perchè mi dia un solo messaggio (sarebbero 2 in realtà, 3 con questo) ma mi sono già presentato nell'apposita sezione.
Perchè i post inseriti nell'area Off Topic, non vengono conteggiati.
Comunque ti sei presentato nell'area corretta.
Benvenuto sul Forum.
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#10
Perchè i post inseriti nell'area Off Topic, non vengono conteggiati.
Comunque ti sei presentato nell'area corretta.
Benvenuto sul Forum.
a me semba che questa settimana mi abbia de-sottoscritto in automatico da molte discussioni, non ho capito perchè, quindi mi tocca ricordare quelle che seguo e andare a pescarle.
 

Exatem

Moderatore
Staff Forum
Professione: Commodoro
Software: Creo 3.0 - Microstation
Regione: N.D.
#11
a me semba che questa settimana mi abbia de-sottoscritto in automatico da molte discussioni, non ho capito perchè, quindi mi tocca ricordare quelle che seguo e andare a pescarle.
Tutti i post scritti nell'area OT, non entrano nel conteggio dei propri post scritti.
Se non ho capito male, ogni tanto questi post vengono "azzerati" quindi il numero indicato, all'improvviso si riduce. E siccome tutti scriviamo spesso in area OT, si hanno delle differenze anche "consistenti".
 

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#12
eccomi qui ancora a "rompere le scatole".
il progetto in sè è completato, ora c'è qualche problema con le animazioni. A prescindere dalla realtà o meno di quello che c'è disegnato (non interessa che i motori si muovano o simili), non riesco a capire cosa succede. Le camme devono girare a 35 giri/min, applico un motore rotatorio a velocità costante, tuttavia parte a girare, poi dopo poco si ferma, cambia verso e torna indietro e accellera :confused:
inoltre, come faccio a far scomparire il pacco nel movimento di discesa?
Ringrazio veramente molto l'anima pia che può buttare un occhio ai miei file :smile:
 

Allegati

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#13
eccomi qui ancora a "rompere le scatole".
il progetto in sè è completato, ora c'è qualche problema con le animazioni. A prescindere dalla realtà o meno di quello che c'è disegnato (non interessa che i motori si muovano o simili), non riesco a capire cosa succede. Le camme devono girare a 35 giri/min, applico un motore rotatorio a velocità costante, tuttavia parte a girare, poi dopo poco si ferma, cambia verso e torna indietro e accellera :confused:
inoltre, come faccio a far scomparire il pacco nel movimento di discesa?
Ringrazio veramente molto l'anima pia che può buttare un occhio ai miei file :smile:
Ti allego l'assieme modificato. Ho levato le chiavi inutili che c'erano in mezzo al percorso, fissato la vista in modo che non mi inserisce chiavi se ruoto o zoommo la vista (questo però puoi ripristinarlo) e ho fatto il ricalcolo.

Complimenti per il meccanismo. Ah... .ho messo il motore a 20 giri/min come cifra tonda....ma rimettilo come era prima :smile: Poi ti ho trascinato il motore fino alla fine.

Adesso sembra funzionare tutto correttamente.

Per far sparire il pezzo smanetta un po' che trovi come fare... del tipo inserisci chiave e in quel punto si sospende il pezzo (provalo su un assieme semplice così è più veloce e capisci come funziona)
 

Allegati

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#14
ciao meccanicamg, innanzitutto ti ringrazio ancora moltissimo per l'aiuto che dai agli utenti del forum. Sei veramente un personaggio in gamba :finger:
In ogni caso ieri, dopo aver perso ore a risistemare un po' le cose (qualche vincolo strano non permetteva una corretta rotazione delle camme, tant'è che il meccanismo accellerava da solo :confused:), ora sono alle prese con i pacchi.
Allora, ai due pacchi antecedenti a quello che deve essere sollevato è stato applicato un motore lineare a segmenti con i tempi giusti (grazie a un tuo precedente consiglio), ma veramente le trasparenze sono impossibili :frown:
come vedi nel disegno il pacco ora dovrebbe scomparire, per poi ricomparire 1.714 secondi più avanti e cosi ciclicamente per una decina di secondi (durata del filmato).
Clicco tasto sospendi, e poi? non fa nulla.
Tra l'altro nemmeno a cercare guide su internet si trova qualcosa...grazie
 

Allegati

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#15
ciao meccanicamg, innanzitutto ti ringrazio ancora moltissimo per l'aiuto che dai agli utenti del forum. Sei veramente un personaggio in gamba :finger:
In ogni caso ieri, dopo aver perso ore a risistemare un po' le cose (qualche vincolo strano non permetteva una corretta rotazione delle camme, tant'è che il meccanismo accellerava da solo :confused:), ora sono alle prese con i pacchi.
Allora, ai due pacchi antecedenti a quello che deve essere sollevato è stato applicato un motore lineare a segmenti con i tempi giusti (grazie a un tuo precedente consiglio), ma veramente le trasparenze sono impossibili :frown:
come vedi nel disegno il pacco ora dovrebbe scomparire, per poi ricomparire 1.714 secondi più avanti e cosi ciclicamente per una decina di secondi (durata del filmato).
Clicco tasto sospendi, e poi? non fa nulla.
Tra l'altro nemmeno a cercare guide su internet si trova qualcosa...grazie

Ti ringrazio per la considerazione :) . Oggi e domani non riesco a guardare, forse domani sera sul tardi. Comunque ci guardo e voglio trovare una soluzione. Comunque è come per i motori che si possono sospendere in un certo intervallo semplicemente mettendo le chiavi nel grafico del tempo e cliccando sul motore tasto dx...sospendi. Lo stesso con i pacchi dovrebbe funzionare. Chiaramente devi far partire più pacchi e ripetere la cosa se nel tuo filmato non c'è solo 1 ciclo ma più di uno.
 

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#16
ce l'ho fatta, bastava inserire la chiave al tempo voluto (ma non cliccare sul "tasto sospendi" come facevo io!), cliccare sul componente e fare "nascondi" e come modalità di interpolazione mettere "snap" in modo da farlo scomparire subito.
Ora sto ultimando, magari faccio un piccolo rendering e posterò i risultati...
grazie meccanicamg per tutte le info!
 

prestef

Utente Junior
Professione: Bergamo
Software: solidworks
Regione: lombardia
#17
un piccolo video (compressione spinta, non è il top) ma rende l'idea...grazie a tutti, vi farò sapere come va l'esame :)
 

Allegati

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#18
un piccolo video (compressione spinta, non è il top) ma rende l'idea...grazie a tutti, vi farò sapere come va l'esame :)
Veramente molto tanto bello :biggrin: (so che è italiano scorreggiuto)