Modulo "Real Time Rendering"

barlafus

Utente Standard
Professione: chairwarmer
Software: utilizzato dal CAD
Regione: .
#21
Allora, la sperimentazione non ha vuto grandi esiti, almeno non quelli sperati.
L'illuminazione ambientale riceve un duro colpo dalla finestratura atta a simulare una fila di plafoniere da controsoffitto, smorzando notevolmente la quantità di luce utile ad illuminare l'interno.
Devo prova a sdoppiare la luce sopra le plafoniere (da 1 ad almeno 2) ed eventualmente a cambiarne il tipo (da rettangolare a ... ??? direzionale?)

Ho un problema neglia angoli del soffitto sul lato del palco ... gli angoli raccolgono troppa luce :mad: ti viene in mente nulla per ovviare?
L'unica cosa che mi e' chiara e' che non hai ottenuto grandi risultati; da li in poi, nebbia!
Cerca di capirmi, i miei due neuroni stanno giocando a dadi...
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#22
...e chi vince? Quello di dx o quello di sx? :D
Traduco:
mettere una grande luce rettangolare al di sopra di un 'controsoffitto' forato in maniera da simulare le numerose aree luminose delle plafoniere, pur sembrando una buona idea in realtà non si è dimostrata tale (almeno in base alle sperimentazioni).
Ho tentato di dividerla in due luci sperando di migliorare la cosa ... ma niente da fare.

Per di più ho notato che lasciare un valore 0 per la lunghezza del raggio della luce diffusa è controproducente per due motivi: tempo di calcolo; false zone sovrailluminate negli angoli tra soffitto e pareti.

Nei render delle scorse notti (più di 8 ore ... ma io ero a nanna;)) ho ricollocato la luce (singola) all'interno dell'ambiente e l'ho tenuta fissa ad una campionatura U e V di 40 (!) variando solo l' intensità (notte per notte da 10 a 5 a 2), e tenendo fisso pure il numero dei raggi emessi a 5000 con limitazione a 500mm (sia per la diffusa che per l'ambientale).
Il risultato non era male, ma ripeto, l'equilibrio va cercato anche con i valori dei materiali assegnati.

Ed ora un problema con gli adesivi (stikers), c'è forse qualche opzione che mi potrebbe impedire di 'renderizzarli'??

Ciao e buona lettura ... sembra quasi un blog :D
 

Tatankabl

Utente Junior
Professione: Progettista
Software: Catia V5 r19/Photoshop CS4
Regione: Veneto
#23
A parere mio ragazzi, lavorate con troppi raggi, avete tempi di calcolo impermissibili, se renderizzate oggetti più complessi con questi parametri vi ci vorranno 40 ore.....
Cmq per la luce diffusa io di solito uso un valore tra 500 e 1000 per la lunghezza, e 500 per il numero di raggi ed i risultati non sono male, sopratutto i tempi diventano più permissivi!
Una grande luce rettangolare non ti darà mai l'effetto di tante piccole.....la campionatura puoi tenerla a 20 è già sufficiente
I materiali sono abbastanza intuitivi, ricordati che per quelli trasparenti più la barra è sul nero e più sarà opaco,mentre il quadratino del colore ti dà il colore emesso dal materiale tramite le caustiche, i metalli hanno una riflessività dal 0,50 in su e l'ambiente e il diffuso al di sopra del 0,40, la speculare va tenuta bianca per tutti i materiali plastici e metallici, va colorata se si usano tessuti....
Per le mappature del materiale attraverso l'uso d'immagine la riflessione non può superare il 0,20 altrimenti non si vedrà nulla,altro......sono ancora in sperimentazione.....
Ciao ragazzi continuate così.....
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#24
Ciao tatanka,
dove hai preso questi che mi sembra tu consideri dei capisaldi?
Riguardo alle ore di elaborazione, che ti frega! Mica ci devi stare davanti, lo lasci li una notte e al mattino ... buongiorno!
Per gli stikers sai nulla?
 
Professione: docente, autore e divulgatore
Software: Catia V5 - Creo - Pro/Engineer
Regione: Lombardia
#25
Ciao,
Non ho capito bene se il problema è relativo alla nuova macchina (PC) che hai comprato oppure è legato al fatto di fare uso del real time rendering scoprendolo da autodidatta. Se vale l'ultima allora forse è il caso di andare a guardarsi la guida in linea oppure di prendere un manuale.


Ciao

Giuseppe Del Nobile
 
Professione: ????????
Software: prima catia v5 r17 adesso cerco di usare sw 2008...
Regione: friuli
#26
beh, il fatto di essere un neofita autodidatta, non mi aiuta molto anzi....comunque ho un manuale, è in inglese ma abbastanza chiaro e ho una piccola guida (piu' che altro dei consigli) che mi ha dato un amico progettista.
comunque secondo me i problemi che sto avendo con il modulo photo studio, sono dovuti
alla scheda video o ai suoi driver che probabilmente non supportano catia.
infatti come scritto qualche giorno fa, facendo girare il programma in modalita' provvisoria, renderizza anche se ci vuole pareccio piu' tempo non avendo l'aiuto della gpu.
c'e' qualche impostazione particolare da settare in catia?
sempre il mio amico progettista mi diceva anche, che lui aveva provato a lanciare dei render anche con schede piu' vecchie e meno potenti e non ha mai avuto problemi...
potrebbe essere un bug del programma?
 

Tatankabl

Utente Junior
Professione: Progettista
Software: Catia V5 r19/Photoshop CS4
Regione: Veneto
#27
Io ci lavoro da due mesi con questo modulo di catia,i parametri a cui mi appiglio sono frutto di prove e di esperienze avute con altri programmi di render,una cosa che mi fa arrabbiare è il fattoi di non trovare un benedetto manuale o altro,la guida in linea e una m...... ti dice metà del potenziale del programma,un esempio,non mensiona nemmeno il fatto di poter creare filmati......!!!il fatto è che non riesco a capire se il modulo di render è unbiased o biased,dai settaggi e dai calcoli sembrerebbe unbiased,ma a volte mi dà dei risultati.........da biased!boh!stò impazzendo per ottenere risultati realistici.....a volte rimpiango il bel Maxwell......quello si funziona a patto di tempi di calcolo enormi!
Caro barcollomanonmollo a parere mio il tuo amico progettista,sarà bravo nella modellazione, ma il render......... è un'altra parrocchia!io lavoro con una Nvidia Quadro FX3500 e ti posso assicurare che il real time fà schifo...fà di quegli errori di grafica......è ti dà un'idea molto alla larga dal risultato del render calcolato!un consiglio non usate il preview per avere un'idea di come sarà il risultato,resterete delusi quando farete quello calcolato!
Cmq prova a sbirciare nel sito dell'Nvidia, ci sono i driver certificati per CATIA!Tieni conto però che la release 17 pesa di più delle versioni precedenti!
Io sono ancora in altomare per creare i colori multistrato.....mah chissà che prima o poi una soluzione arrivi....
Io per quello che sò vi posso aiutare......ma......non sono un super esperto!
 
Professione: ????????
Software: prima catia v5 r17 adesso cerco di usare sw 2008...
Regione: friuli
#28
grazie della dritta tankbl, vedro' di procurarmi un'invidia e fare delle prove...
effettivamente potrebbero fare delle guide un po' piu' decenti...
nessuno di voi ha mai usato nvidia gelato come renderizzatore?
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#29
.... che il real time fà schifo...fà di quegli errori di grafica......è ti dà un'idea molto alla larga dal risultato del render calcolato!un consiglio non usate il preview per avere un'idea di come sarà il risultato,resterete delusi quando farete quello calcolato! ....

Quoto, preferisco un render con valori caccolosi e rapidi piuttosto che un quick di cui per altro non si conosce con esattezza quali parametri usi per la resa ... credo nel potenziale del programma e solo attraverso la sperimentazione (ore ed ore ed ore ed ore ... non continuo) sto riuscendo ad ottenere risultati soddisfacenti. La guida on line ha degli errori macroscopici ...
 
Professione: ????????
Software: prima catia v5 r17 adesso cerco di usare sw 2008...
Regione: friuli
#30
...se non altro avete uno straccio di immagine da cui partire per fare delle prove....
sempre meglio di un'immagine tutta nera!!!
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#31
per arricchire la scena ho scaricato questo dettaglio da www.3dvia.com (che potrebbe essere interssante da vedere...) e mi ha dato questo errore ... non ne sa niente nessuno?
 

Allegati

Tatankabl

Utente Junior
Professione: Progettista
Software: Catia V5 r19/Photoshop CS4
Regione: Veneto
#32
Secondo me,questo errore ti esce perchè non hai le librerie degli shader aggiornate,infatti il 3dxml si basa sul real time rendering,sbircia nel sito della Nvidia,dovrebbero esserci i download,oppure sulla dassault.......
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#33
...mm, qualcuno mi aveva chiesto di vedere alcuni scorci ... diciamo che (vanità delle vanità) ho estrapolato una cosettina...

Si, non è perfetta ... ma ...

enjoy it
 

Allegati

Professione: ????????
Software: prima catia v5 r17 adesso cerco di usare sw 2008...
Regione: friuli
#34
ciao a tutti, ieri ho provato una nvidia geforce 8600 gt da 512 mb.
risultato: uguale a prima: una bella immagine nera.
non so piu' cosa fare....
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#35
barco, quanto impiega a generare la tua immagine nera?
al termine della resa, compare in basso alla finestra la dicitura immagine salvata in c:\....\....\....\xxx.tif?
 
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#36
...mm, qualcuno mi aveva chiesto di vedere alcuni scorci ... diciamo che (vanità delle vanità) ho estrapolato una cosettina...

Si, non è perfetta ... ma ...

enjoy it
complimenti toniaccio, belle le ombre che fa la sedia, molto reali.
ciao e continua così:)
 
Professione: ????????
Software: prima catia v5 r17 adesso cerco di usare sw 2008...
Regione: friuli
#37
per generare l'immagine impieghera' un paio di minuti forse qualcosa in piu', e durante il
"rendering" la cpu non schizza al 100% ma resta ferma al 5/7%, non so se è normale.
alla fine si mi appare la dicitura
immagine salvata con nome:C\DOCUME\ADMIN 1\IMPOST 1\Ttemp\Ripresa.tiff
ho provato a cambiare il salvataggio in jpeg ma il risultato non cambia.

altra cosa, qualcuno di voi sa per caso se esiste un modulo di catia per il nesting?
 
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#38

Allegati

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#39
per stef ... toRniaccio please ...

per barcollo il valore di cpu è indicativo ma non più di tanto. Dipende dalla fase di resa.
Ora ti domando, hai mai provato ad aprire il tiff nella cartella in cui lo alloca?
Ti spiego, alle volte dopo ore di resa ... (lo so per certo)... il pc "sbarella" e la resa non viene mostrata a schermo MA viene salvata nella cartella di cui sopra in formato tiff.

Potresti fare una prova e farci sapere?
P.s. alle volte salvando dalla maschera di resa in jpg mi è capitato pure che non aggiungesse l'estensione *.jpg dandomi così in cartella un file "sconosciuto", in realtà basta rinominarlo in xxxx.jpg e poi è possibile aprirlo.

Fammi sapere e preparati ad offrirmi un aperitivo.;)
 
Professione: ????????
Software: prima catia v5 r17 adesso cerco di usare sw 2008...
Regione: friuli
#40
per fortuna dopo vari tentativi e dopo aver quasi scaraventato il pc fuori dalla finestra
sono riuscito a far partire il rendering. è stato un colpo di culo, visto che ho cambiato
alcune impostazioni della scheda video e nei settings di catia, nella finestra prestazioni,
in fondo ci sono dei parametri sulle opengl da fleggare. non so se facendo a caso ho ho settato giusto. qualcuno mi puo' postare i suoi parametri cosi' faccio un confronto?

per stef grazie dell'info, provero' a vedere con calma, speravo ci fosse un modulo gia' in catia. grazie comunque.