Modifica profili strutturali

Parceval

Utente Junior
Professione: Progettista meccanico
Software: Solidworks
Regione: Padova
#1
Ciao a tutti!
Mi capita spesso, disegnando un telaio, di dover modificare la dimensione di un profilo strutturale (ad es. passare da un tubolare 80x80 a un 100x100). Dopo tale modifica vanno in crisi tutti gli "Accordia/estendi", gli schizzi facenti riferimento a facce/spigoli del tubolare, nonchè tutte le relazioni presenti nell'insieme (e dato che si tratta di un telaio i vincoli non sono pochi.....).
E' normale? Dato che i profili li ho disegnati io non vorrei aver sbagliato qualcosa...
Grazie e ciao a tutti!!

PS
uso SW2008 SP5
 

cubalibre00

Utente Senior
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#2
Ciao a tutti!
Mi capita spesso, disegnando un telaio, di dover modificare la dimensione di un profilo strutturale (ad es. passare da un tubolare 80x80 a un 100x100). Dopo tale modifica vanno in crisi tutti gli "Accordia/estendi", gli schizzi facenti riferimento a facce/spigoli del tubolare, nonchè tutte le relazioni presenti nell'insieme (e dato che si tratta di un telaio i vincoli non sono pochi.....).
E' normale? Dato che i profili li ho disegnati io non vorrei aver sbagliato qualcosa...
Grazie e ciao a tutti!!

PS
uso SW2008 SP5
Oltre ad inserire un piccolo esempio di ciò che ti succede, per meglio capire il tuo metodo di lavoro, ti consiglio di utilizzare i comandi di auto-trim presenti durante la fase creazione dei profilati ed usare i corpi come strumenti di taglio, anziché le facce.
 
Ultima modifica:

Gabriele SWX

Utente Standard
Professione: Progettista
Software: Solidworks 2017, Creo 3.0 M60
Regione: Toscana, Firenze
#3
Capita anche a me.
Praticamente quando si cambiano le proprietà del membro strutturale il programma inspiegabilmente ruota lo schizzo di base.
Ad esempio: se ho un tubolare quadro 30x30 saldato ad altri e sul quale altri profilati hanno delle funzioni di accorciatura, quando lo cambio in 40x40 i lati di riferimento sono ruotati, quindi le funzioni di accorciamento si riferiscono a dei lati sui quali non possono funzionare.
Se non hai distinte di taglio legate alla proprietà dello schizzo di base, es. descrizione, ti conviene modificare lo schizzo, modificando le misure.
Un metodo molto più lungo consiste nel modificare l'orientamenro dello schizzo (si può ruotare) dopo che hai cambiato il membro strutturale fino a quando non hai più errori nelle funzioni successive.
Questo problema esisteva già nella 2008 ed è presente anche nella 2009.
Ciao
 

cubalibre00

Utente Senior
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#4
Ciao a tutti!
Mi capita spesso, disegnando un telaio, di dover modificare la dimensione di un profilo strutturale (ad es. passare da un tubolare 80x80 a un 100x100). Dopo tale modifica vanno in crisi tutti gli "Accordia/estendi", gli schizzi facenti riferimento a facce/spigoli del tubolare, nonchè tutte le relazioni presenti nell'insieme (e dato che si tratta di un telaio i vincoli non sono pochi.....).
E' normale? Dato che i profili li ho disegnati io non vorrei aver sbagliato qualcosa...
Grazie e ciao a tutti!!

PS
uso SW2008 SP5
Ho provato a fare alcune prove, ma con SW2009 SP3.0EV non succede.
Potresti allegare un esempio ?
 

Parceval

Utente Junior
Professione: Progettista meccanico
Software: Solidworks
Regione: Padova
#5
Vi allego un semplice esempio con i due profili usati. Se provate a cambiare il primo elemento strutturale 80x80 in un 100x100 l'accorcia/estendi va in errore (per lo meno a me). Come ha detto Gabriele, anch'io ho notato che "ruotano" le facce di riferimento e quindi gli accoppiamenti in assieme non si trovano più...
 

Allegati

cubalibre00

Utente Senior
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#6
Vi allego un semplice esempio con i due profili usati. Se provate a cambiare il primo elemento strutturale 80x80 in un 100x100 l'accorcia/estendi va in errore (per lo meno a me). Come ha detto Gabriele, anch'io ho notato che "ruotano" le facce di riferimento e quindi gli accoppiamenti in assieme non si trovano più...
Ho dato un'occhiata al tuo file e confermo che subentra l'errore, ma è anche vero che non avrei utilizzato le facce da tagliare, ma i corpi, come suggerito prima di vedere i tuoi file e l'errore non subentrerebbe.
C'è anche da dire che la 2009 ha implementato gli elementi saldati.
Il tuo trim e la seconda funzione, con la 2009, non risulterebbe necessaria.

Per quanto riguarda gli accoppiamenti, saltano anche con la 2009 e sinceramente direi che è normale, visto che generi un nuovo profilo.
La soluzione di Gabriele ti permette di ovviare al problema e la descrizione della tua distinta di taglio si aggiorna in quanto punta alle dimensioni del tuo profilo (se hai fatto così).