• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

modello selezionato non coincide con quello mancante

calacc

Utente Standard
Professione: Product Development Engineering Specialist
Software: CREO Parametric 2.0 M230
Regione: Emilia Romagna
#1
Buongiorno a tutti!

Durante la rigenerazione di un'assieme contenente più sotto-assiemi ho notato con sorpresa la mancata rigenerazione di uno di essi. Ciò non è mai successo, soprattutto dopo che ho configurato a dovere il mio file search.pro...
Cliccando su info-feature mi dice che manca il modello di componente. Provando a recuperare manualmente il componente mancante (che non dovrebbe servire essendoci già il search.pro...) mi da un messaggio d'errore come nel titolo "modello selezionato non coincide con quello mancante". Ciò è molto strano perché sono sicuro di non aver mai rinominato niente e aprendo singolarmente il generico del sotto-assieme fallito me lo apre e me lo rigenera bene con tutte le varianti, quindi sembra proprio che ci sia un conflitto di identità...

A qualcuno è mai capitata una cosa del genere? Mi riuscite a dare qualche suggerimento a riguardo?
Grazie
 

calacc

Utente Standard
Professione: Product Development Engineering Specialist
Software: CREO Parametric 2.0 M230
Regione: Emilia Romagna
#2
Apposto, risolto ora l'inghippo!!! :wink:

Adesso vi spiego cos'era successo...
Nel mio file search.pro c'erano 3 percorsi consequenziali che schematizzano i miei premontaggi: Livello1; Livello2; Livello3; in quest'ordine.
L'assieme che tentavo di aprire era nel Livello4, quindi prima rigenerava i livelli 1, poi 2, poi 3.
Beh, ho scoperto che nel livello 1 c'era un file di assieme con lo stesso nome del corrispondente livello2 che mi dava l'errore iniziale... Lo vado ad aprire ed era un file vuoto, finito probabilmente lì per sbaglio con un copia e incolla o che so io.
Quindi il sistema cosa faceva, tentava di aprire il file di sotto-assieme del livello1 (vuoto), al 2 non andava perché secondo lui lo aveva già trovato. Per questo quando forzavo la ricerca componente al livello 2 mi diceva "modello selezionato non coincide con quello mancante"...
Sono andato ad aprire quel file fasullo, ho fatto elimina tutte le versioni e voilà, come per magia tutto si rigenera!

Fanculo, un intero pomeriggio perso per questa cazzata, ma adesso non ci penso più che è meglio!
 

taz83

Utente poco attivo
Professione: disegnatore/progettista
Software: ProE WF5
Regione: Piemonte
#3
Mi permetto di farti una domanda.
Uso ProE WF5 ma non riesco a trovare il file search.pro mentre il file search_path è dove deve essere, sapresti dirmi dove dovrebbe essere?!?
Ho cambiato PC ed ho già avuto problemi di vario tipo, quindi magari è andato cancellato(?!?).
Grazie
 

nicksoft

Utente Standard
Professione: cad-pdm related
Software: Creo
Regione: Emilia Romagna
#4
Mi permetto di farti una domanda.
Uso ProE WF5 ma non riesco a trovare il file search.pro mentre il file search_path è dove deve essere, sapresti dirmi dove dovrebbe essere?!?
Ho cambiato PC ed ho già avuto problemi di vario tipo, quindi magari è andato cancellato(?!?).
Grazie
Il search.pro può essere in qualsiasi cartella, la sua posizione è definita dalla variabile di config "search_path_file", guarda se hai quel parametro nei tuoi vari config e a che cartella punta;
Hai già fatto una ricerca di search.pro su tutti i dischi?
 

taz83

Utente poco attivo
Professione: disegnatore/progettista
Software: ProE WF5
Regione: Piemonte
#5
Grazie nicksoft.
Ho già fatto una ricerca su tutto il PC e tutto il server, non c'è il search.pro, però la variabile search_path_file non fa riferimento alsearch.pro ma ad un file .txt (search_path.txt)...
Quindi dovrebbe essere giusto, i riferimenti li prende dall'elenco nel .txt?!?!
 

calacc

Utente Standard
Professione: Product Development Engineering Specialist
Software: CREO Parametric 2.0 M230
Regione: Emilia Romagna
#6
Ma così funziona? Perché credo che il file contenente le stringhe di testo debba chiamarsi proprio search.pro...
Al massimo secondo me basta rinominarlo e settare la variabile search_path_file correttamente al search.pro
 

nicksoft

Utente Standard
Professione: cad-pdm related
Software: Creo
Regione: Emilia Romagna
#7
sì, va bene anche se fa riferimento a search_path.txt, il quale deve contenere le cartelle dove ricercare gli oggetti
 

taz83

Utente poco attivo
Professione: disegnatore/progettista
Software: ProE WF5
Regione: Piemonte
#8
Come dice nicksoft, infatti funziona.
Per quanto riguarda i particolari commerciali non ci sono problemi, ho delle cartelle "fisse" sul server con i riferimenti nel search_path, ma il grosso problema che io ho la divisione per clienti prima che per progetti (hanno codici di numerazione differenti) ed alcuni hanno assiemi grandi divisi a loro volta in sottoassiemi (che per comodità vengono separati in sottocartelle) e inserirle tutte sarebbe un suicidio...
 

nicksoft

Utente Standard
Professione: cad-pdm related
Software: Creo
Regione: Emilia Romagna
#9
Come dice nicksoft, infatti funziona.
Per quanto riguarda i particolari commerciali non ci sono problemi, ho delle cartelle "fisse" sul server con i riferimenti nel search_path, ma il grosso problema che io ho la divisione per clienti prima che per progetti (hanno codici di numerazione differenti) ed alcuni hanno assiemi grandi divisi a loro volta in sottoassiemi (che per comodità vengono separati in sottocartelle) e inserirle tutte sarebbe un suicidio...
C'è un comando che ti può aiutare
se hai la cartella, ad esempio,
c:\clienti così divisa :

c:\clienti\clienteA\progetto1\...
c:\clienti\clienteA\progetto2\...
c:\clienti\clienteB\progetto1\...
etc.

puoi fare, da un command prompt,

dir c:\clienti /ad /b /s > c:\search.pro

e ti scrive tutte le cartelle, ricorsivamente, nel search.pro

rischia di diventare un search.pro enorme, con conseguente aumento dei tempi di caricamento, ma può fare al caso tuo
 

taz83

Utente poco attivo
Professione: disegnatore/progettista
Software: ProE WF5
Regione: Piemonte
#10
uhm...
potrebbe fare al caso mio, ma ti chiedo ancora una cosa, essendo un comando ("batch"?!?!) devo avviarlo tutte le volte che aggiungo le cartelle, vero?!?
PS: Scusa se la domanda ti risulta stupida!
 

nicksoft

Utente Standard
Professione: cad-pdm related
Software: Creo
Regione: Emilia Romagna
#11
Sì, se la struttura di cartelle cambia, devi rilanciare il comando che sovrascrive il search.pro precedente.
Puoi farti un .bat di avvio che come prima riga crea il search.pro e come seconda avvia Creo