• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Massa oggetto nel cartiglio

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#1
E' possibile far comparire in automatico la massa di un particolare costruttivo nella messa in tavola?

e inoltre si può scegliere anche l'unità di misura? o prende quella preimpostata nel part?
 

herbie

Utente Standard
Professione: progettazione
Software: proE2000i2
Regione: italia
#2

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#3
Il materiale l'avevo già impostato e ho provato anche a mettere questo parametro report ma non mi tira fuori nulla...anzi si autoelimina....
....ora provo a dare un'occhiata anche a quelle discussioni...
intanto grazie....
...eventualmente ci risentiamo qui :)
 

Ozzy

Guest
#4
mettilo all'interno di una tabella e non come nota libera.
&pro_mp_mass oppure se nella parte hai la relazione
peso=pro_mp_mass scrivi &peso.

Saluti Ozzy
 

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#5
C'è qualcosa che non mi torna allora; ok nella tabella funziona diciamo, però il valore che esce non corrisponde al valore che mi da l'interrogazione della proprietà di massa del modello (dal menu a tendina: "Analisi modello-->proprietà di massa del modello)

E nonostante abbia impostato per tutti il materiale, per alcuni mi esce il valore sballato e per altri mi esce il valore 0....cannato lo stesso.....:confused::confused::confused:
 

Ozzy

Guest
#6
Imposta nel config.pro la seguente chiave:
mass_property_calculate su automatic

e assicurati che il il parametro PRO_MP_SOURCE sia settato su Geometry e non su parameter.
 

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#8
Imposta nel config.pro la seguente chiave:
mass_property_calculate su automatic

e assicurati che il il parametro PRO_MP_SOURCE sia settato su Geometry e non su parameter.


Grande Ozzy...cosi funziona.Grazie.

Cmq son curioso anche io di conoscere la risposta alla domanda di "scmcrd"....perchè a volte vien comodo inserire questi parametri automatici anche come note, quindi al di fuori di tabelle.
 

Ozzy

Guest
#9
Ciao Ozzy

Qual é la differenza tra inserire in una tabella piuttosto che in una nota?

Grazie
La differenza sta proprio nel fatto che se si mettono come nota, proe non riesce a pescarli, o meglio pesca solo determinati parametri di sistema quali:
&model_name
&dwg_name
&format

ecc

Questi sono parametri di sistema std che il formato sente e riesce ad aggiornare, mentre i parametri definiti da utente oppure quelli generati dal modello tipo pro_mp_mass e altri no.
Mentre invece se si mettono all'interno di una tabella questo non accade,ma attenzione questa regola vige solo in ambiente formato, non in ambiente disegno, infatti se in ambiente disegno scrivete una nota con un parametro utente o un parametro generato, ve la riporta tranquillamente.
Probabilmente questo accade perchè quando si crea un disegno e si carica il formato all'interno, lui non riconosce in automatico le cose non di "default" per questo non riesce a rigenerarle.
In ogni caso potete metterlo in tabella e se non volete vedere il riquadro potete nasconderlo, così è come se fosse una nota e lo fregate.:D


Grande Ozzy...cosi funziona.Grazie.

Cmq son curioso anche io di conoscere la risposta alla domanda di "scmcrd"....perchè a volte vien comodo inserire questi parametri automatici anche come note, quindi al di fuori di tabelle.
Grazie.:D
 

scmcrd

Utente Junior
Professione: ing
Software: proE/AnsysWB
Regione: no
#10
Grazie Ozzy per le dritte


Imposta nel config.pro la seguente chiave:
mass_property_calculate su automatic

e assicurati che il il parametro PRO_MP_SOURCE sia settato su Geometry e non su parameter.
Scusa, ma dov'é il parametro PRO_MP_SOURCE e come faccio a settarlo?

Nel config non l'ho trovato e nemmeno nel *.dtl dei drawing

Ciao
 

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#11
Se accedi dal menu a tendina Strumenti-->Parametri-->Proprietà di massa generale vedi i parametri di default di pro-e

Prima però devi assegnare un materiale al modello..
 

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#12
piu esattamente è nel menu tendina "proprietà di massa altenrative...non generali" nella finestra che si apre da Strumenti-->Parametri (in basso a fianco a "proprietà")
 

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#14
Imposta nel config.pro la seguente chiave:
mass_property_calculate su automatic

e assicurati che il il parametro PRO_MP_SOURCE sia settato su Geometry e non su parameter.

In questi giorni dopo aver risolto il mio problema con la massa (non nel senso che sono in sovrappeso...:D)ho provato ad aggiornare anche il config di un'altra macchina in ufficio ma non riesco ad ottenere lo stesso risultato (ho provato addirittura a copiare il mio config.)
Però succede che nei parametri il valore della massa della densità ecc li da come nulli (nonostante sia stato impostato anche il materiale.)
non riesco a trovare l'inghippo....che altre condizioni sono da aggiornare che non siano nel config? Help super Ozzy & c. :D
 

Ozzy

Guest
#15
Ma nell'altra macchina, carica le stesse start part, oppure altre?
Deve sempre esserci la relazione peso= pro_mp_mass ricorda.

Saluti Ozzy
 

scmcrd

Utente Junior
Professione: ing
Software: proE/AnsysWB
Regione: no
#16
Ma nell'altra macchina, carica le stesse start part, oppure altre?
Deve sempre esserci la relazione peso= pro_mp_mass ricorda.

Saluti Ozzy
Gent.mo Ozzy

In altre discussioni é stata indicata (hai indicato?) anche la relazione

peso=mp_mass("")

ho provato e funziona esattamente come

peso= pro_mp_mass

Domanda: qual é la differenza tra i due modi di indicare relazioni?
Che significato hanno le virgolette e parentesi?

Ciao e grazie
 

summer3d

Utente Standard
Professione: progettista
Software: Creo2.0 - Proe wildfire 2
Regione: brescia
#17
Ma nell'altra macchina, carica le stesse start part, oppure altre?
Deve sempre esserci la relazione peso= pro_mp_mass ricorda.

Saluti Ozzy
Stmattina Ozzy attacco incrociato: cmq la relazione l'avevo inserita anche nell'altra macchina.
La cosa strana sai qual'è?! che se apro un modello dalla macchina del mio collega che però ho creato io dalla mia macchina i valori li vede ma se crea un modello nuovo (con il modello di riferimento del templates che gli ho passato io) e comincia a fare estrusione ecc quando entro nei paramentri il peso, la densità ecc sono sempre 0, nulli.
???????????
 

Ozzy

Guest
#18
Gent.mo Ozzy

In altre discussioni é stata indicata (hai indicato?) anche la relazione

peso=mp_mass("")

ho provato e funziona esattamente come

peso= pro_mp_mass

Domanda: qual é la differenza tra i due modi di indicare relazioni?
Che significato hanno le virgolette e parentesi?

Ciao e grazie
pro_mp_mass è un parametro di sistema generato in automatico da proe, prima dell'avvento wildfire non esisteva, si poteva solo accedere tramite mp_mas(""), quindi si necessitava di avere una relazione esempio appunto:
peso=mp_mass("").
Ora questa procedura non è più necessaria,se tu in un disegno richiami &pro_mp_mass proe ti riporta il peso effettivo, anche se nella parte non hai scritto:
peso=pro_mp_mass idem per tutti gli altri parametri di sistema alternativi e successivamente generati in base al materiale caricato.
pro_mp_source comanda come calcolarlo se prenderlo dalla geometria del modello oppure da un parametro.
Un esempio banale potrebbe essere quello di un assieme dove si hanno dei pezzi modellati e non commerciali e con la geometria e la densità si ha il peso effettivo, ma può capitare di avere anche dei componenti commerciali semplificati, dove la geometria non rispecchia l'originale (magari è solo la pelle e dentro e vuoto) quindi in quel caso non possiamo fare un calcolo su geometria ma dobbiamo settarglielo da parametro e dirgli che quel componente pesa X kg.
Le virgolette in mp_mass servivano anche a questo, come ad altre cose.
La nuova scuola indica pro_mp_mass è anche più semplice da utilizzare.
mp_mass dovrebbero toglierlo perchè crea solo confusione in un argomento che è già confusionale di suo.:D

Saluti Ozzy
 

Ozzy

Guest
#19
Stmattina Ozzy attacco incrociato: cmq la relazione l'avevo inserita anche nell'altra macchina.
La cosa strana sai qual'è?! che se apro un modello dalla macchina del mio collega che però ho creato io dalla mia macchina i valori li vede ma se crea un modello nuovo (con il modello di riferimento del templates che gli ho passato io) e comincia a fare estrusione ecc quando entro nei paramentri il peso, la densità ecc sono sempre 0, nulli.
???????????
Azz ma tu e smcrd andate in coppia?:D

Non è una cosa strana quella che succede, è normalissimo.
Perchè se tu gli passi il tuo modello che è gia compreso di parametri li vede perchè sono stati già creati, ma quando tu crei un modello nuovo proe come sai apre una maschera di partenza standard e se il tuo collega non ha le maschere di partenza con i parametri standard , ti attacchi.
Soluzione:
O gli passi anche le tue maschere di partenza così quando crea un modello nuovo li avrà sempre anche lui.
O gli configuri le sue maschere di partenza nel suo pc.
terza soluzione la migliore.
Mettete tutte le configurazioni sia config.pro,win.ecc e anche maschera in rete, così caricati tutti le stesse configurazioni e quando dovrete fare una modifica, la fate una volta sola.

Saluti Ozzy
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#20
L'ultima strada indicata da Ozzy è assolutamente la migliore.
Immaginate cosa succede in un ufficio tecnico con 10-15 postazioni se si dovesse gestire il tutto sulle singole workstation.