• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

mantenere relazioni dopo la protrusione

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#1
buon giorno a tutti,

devo realizzare una ruota dentata ma per ora mi sto concentrando sulla realizzazione della ruota in se!
Per definire la geometria, lavorando in sincrono, ho creato una serie di diametri concentrici; questi sono stati ottenuti dal più grande tramite il comando offset. Così facendo avevo vincolato i diametri a delle distanze.. e qui la prima domanda: è possibile creare un vincolo percentuale? Cioè se ho 100 la distanza è 5, ma se è 200 allora diventa 10 e così via?

E ancora, quando passo alle protrusioni ogni corona circolare ha un suo spessore e, oltre a dover ripristinare lo schizzo utilizzato, queste "rompono" i vincoli (le quote da rosse diventano blu)! come posso mantenere anche nel disegno 3D i vincoli di dimensione?

grazie
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#2
buon giorno a tutti,

devo realizzare una ruota dentata ma per ora mi sto concentrando sulla realizzazione della ruota in se!
Per definire la geometria, lavorando in sincrono, ho creato una serie di diametri concentrici; questi sono stati ottenuti dal più grande tramite il comando offset. Così facendo avevo vincolato i diametri a delle distanze.. e qui la prima domanda: è possibile creare un vincolo percentuale? Cioè se ho 100 la distanza è 5, ma se è 200 allora diventa 10 e così via?

E ancora, quando passo alle protrusioni ogni corona circolare ha un suo spessore e, oltre a dover ripristinare lo schizzo utilizzato, queste "rompono" i vincoli (le quote da rosse diventano blu)! come posso mantenere anche nel disegno 3D i vincoli di dimensione?

grazie
Non conosco la modalita' sincrona, ma per fare cio' che chiedi apri la tabella variabili ed applica una relazione fra i due diametri che ti interessano, esempio:

D2 = D1 + 0.05*D1
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#3
buon giorno a tutti,

devo realizzare una ruota dentata ma per ora mi sto concentrando sulla realizzazione della ruota in se!
Per definire la geometria, lavorando in sincrono, ho creato una serie di diametri concentrici; questi sono stati ottenuti dal più grande tramite il comando offset. Così facendo avevo vincolato i diametri a delle distanze.. e qui la prima domanda: è possibile creare un vincolo percentuale? Cioè se ho 100 la distanza è 5, ma se è 200 allora diventa 10 e così via?

E ancora, quando passo alle protrusioni ogni corona circolare ha un suo spessore e, oltre a dover ripristinare lo schizzo utilizzato, queste "rompono" i vincoli (le quote da rosse diventano blu)! come posso mantenere anche nel disegno 3D i vincoli di dimensione?

grazie
Visto che le ruote dentate seguono delle regole bene definite l'ambiente migliore per modellarle è quello "Ordinato".

Se vuoi continuare con il sincrono devi introdurre delle quote per fissare le dimensioni ed inserire nelle formule i calcoli che vuoi realizzare (ma del resto dovresti farlo anche in ambiente ordinato).

Normalmente le quote pilotano la geometria ma non la vincolano e quindi sono blu, se vuoi vincolarle devi premere il pulsante del lucchetto.

Ciao
 

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#4
in ogni caso ... mi sembra di capire ... che la quotatura dello schizzo vada persa... e occorra riquotare tutto ... o mi sbaglio?
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#5

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#7
se è vero quello che dici... perchè nel mio caso sono tutte sparite? non c'è più traccia di loro ... nemmeno nella tabella variabili! il tutto succede non appena inizio a fare le protrusioni! :(
 

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#8
ragazzi.. mi succede una cosa stranissima...

ho creato delle relazioni tra il diametro principale e tutte le altre dimensioni (d_main*0.05 ad es.)
ma nel momento in cui vado a creare una protrusione..... succede un bel casotto!!!!

quando decido la lunghezza della protrusione è tutto ok e visualizzo correttamente quello che "vorrei" ... ma non appena schiaccio invio...

i diametri impazziscono! da 40 passano a 60 o 80! disegnando un disco invece che un cilindro cavo! :confused::confused:

cosa potrei aver sbagliato???
 

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#9
ho provato su un file nuovo...

ho creato due diametri concentrici ...
ho quotato il primo e poi il secondo; quindi in formule ho messo in formule che il secondo diametro deve essere d_main*0.5

non appena creo la protrusione...... ciao ciao alla definizione e alla protrusione... esce tutt'altro! O_ò
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#10
ho provato su un file nuovo...

ho creato due diametri concentrici ...
ho quotato il primo e poi il secondo; quindi in formule ho messo in formule che il secondo diametro deve essere d_main*0.5

non appena creo la protrusione...... ciao ciao alla definizione e alla protrusione... esce tutt'altro! O_ò
hai guardato il modello che ti ho linkato? E' abbastanza utile dal punto di vista didattico.

Ho fatto un modellino con la ST4, si riesce tranquillamente a farlo parametrico anche con la modalita' sincrona.

Immagine.png
 

Allegati

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#11
si li ho visti .. ma non riesco a fare niente in ordinato! il tutorial parla soprattutto di sincrono! non so dove mettere le mani in ordinato!

potresti, per cortesia, descrivermi i pochi passi che hai seguito per realizzare quel cilindro cavo?

grazie
 

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#12
piccolo edit: ho notato, correggimi se sbaglio, che hai quotato i diametri DOPO aver realizzato le protrusioni ...

potresti provare a farlo prima, con 3 diametri concentrici quotati e resi parametrici prima della protrusione?
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#13
piccolo edit: ho notato, correggimi se sbaglio, che hai quotato i diametri DOPO aver realizzato le protrusioni ...

potresti provare a farlo prima, con 3 diametri concentrici quotati e resi parametrici prima della protrusione?
Le relazioni fra i diametri le ho impostate quando ero ancora in ambiente schizzo. Hai provato a fare i tutorial inclusi in SE?

[youtube]nb9YuxwdRY0[/youtube]
 
Ultima modifica:

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#14
ciao, grazie per il video... spero che in questo si capisca qual è il problema di cui parlo!

[video=youtube_share;1RvRRVMwkaQ]http://youtu.be/1RvRRVMwkaQ[/video]

il computer si è rallentato molto durante la registrazione :D
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#15
ciao, grazie per il video... spero che in questo si capisca qual è il problema di cui parlo!
Si, e' un comportamento anomale. Hai provato a "lucchettare" le quote quando sei in ambiente schizzo, prima ancora di andare alla tabella variabili?
 

zioTonino

Utente Junior
Professione: studente
Software: Solid Edge
Regione: Italia
#16
si, è uguale .. o prima o dopo ...

ma lo fa anche a te? mi sembra un bug ... a questo punto l'unica alternativa è creare le protrusioni e poi quotare con le formule ...
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#17
No, a me funziona normalmente, ma su questo PC ho la ST4. Puo' darsi che sia un bug, ma andrebbe verificato per bene prima di poterne essere sicuri.
 

Allegati

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#19
A mio avviso ostinarsi all'ambiente sincrono per una parte completamente parametrica è un suicidio.

L'ambiente sincrono è vincente in fase di studio dove non è ancora ben definito cosa e come si vuole realizzare, nel momento in cui si lavora su una parte completamente definita è vincente il parametrico.

ciao
 

ceschi1959

Utente Standard
Professione: progettista
Software: UG 11 - NX11 TC10
Regione: veneto
#20
Scusate l'intromissione ma pochi giorni fa ho avuto uno scambio di idee con utilizzatori di SE per quel che riguarda la ST. Io utilizzo NX, stessa famiglia Siemens, in cui la ST è una cosa mooolto particolare. Chiedo agli utenti SE: cos'è la ST? Dalla ST1 alla odierna ST è cambiato qualcosa? E se sì perchè? A me sembra che quella che viene definita come ST sia diversa in NX e in SE. Se viene dalla stessa Casa perchè è diversa? Spero di poter spiegare meglio il tutto postando un filmato su YouTube.
Ciao