• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

[MACRO] - Draft Painter

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#1
Ragazzi, vi riporto una macro fatta da tale Russ Bliss pubblicata sul NG americano.

Va utilizzata in ambiente Draft e devo dire che è davvero un bel lavoro. Selezionando il bordo di un pezzo in una vista, questo verrà colorato del colore scelto, nelle opzioni è possibile settare se colorare la sola parte selezionata, tutte le parti uguali e se farlo nella sola vista in cui si seleziona o se in tutte le viste.

Ciao

View attachment DraftPainter.zip
 

gerod

Moderatore
Staff Forum
Professione: Libero professionista
Software: Solid Edge, Ansys DS, e altri ancora
Regione: Veneto
#2
L'ho provato ma non funziona. Tu dici "selezionare il bordo di un pezzo in una vista" intendi selezionare la vista? (forse mi manca un passaggio).
Mi da un "runtime error".
Ciao
 

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#3
Peccato, non mi parte.
win Vista, S.E. v20.9
---------------------------
DraftPainter
---------------------------
Errore di run-time '-2147218608 (80040b50)':

Metodo '~' dell'oggetto '~' non riuscito
---------------------------
OK
---------------------------
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#4
Non saprei, non ci sono i sorgenti.

Qui da me funziona, SE V20 sp.8 Windows XP sp.2

Per Gerod: fai partire la macro, aspetta che carichi i dati delle viste, seleziona un colore e poi clicca su un bordo. Se fai qualcos'altro al di fuori del pannelo o di selezionare dei bordi (ad esempio cliccare la freccia o qualche altro comando in SE) è come se chiudessi il comando, anche se in verità rimane visibile.

Ciao
 

gerod

Moderatore
Staff Forum
Professione: Libero professionista
Software: Solid Edge, Ansys DS, e altri ancora
Regione: Veneto
#5
Provato ma mi da l'errore postato sopra.
Win Xp sp3, SE20 sp9
Ho provato sull'altra macchina: XP 64 sp2 con stessa versione di SE e stesso Sp e va.
Che sia qualche istruzione sul registro che gli rompe? sarà il sp3 di win?
da capire che roba è! Mi ricordo che a suo tempo lo stesso problema nasceva con la macro per fare gli esagoni, poi ho re-installato e filava liscio.
Ciao
Ciao
 

Marco74

Utente Senior
Professione: Sviluppo lamiera per taglio laser, piegatura e assemblaggio
Software: Solid Edge ST9 - Autocad Mechanical 2017- Lantek
Regione: Veneto - Emilia
#6
Io ho SE 20 sp9 win xp sp.3 e la macro funziona, però sinceramente non ne capisco l'utilità....
Ciao.
 

Marco74

Utente Senior
Professione: Sviluppo lamiera per taglio laser, piegatura e assemblaggio
Software: Solid Edge ST9 - Autocad Mechanical 2017- Lantek
Regione: Veneto - Emilia
#8
Probabilmente non ti serve allora :rolleyes:

Ciao
Forse in complessivi abbastanza corposi....per trovare le parti, comunque se qualcuno vuole suggerire io prendo anche le critiche come costruttive e non solo come critiche....
Ciao.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#9
Forse in complessivi abbastanza corposi....per trovare le parti, comunque se qualcuno vuole suggerire io prendo anche le critiche come costruttive e non solo come critiche....
Ciao.
Ma dai la mia era una battuta. :tongue:

In alcuni disegni di assemblaggi piuttosto complessi, mi è comodo evidenziare una o più parti con colori diversi. Con questo strumento diventa molto veloce e immediata la cosa.

Questo l'uso che ne faccio io.

Ciao
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#10
Ma dai la mia era una battuta. :tongue:

In alcuni disegni di assemblaggi piuttosto complessi, mi è comodo evidenziare una o più parti con colori diversi. Con questo strumento diventa molto veloce e immediata la cosa.

Questo l'uso che ne faccio io.

Ciao
Ma poi in stampa ci va il colore che gli hai dato con la macro o quello dello stile in uso per quel tipo di spigolo?

ciao.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#11
Ma poi in stampa ci va il colore che gli hai dato con la macro o quello dello stile in uso per quel tipo di spigolo?

ciao.
La macro crea un nuovo stile con il colore scelto e lo associa al pezzo, quindi non c'è differenza dagli altri stili e si vede in stampa.

Ciao
 

Marco74

Utente Senior
Professione: Sviluppo lamiera per taglio laser, piegatura e assemblaggio
Software: Solid Edge ST9 - Autocad Mechanical 2017- Lantek
Regione: Veneto - Emilia
#12
Ma dai la mia era una battuta. :tongue:

In alcuni disegni di assemblaggi piuttosto complessi, mi è comodo evidenziare una o più parti con colori diversi. Con questo strumento diventa molto veloce e immediata la cosa.

Questo l'uso che ne faccio io.

Ciao
Sicuramente non me la sono presa....anzi, non lavorando con complessivi molto grandi non ne vedevo l'utilità immediata.....

Ciao.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#13
Peccato, non mi parte.
win Vista, S.E. v20.9
---------------------------
DraftPainter
---------------------------
Errore di run-time '-2147218608 (80040b50)':

Metodo '~' dell'oggetto '~' non riuscito
---------------------------
OK
---------------------------
Probabilmente hai usato la macro con il dft non attivato. Ho segnalato la cosa a chi l'ha sviluppata che ha provveduto ad aggiornarla inserendo anche la traduzione in italiano.

Appena ho un pò di tempo aggiorno l'allegato.

Ciao
 

a.belloni

Utente Standard
Professione: P.M. tuttofare
Software: Solid Edge
Regione: Veneto
#14
Peccato, non funziona neppure a me.
win xp sp3, S.E. v19 sp.12
---------------------------
DraftPainter
---------------------------
Errore di run-time '-2147218608 (80040b50)':
 

Leso

Utente Standard
Professione: Ufficiale tecnico
Software: Solid Edge ST9
Regione: Veneto
#15
Ho provato ad usare la macro ma ci sono problemi.
In pratica se la usa all'interno di un dft contenente la tavola di un par funziona, con un assieme no.
Edge per caso hai messo le mani su una versione aggiornata?
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#16
Ho provato ad usare la macro ma ci sono problemi.
In pratica se la usa all'interno di un dft contenente la tavola di un par funziona, con un assieme no.
Edge per caso hai messo le mani su una versione aggiornata?
Io la sto utilizzando senza problemi, anche con tavole di assiemi.

Magari postate qualcosa che ci butto un'occhio.

Ciao
 

Cast16

Utente Standard
Professione: Progettazione, Sviluppo lamiera per taglio e piega
Software: Inventor, Autocad, Solid Edge
Regione: Emilia romagna
#17
Ciao a tutti,

la macro non mi funziona più.
mi da errore. coma nel img.
Versione SE ST2.

A voi funziona?
 

Allegati