linee nascoste e importazione autocad

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#21
Tu usi dimscale o dimlfac su autocad?i tuoi disegni sono sempre in scala 1:1 e modifichi la scala del cartiglio?
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#22
comunque imposta dxf_out_drawing_scale yes sul config.pro.
sta attento però,il disegno che otterai avrà la geometria scalata in base alla scala del disegno,ma le quote saranno sempre del valore giusto.Praticamente se hai la scala 1:2 la geometria sara 1:2 nel dwg.
 

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#23
sul config è gia' impostato " yes" .

il problema e' che io salvo il drw ad esempio su scala 1:20 e sul dwg non ottengo un disegno con la stessa scala, ma con una scala differente;

quindi devo riscalare tutto.

e le scale che ottengo sul dwg sono stupide, tipo 1: 14,3...
 

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#24
e ritiro pure tutto quello che ho detto sul problema precedente; anche rifacendo i disegni non cambia nulla!su alcuni disegni non vuole darmi le linee nascoste!
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#25
ma quando lo esporti sul cartiglio nel file dwg la scala è corretta?
non è che per caso sul file che ti regola le impostazioni del drw non hai il comando
drawing_units settato su MM?!
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#26
Poresti settare intf_out_layer part_layer nel config.pro.
Se non hi particolari esigenze potrebbe andarti bene.

Crea livelli predefiniti.

Esegue la mappatura degli stili linea Pro/ENGINEER agli stili linea di AutoCAD.

Applica al disegno esportato la scala 1:1 indipendentemente dalla scala originale.

Crea blocchi per ogni campitura e tabella.

Il testo viene esportato come testo AutoCAD e non in un blocco esterno.
 

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#27
scusami forse non capisco bene cosa intendi.

il problema e' che nel passaggio da proE ad autocad non viene mantenuta la scala.

cioe' sul drw io ho scala 1:20. dopo l'importazione appena apro il .dwg ho una scala diversa.

sono settati millimetri in entrambi.



altra curiosità.--> come si fa a modificare il file dxf_export che regola il layer di autocad?

mi servirebbe in particolare cambiare il colore delle linee nascoste e impostare il formato delle quote, pero' non capisco cosa devo modificare..

grazie!:biggrin:
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#29
Hai letto Mappatura DXF-DWG?!
Devi impostare il numero del colore Autocad all'entità del pro-e.
Es. map_color HIDDEN_COLOR 1
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#31
devi crearti un file dxf_export.pro con WordPad.
Dentro ci scrivi:
map_color BACKGROUND_COLOR 0
map_color DIMMED_COLOR 4
map_color LETTER_COLOR 3
map_color HIGHLIGHT_COLOR 4
map_color EDGE_HIGHLIGHT_COLOR 7
map_color GEOMETRY_COLOR 7
map_color HIDDEN_COLOR 1
map_color SHEETMETAL_COLOR 7
map_color CURVE_COLOR 4
map_color VOLUME_COLOR 4
map_color SECTION_COLOR 7
map_color DATUM_COLOR 1

Assegnando ad ogni entità pro-e(es.DATUM_COLOR) il numero del colore autocad.

Sul config.pro indichi il percorso del file dxf_export.pro

dxf_export_mapping_file H:\.......\dxf_export.pro
 

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#32
ahhhhh ecco!!!!

belin c'ho studiato tutta la mattina...credevo che fossero impostazioni da inserire dentro il config, allo stesso modo dei flag che mi hai suggerito di cambiare...che scemo!

lollone grazie della pazienza, appena passi da genova c'hai una birra offerta!!!!
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#35
Prova a mettere sul file dxf_export.pro
map_font font arial.ttf
map_font trium arial.ttf
map_font filled arial.ttf
map_font isofont arial.ttf

La prima colonna corrispondone al font in proe la seconda a quella di acad in cui vuoi trasformarla.

Non l'ho mai provato...ma dovrebbe funzionare!
 

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#37
la scala funziona, il font e i colori non l'ho ancora provato, ma appena lo faccio ti dico se funziona o meno!

vieni a genova quando vuoi, che se non ti va la birra, ci sono sempre le trofie al pesto o la focaccia!!!
 

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#38
allora, secondo me ProE mi prende per il sedere.


ti spiego, è tornato il problema del tratteggio nelle linee nascoste: cioè anzichè essere tratteggiate sono continue.

in pratica funziona cosi:

- mantengo le stesse impostazioni che mi hai fornito e succede quqnto segue:

1- se estrapolo il .drw da un . prt, in autocad vedo tutto giusto ( linee tratteggiate e continue giuste)

2- se estrapolo il .drw da un . asm ... non funziona piu' niente ( in autocad mi compaiono solo linee continue, cioe' non distingue spigoli in vista da quelli nascosti)

cazzarola ma puo' essere possibile????:eek::confused::frown:
 

lollone

Utente Standard
Professione: Project Engineer
Software: Creo 3.0 - AutoCAD - Inventor - Solid Edge
Regione: Veneto
#39
Fammi un riepilogo delle impostazioni che hai settato per l'esportazione!
Riesci a mandarmi il tuo config.pro?
 
Ultima modifica:

fedemito

Utente Junior
Professione: disegnatore
Software: proE
Regione: liguria
#40
purtroppo qui a lavoro la mail è bloccata, ti scrivo le impostazioni che ho cambiato io:


INTF_OUT_LAYER " NONE "

INTERFACE_QUALITY " 3 "

settando solo queste due cose riesco ad ottenere dei disegni autocad corretti partendo da un file .prt proE.


ti dico anche che ho riprovato a fare il .drw dell'assemblaggio e non è cambiato nulla.

Ho provato anche ad impostare

DFX_OUT_SEP_DIM_W_BREAKS " YES " e non è cambiato nulla (quest'ultima è provata a caso: ho interpretato "breaks on witness line" come linee tratteggiate, ma evidentemente non c'entrano nulla!)