Lavora in rete o in locale?

bazzy

Utente Standard
Professione: Produttore
Software: Solid Edge
Regione: Toscana
#1
Di sicuro questo problema è già stato affrontato anni fa, mi pare di aver letto qualcosa ma fino ad oggi non ne avevo l'interesse.

Da ieri abbiamo montato un server aziendale.
Per comodità ho messo lì sopra tutti glki archivi che erano sparsi sui vari PC.

Aprendo SE mi pare però di notare un certo rallentamento, potrebbe essere causato dal server?!

insomma, secondo voi, vale la pena lasciare i file di SE sul server (maggiore comodità, backup automatici) o conviene più lavorare in locale!? (se guadagno molto in velocità, dovendo poi organizzare un sistema per trasferire i file sul server per i backup)
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#2
Di sicuro questo problema è già stato affrontato anni fa, mi pare di aver letto qualcosa ma fino ad oggi non ne avevo l'interesse.

Da ieri abbiamo montato un server aziendale.
Per comodità ho messo lì sopra tutti glki archivi che erano sparsi sui vari PC.

Aprendo SE mi pare però di notare un certo rallentamento, potrebbe essere causato dal server?!

insomma, secondo voi, vale la pena lasciare i file di SE sul server (maggiore comodità, backup automatici) o conviene più lavorare in locale!? (se guadagno molto in velocità, dovendo poi organizzare un sistema per trasferire i file sul server per i backup)
La domanda fondamentale e':
siete in piu' di uno a condividere i file e lavorare sugli stessi progetti? Esempio: parti di libreria, codici comuni fra piu' gruppi...

In tal caso: file sul server assolutamente si, per le ragioni stesse che tu hai detto.

Io lavoro con un server PII a 350 MHz e non noto grossi peggioramenti rispetto a quando sono in locale, se tu hai dei rallentamenti sensibili forse devi fare un po' di messa a punto alla rete.

Per caso sei abiutato a caricare gli assiemi con tutte le parti attive? Questo effettivamente potrebbe provocare un certo carico sulla rete, io per mio conto carico gli assembly sempre con le parti disattivate.
 

bazzy

Utente Standard
Professione: Produttore
Software: Solid Edge
Regione: Toscana
#3
La domanda fondamentale e':
siete in piu' di uno a condividere i file e lavorare sugli stessi progetti? Esempio: parti di libreria, codici comuni fra piu' gruppi...

In tal caso: file sul server assolutamente si, per le ragioni stesse che tu hai detto.

Io lavoro con un server PII a 350 MHz e non noto grossi peggioramenti rispetto a quando sono in locale, se tu hai dei rallentamenti sensibili forse devi fare un po' di messa a punto alla rete.

Per caso sei abiutato a caricare gli assiemi con tutte le parti attive? Questo effettivamente potrebbe provocare un certo carico sulla rete, io per mio conto carico gli assembly sempre con le parti disattivate.
No, una sola postazione.
Il rallentamento è stato grosso, ora (la seconda volta che apro SE da quando abbiamo messo il server) ha impiegato qualche minuto fra il comando "chiudi" e la finestra che mi chiedeva se volevo salvare...

Si, carico anche gli assiemi con le parti attive, ma, salvo alcuni casi, sono asiemi di 5/10 parti
 

Marco74

Utente Senior
Professione: Sviluppo lamiera per taglio laser, piegatura e assemblaggio
Software: Solid Edge ST9 - Autocad Mechanical 2017- Lantek
Regione: Veneto - Emilia
#4
Puoi lavorare in locale, e alla sera passare il tutto sul server....

Ciao.
 

zeigs

Utente Standard
Professione: Progettista
Software: Solid Edge
Regione: Emilia-Romagna
#5
domanda: hai passato i file che hai spostato sul server sotto l'aggiornamento dei collegamenti? se non l'hai fatto molto probabilmente ogni volta che apri un disegno in realtà non lo trova dove dovrebbe essere (sul c) e lo cerca nei vari percorsi di ricerca, finchè non li trova.
ricorda che SE usa la filosofia del percorso assoluto se non sono dentro la stessa cartella. e per i file in rete segna il nome del server, non la lettera a cui hai assegnato la risorsa
mi spiego meglio: se il tuo server si chiama "server1", e condividi la cartella "disegni" collegandola come "d:", un eventuale assieme in cui metti "d:\parte.par" viene in realtà collegato a "\\server1\disegni\parte.par"
per cui se rinomini il server in "server2" e continui a montarlo come "d:" non trova più i le parti perchè i collegamenti dovrebbero essere aggiornati a "\\server2\disegni\parte.par"
il problema è parzialmente risolto se il percorso di ricerca dei file contempla "\\server2\disegni" perchè quello che non trova lo cerca poi anche lì, ma perde molto tempo nella ricerca. aggiornando i collegamenti potresti risolvere il problema
tu non hai cambiato il nome del server, ma il problema è simile
ciao
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#6
Il peggioramento dovuto al lavorare in rete non è dovuto al trasferimento file (come molti credono), ma principalmente alle latenze che si scatenano nel momento di link interrotti, server non trovati, malfunzionamenti della rete.

E' quindi importante avere una rete affidabile e di ottima qualità.

Ciao

P.S.: se usate texture negli stili faccia e queste vengono perse, possono esserci dei grossi rallentamenti e non viene segnalato il link interrotto da nessuna parte. Ho creato un programma apposta per analizzare queste situazioni.
 

gerod

Moderatore
Staff Forum
Professione: Libero professionista
Software: Solid Edge, Ansys DS, e altri ancora
Regione: Veneto
#7
E' quindi importante avere una rete affidabile e di ottima qualità.
confermo!
Un mio cliente ha messo un server figo e una rete con i contro e lavora con SE in rete tranquillamente.
Io comunque preferisco lavorare in locale, mooolto più veloce!
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#8
No, una sola postazione.
Il rallentamento è stato grosso, ora (la seconda volta che apro SE da quando abbiamo messo il server) ha impiegato qualche minuto fra il comando "chiudi" e la finestra che mi chiedeva se volevo salvare...
E' evidente che c'e' qualche problema.

Comunque se lavori da solo anche io non vedo la necessita' del server, tanto vale tenere tutto in locale e ogni tanto salvare su un disco usb, risparmi anche parecchia corrente.
 

bazzy

Utente Standard
Professione: Produttore
Software: Solid Edge
Regione: Toscana
#9
E' evidente che c'e' qualche problema.

Comunque se lavori da solo anche io non vedo la necessita' del server, tanto vale tenere tutto in locale e ogni tanto salvare su un disco usb, risparmi anche parecchia corrente.
non hai tutti i torti.
anche se io sincronizzerei i file sul server per farli backuppare.
 

bazzy

Utente Standard
Professione: Produttore
Software: Solid Edge
Regione: Toscana
#10
domanda: hai passato i file che hai spostato sul server sotto l'aggiornamento dei collegamenti?
ecco, vedrai è questo il problema.
No, non ho ancora aggiornato i collegamenti, ho solo passato l'archivio sul server e poi ho aperto un disegno che avevod a vedere con urgenza, senza pensare ai collegamenti (non ho reimpostato neanche le cartelel predefinite...)